summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-mathematics/diagrtb/diagrtb-2.64.ebuild11
1 files changed, 7 insertions, 4 deletions
diff --git a/sci-mathematics/diagrtb/diagrtb-2.64.ebuild b/sci-mathematics/diagrtb/diagrtb-2.64.ebuild
index 1283039df7eb..27c9262aa64e 100644
--- a/sci-mathematics/diagrtb/diagrtb-2.64.ebuild
+++ b/sci-mathematics/diagrtb/diagrtb-2.64.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=4
+EAPI=6
inherit cmake-utils fortran-2
@@ -20,11 +20,14 @@ S="${WORKDIR}"/Source_RTB2011
src_prepare() {
cp "${FILESDIR}"/CMakeLists.txt . || die
+
+ cmake-utils_src_prepare
}
src_configure() {
- mycmakeargs=(
- $(cmake-utils_use examples EXAMPLES)
+ local mycmakeargs=(
+ -DEXAMPLES=$(usex examples)
)
+
cmake-utils_src_configure
}