summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-editors/vscodium/Manifest3
-rw-r--r--app-editors/vscodium/vscodium-1.80.1.23194.ebuild121
2 files changed, 124 insertions, 0 deletions
diff --git a/app-editors/vscodium/Manifest b/app-editors/vscodium/Manifest
index 800ece93c8a2..5a7fd2de1281 100644
--- a/app-editors/vscodium/Manifest
+++ b/app-editors/vscodium/Manifest
@@ -4,3 +4,6 @@ DIST vscodium-1.79.0.23159-arm64.tar.gz 120850283 BLAKE2B ab8edcf8870fe1584c508a
DIST vscodium-1.79.2.23166-amd64.tar.gz 120602785 BLAKE2B d15fcdc0f1db850275ec8f2b8e0b0ddb66373eceba788028cd33ed6e2151ad4d33b98796bf6be00822f76436499521dbd9e1e5110f1df43d924d7e7f3d8f1972 SHA512 c2e007eef22e4027d252d2a9d578390499c4d07fe41b1f69d7cb6ba856ba51e864c46ec80a6bed8f37ab1cfe20954ce3878db78ce79ab0991635417cf627c9be
DIST vscodium-1.79.2.23166-arm.tar.gz 109328791 BLAKE2B 783c854c16be3eac8ea349eaa0ed9ff509eb27191606f245232e2b51ebbc2f338eb8e758677da2ac4ba1cfface487ea38c884b7ddec519e3409df9b066f1aa9c SHA512 6067ac88ef806e784bb8dda8eb2ecd377f52f71f60356384fde1cdca6a802568dba9abefeece2853c4e3961dd98636a66fd0fc4a98131cf4cd59300da2e67377
DIST vscodium-1.79.2.23166-arm64.tar.gz 120833812 BLAKE2B f8cb53aa5faede65b62b174a48a23f6e761a737dffe86e2a92625b745856e106fd1398f68fc3b62d3c2ea5164e7f997be88b0cef735e9e718721982ffd630f09 SHA512 79f3c7e1507c0db4d93a35b207aa850d31127196c846f6479b863589634e75da68b30b1c0c5f66ba2c63201a1c4540c910f569f3152ceff523a27889b47a9eb0
+DIST vscodium-1.80.1.23194-amd64.tar.gz 120915926 BLAKE2B fad2f3146b6777ff7f78c5c4cbfb65976402c3033790a26f3cbee0f5503586fea86764c42294026a139fe8797d41aeedbf966adb2e9c86b65d77b81ef9cdb83d SHA512 4dec8a293d320eb851c7d4257df96ee46871b1314df5176f8cfbd6db1cdb492f5bf1cfe2125c2cd2e4fb69d81ebc21a380f7464857b443c72954be665b36a065
+DIST vscodium-1.80.1.23194-arm.tar.gz 109644410 BLAKE2B 90dadf201d9f753ebc05a964b9ebf9dad7f94943fccdacb3b90fac5f51bd3fd91fbf9a7c41b853ecf6527f62265b22d99f746f56fd388f1ab4968a4c365d8977 SHA512 96b75f4c065d35e4e695c8e4813d6412cfd93bae2da27bf091620ba1ca6a4161bf7805865679205b01029b92d7be647defd1a46a7a88f79a45e4b9f9907fcac6
+DIST vscodium-1.80.1.23194-arm64.tar.gz 121174305 BLAKE2B 1586eb8aaf4e62ddc1378138033b9d5985bf403f733d11e114ebfeec1f9afa5879a718e1cd1cd8f1c0344a0a8aaaf4ec33bf40c812b96fdbb6656e8fb76fa311 SHA512 eec75079306df5a5985cdabb12d2b65a51be32c2d64001adc03ac4dd172bded3c49faae6bbac8ab88e098cba7c8ceac24e74ad7cb73dd91073f01b3ba19a5265
diff --git a/app-editors/vscodium/vscodium-1.80.1.23194.ebuild b/app-editors/vscodium/vscodium-1.80.1.23194.ebuild
new file mode 100644
index 000000000000..ade568c41973
--- /dev/null
+++ b/app-editors/vscodium/vscodium-1.80.1.23194.ebuild
@@ -0,0 +1,121 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop pax-utils xdg optfeature
+
+# Usage: arch_src_uri <gentoo arch> <upstream arch>
+arch_src_uri() {
+ echo "${1}? (
+ https://github.com/VSCodium/${PN}/releases/download/${PV}/VSCodium-linux-${2}-${PV}.tar.gz
+ -> ${P}-${1}.tar.gz
+ )"
+}
+
+DESCRIPTION="A community-driven, freely-licensed binary distribution of Microsoft's VSCode"
+HOMEPAGE="https://vscodium.com/"
+SRC_URI="
+ $(arch_src_uri amd64 x64)
+ $(arch_src_uri arm armhf)
+ $(arch_src_uri arm64 arm64)
+"
+
+RESTRICT="strip bindist"
+
+LICENSE="
+ Apache-2.0
+ BSD
+ BSD-1
+ BSD-2
+ BSD-4
+ CC-BY-4.0
+ ISC
+ LGPL-2.1+
+ MIT
+ MPL-2.0
+ openssl
+ PYTHON
+ TextMate-bundle
+ Unlicense
+ UoI-NCSA
+ W3C
+"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~arm ~arm64"
+IUSE=""
+
+RDEPEND="
+ >=app-accessibility/at-spi2-core-2.46.0:2
+ app-crypt/libsecret[crypt]
+ dev-libs/expat
+ dev-libs/glib:2
+ dev-libs/nspr
+ dev-libs/nss
+ media-libs/alsa-lib
+ media-libs/mesa
+ sys-apps/util-linux
+ sys-apps/dbus
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3
+ x11-libs/libdrm
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libxkbcommon
+ x11-libs/libxkbfile
+ x11-libs/libXrandr
+ x11-libs/libxshmfence
+ x11-libs/pango
+"
+
+QA_PREBUILT="
+ /opt/vscode/bin/code-tunnel
+ /opt/vscodium/chrome_crashpad_handler
+ /opt/vscodium/chrome-sandbox
+ /opt/vscodium/codium
+ /opt/vscodium/libEGL.so
+ /opt/vscodium/libffmpeg.so
+ /opt/vscodium/libGLESv2.so
+ /opt/vscodium/libvk_swiftshader.so
+ /opt/vscodium/libvulkan.so*
+ /opt/vscodium/resources/app/extensions/*
+ /opt/vscodium/resources/app/node_modules.asar.unpacked/*
+ /opt/vscodium/swiftshader/libEGL.so
+ /opt/vscodium/swiftshader/libGLESv2.so
+"
+
+S="${WORKDIR}"
+
+src_install() {
+ # Cleanup
+ rm "${S}/resources/app/LICENSE.txt" || die
+
+ # Disable update server
+ sed -i "/updateUrl/d" "${S}"/resources/app/product.json || die
+
+ # Install
+ pax-mark m codium
+ mkdir -p "${ED}/opt/${PN}" || die
+ cp -r . "${ED}/opt/${PN}" || die
+ fperms 4711 /opt/${PN}/chrome-sandbox
+
+ dosym -r "/opt/${PN}/bin/codium" "usr/bin/vscodium"
+ dosym -r "/opt/${PN}/bin/codium" "usr/bin/codium"
+ domenu "${FILESDIR}/vscodium.desktop"
+ domenu "${FILESDIR}/vscodium-url-handler.desktop"
+ domenu "${FILESDIR}/vscodium-wayland.desktop"
+ domenu "${FILESDIR}/vscodium-url-handler-wayland.desktop"
+ newicon "resources/app/resources/linux/code.png" "vscodium.png"
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ elog "When compared to the regular VSCode, VSCodium has a few quirks"
+ elog "More information at: https://github.com/VSCodium/vscodium/blob/master/DOCS.md"
+ optfeature "keyring support inside vscode" "virtual/secret-service"
+}