summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-antivirus/clamav/files/clamav-0.101.2-tinfo.patch31
-rw-r--r--app-antivirus/clamav/files/clamav-0.102.3-system-tomsfastmath.patch113
-rw-r--r--app-antivirus/clamav/files/clamav.logrotate17
-rw-r--r--app-antivirus/clamav/files/clamd.conf9
-rw-r--r--app-antivirus/clamav/files/clamd.conf-r17
-rw-r--r--app-antivirus/clamav/files/clamd.initd-r6128
6 files changed, 0 insertions, 305 deletions
diff --git a/app-antivirus/clamav/files/clamav-0.101.2-tinfo.patch b/app-antivirus/clamav/files/clamav-0.101.2-tinfo.patch
deleted file mode 100644
index 66130be41882..000000000000
--- a/app-antivirus/clamav/files/clamav-0.101.2-tinfo.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-https://bugs.gentoo.org/670729
-
---- a/m4/reorganization/clamdtop.m4
-+++ b/m4/reorganization/clamdtop.m4
-@@ -4,12 +4,26 @@
-
- if test "$enable_clamdtop" != "no"; then
-
-+PKG_CHECK_MODULES([CURSES], [ncursesw],
-+ [CURSES_INCLUDE="<ncurses.h>";
-+ HAVE_LIBNCURSES=yes],
-+ HAVE_LIBNCURSES=no])
-+
-+if test "X$HAVE_LIBNCURSES" != "Xyes"; then
-+PKG_CHECK_MODULES([CURSES], [ncurses],
-+ [CURSES_INCLUDE="<ncurses.h>";
-+ HAVE_LIBNCURSES=yes],
-+ HAVE_LIBNCURSES=no])
-+fi
-+
-+if test "X$HAVE_LIBNCURSES" != "Xyes"; then
- AC_LIB_FIND([ncurses], [ncurses/ncurses.h],
- AC_LANG_PROGRAM([#include <ncurses/ncurses.h>],
- [initscr(); KEY_RESIZE;]),
- [CURSES_CPPFLAGS="$INCNCURSES"; CURSES_LIBS="$LTLIBNCURSES";
- CURSES_INCLUDE="<ncurses/ncurses.h>"],
- [])
-+fi
-
- if test "X$HAVE_LIBNCURSES" != "Xyes"; then
- HAVE_LIBNCURSES=
diff --git a/app-antivirus/clamav/files/clamav-0.102.3-system-tomsfastmath.patch b/app-antivirus/clamav/files/clamav-0.102.3-system-tomsfastmath.patch
deleted file mode 100644
index ee575c3b1287..000000000000
--- a/app-antivirus/clamav/files/clamav-0.102.3-system-tomsfastmath.patch
+++ /dev/null
@@ -1,113 +0,0 @@
-From bcf63fa6bbd519bc61c2b2553fb1913f802eb96e Mon Sep 17 00:00:00 2001
-From: Andreas Cadhalpun <Andreas.Cadhalpun@googlemail.com>
-Date: Wed, 11 Mar 2015 20:03:15 +0100
-Subject: add support for system tomsfastmath
-
-Patch-Name: add-support-for-system-tomsfastmath.patch
----
- configure.ac | 2 ++
- libclamav/Makefile.am | 10 ++++++++--
- libclamav/bignum.h | 6 +++++-
- libclamav/xdp.c | 2 +-
- m4/reorganization/libs/tomsfastmath.m4 | 12 ++++++++++++
- 5 files changed, 28 insertions(+), 4 deletions(-)
- create mode 100644 m4/reorganization/libs/tomsfastmath.m4
-
-diff --git a/configure.ac b/configure.ac
-index 8375971..3cacfb8 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -98,6 +98,7 @@ m4_include([m4/reorganization/libs/libmspack.m4])
- if test "x$use_internal_mspack" = "xno"; then
- mspack_msg="External, $LIBMSPACK_CFLAGS $LIBMSPACK_LIBS"
- fi
-+m4_include([m4/reorganization/libs/tomsfastmath.m4])
-
- AM_MAINTAINER_MODE
- m4_include([m4/reorganization/libs/libz.m4])
-@@ -356,6 +357,7 @@ fi
- CL_MSG_STATUS([yara ],[$enable_yara],[$enable_yara])
- CL_MSG_STATUS([fts ],[yes],[$lfs_fts_msg])
-
-+CL_MSG_STATUS([tomsfastmath],[yes],[$tomsfastmath_msg])
-
- # Yep, downgrading the compiler avoids the bug too:
- # 4.0.x, and 4.1.0 are the known buggy versions
-diff --git a/libclamav/Makefile.am b/libclamav/Makefile.am
-index 699d033..3282272 100644
---- a/libclamav/Makefile.am
-+++ b/libclamav/Makefile.am
-@@ -602,8 +602,10 @@ libclamav_la_SOURCES += yara_arena.c \
- yara_clam.h
- endif
-
--libclamav_la_SOURCES += bignum.h\
-- bignum_fast.h\
-+libclamav_la_SOURCES += bignum.h
-+
-+if !SYSTEM_TOMSFASTMATH
-+libclamav_la_SOURCES += bignum_fast.h\
- tomsfastmath/addsub/fp_add.c\
- tomsfastmath/addsub/fp_add_d.c\
- tomsfastmath/addsub/fp_addmod.c\
-@@ -685,6 +687,10 @@ libclamav_la_SOURCES += bignum.h\
- tomsfastmath/sqr/fp_sqr_comba_generic.c\
- tomsfastmath/sqr/fp_sqr_comba_small_set.c\
- tomsfastmath/sqr/fp_sqrmod.c
-+else
-+libclamav_la_CFLAGS += $(TOMSFASTMATH_CFLAGS)
-+libclamav_la_LIBADD += $(TOMSFASTMATH_LIBS)
-+endif
-
- .PHONY2: version.h.tmp
- version.c: version.h
-diff --git a/libclamav/bignum.h b/libclamav/bignum.h
-index 8fdc956..56dfa95 100644
---- a/libclamav/bignum.h
-+++ b/libclamav/bignum.h
-@@ -1,9 +1,13 @@
- #ifndef BIGNUM_H_
- #define BIGNUM_H_
-
-+#if HAVE_SYSTEM_TOMSFASTMATH
-+#include <tfm.h>
-+#else
- #define TFM_CHECK
--
- #include "bignum_fast.h"
-+#endif
-+
- typedef fp_int mp_int;
- #define mp_cmp fp_cmp
- #define mp_toradix_n(a, b, c, d) fp_toradix_n(a, b, c, d)
-diff --git a/libclamav/xdp.c b/libclamav/xdp.c
-index d5a4c4b..cc3b40d 100644
---- a/libclamav/xdp.c
-+++ b/libclamav/xdp.c
-@@ -52,7 +52,7 @@
- #include "scanners.h"
- #include "conv.h"
- #include "xdp.h"
--#include "bignum_fast.h"
-+#include "bignum.h"
- #include "filetypes.h"
-
- static char *dump_xdp(cli_ctx *ctx, const char *start, size_t sz);
-diff --git a/m4/reorganization/libs/tomsfastmath.m4 b/m4/reorganization/libs/tomsfastmath.m4
-new file mode 100644
-index 0000000..2a821a1
---- /dev/null
-+++ b/m4/reorganization/libs/tomsfastmath.m4
-@@ -0,0 +1,12 @@
-+dnl Check for system tomsfastmath
-+PKG_CHECK_MODULES([TOMSFASTMATH], [tomsfastmath], [have_system_tomsfastmath=yes], [have_system_tomsfastmath=no])
-+
-+AM_CONDITIONAL([SYSTEM_TOMSFASTMATH], [test "x$have_system_tomsfastmath" = "xyes"])
-+
-+if test "x$have_system_tomsfastmath" = "xyes"; then
-+ AC_DEFINE([HAVE_SYSTEM_TOMSFASTMATH], [1], [link against system-wide tomsfastmath library])
-+ tomsfastmath_msg="External, $TOMSFASTMATH_CFLAGS $TOMSFASTMATH_LIBS"
-+else
-+ AC_DEFINE([HAVE_SYSTEM_TOMSFASTMATH], [0], [don't link against system-wide tomsfastmath library])
-+ tomsfastmath_msg="Internal"
-+fi
diff --git a/app-antivirus/clamav/files/clamav.logrotate b/app-antivirus/clamav/files/clamav.logrotate
deleted file mode 100644
index 7a811264653b..000000000000
--- a/app-antivirus/clamav/files/clamav.logrotate
+++ /dev/null
@@ -1,17 +0,0 @@
-/var/log/clamav/clamd.log {
- su clamav clamav
- missingok
- postrotate
- /etc/init.d/clamd logfix
- /bin/kill -HUP `cat /var/run/clamav/clamd.pid 2> /dev/null` 2>/dev/null || true
- endscript
-}
-
-/var/log/clamav/freshclam.log {
- su clamav clamav
- missingok
- postrotate
- /etc/init.d/clamd logfix
- /bin/kill -HUP `cat /var/run/clamav/freshclam.pid 2> /dev/null` 2>/dev/null || true
- endscript
-}
diff --git a/app-antivirus/clamav/files/clamd.conf b/app-antivirus/clamav/files/clamd.conf
deleted file mode 100644
index ee055138074c..000000000000
--- a/app-antivirus/clamav/files/clamd.conf
+++ /dev/null
@@ -1,9 +0,0 @@
-# Config file for /etc/init.d/clamd
-
-# NOTICE: Since clamav-0.85-r1, only START_CLAMD and START_FRESHCLAM settings
-# are used, other are silently ignored
-
-START_CLAMD=yes
-START_FRESHCLAM=yes
-CLAMD_NICELEVEL=3
-FRESHCLAM_NICELEVEL=19
diff --git a/app-antivirus/clamav/files/clamd.conf-r1 b/app-antivirus/clamav/files/clamd.conf-r1
deleted file mode 100644
index de95554eea7b..000000000000
--- a/app-antivirus/clamav/files/clamd.conf-r1
+++ /dev/null
@@ -1,7 +0,0 @@
-# Config file for /etc/init.d/clamd
-
-START_CLAMD=yes
-START_FRESHCLAM=yes
-CLAMD_NICELEVEL=3
-FRESHCLAM_NICELEVEL=19
-IONICE_LEVEL=2
diff --git a/app-antivirus/clamav/files/clamd.initd-r6 b/app-antivirus/clamav/files/clamd.initd-r6
deleted file mode 100644
index 8cf8dd0a4bac..000000000000
--- a/app-antivirus/clamav/files/clamd.initd-r6
+++ /dev/null
@@ -1,128 +0,0 @@
-#!/sbin/openrc-run
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-daemon_clamd="/usr/sbin/clamd"
-daemon_freshclam="/usr/bin/freshclam"
-daemon_milter="/usr/sbin/clamav-milter"
-
-extra_commands="logfix"
-
-depend() {
- use net
- provide antivirus
-}
-
-get_config() {
- clamconf | sed 's/["=]//g' | \
- awk "{
- if(\$0==\"Config file: $1.conf\") S=1
- if(S==1&&\$0==\"\") {
- print \"$3\"
- exit
- }
- if(S==1&&\$1~\"^$2\$\") {
- print \$2!=\"disabled\"?\$2:\"$3\"
- exit
- }
- }"
-}
-
-start() {
- # populate variables and fix log file permissions
- logfix
-
- if [ "${START_CLAMD}" = "yes" ]; then
- checkpath --quiet --mode 755 \
- --owner "${clamd_user}":"${clamd_user}" \
- --directory `dirname ${clamd_socket}`
- if [ -S "${clamd_socket}" ]; then
- rm -f ${clamd_socket}
- fi
- ebegin "Starting clamd"
- start-stop-daemon --start --quiet \
- --nicelevel ${CLAMD_NICELEVEL:-0} \
- --ionice ${IONICE_LEVEL:-0} \
- --exec ${daemon_clamd}
- eend $? "Failed to start clamd"
- fi
-
- if [ "${START_FRESHCLAM}" = "yes" ]; then
- checkpath --quiet --mode 755 \
- --owner "${clamd_user}":"${clamd_user}" \
- --directory `dirname ${clamd_socket}`
- ebegin "Starting freshclam"
- start-stop-daemon --start --quiet \
- --nicelevel ${FRESHCLAM_NICELEVEL:-0} \
- --ionice ${IONICE_LEVEL:-0} \
- --exec ${daemon_freshclam} -- -d
- retcode=$?
- if [ ${retcode} = 1 ]; then
- eend 0
- einfo "Virus databases are already up to date."
- else
- eend ${retcode} "Failed to start freshclam"
- fi
- fi
-
- if [ "${START_MILTER}" = "yes" ]; then
- if [ -z "${MILTER_CONF_FILE}" ]; then
- MILTER_CONF_FILE="/etc/clamav-milter.conf"
- fi
-
- ebegin "Starting clamav-milter"
- start-stop-daemon --start --quiet \
- --nicelevel ${MILTER_NICELEVEL:-0} \
- --ionice ${IONICE_LEVEL:-0} \
- --exec ${daemon_milter} -- -c ${MILTER_CONF_FILE}
- eend $? "Failed to start clamav-milter"
- fi
-}
-
-stop() {
- if [ "${START_CLAMD}" = "yes" ]; then
- ebegin "Stopping clamd"
- start-stop-daemon --stop --quiet --name clamd
- eend $? "Failed to stop clamd"
- fi
- if [ "${START_FRESHCLAM}" = "yes" ]; then
- ebegin "Stopping freshclam"
- start-stop-daemon --stop --quiet --name freshclam
- eend $? "Failed to stop freshclam"
- fi
- if [ "${START_MILTER}" = "yes" ]; then
- ebegin "Stopping clamav-milter"
- start-stop-daemon --stop --quiet --name clamav-milter
- eend $? "Failed to stop clamav-milter"
- fi
-}
-
-logfix() {
- clamd_socket=$(get_config clamd LocalSocket /run/clamav/clamd.sock)
- clamd_user=$(get_config clamd User clamav)
- freshclam_user=$(get_config freshclam DatabaseOwner clamav)
-
- if [ "${START_CLAMD}" = "yes" ]; then
- # fix clamd log permissions
- # (might be clobbered by logrotate or something)
- local logfile=$(get_config clamd LogFile)
- if [ -n "${logfile}" ]; then
- checkpath --quiet \
- --owner "${clamd_user}":"${clamd_user}" \
- --mode 640 \
- --file ${logfile}
- fi
- fi
-
- if [ "${START_FRESHCLAM}" = "yes" ]; then
- # fix freshclam log permissions
- # (might be clobbered by logrotate or something)
- local logfile=$(get_config freshclam UpdateLogFile)
- if [ -n "${logfile}" ]; then
- checkpath --quiet \
- --owner "${freshclam_user}":"${freshclam_user}" \
- --mode 640 \
- --file ${logfile}
- fi
- fi
-}