summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ruby/metaclass/metaclass-0.0.4-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ruby/metaclass/metaclass-0.0.4-r1.ebuild b/dev-ruby/metaclass/metaclass-0.0.4-r1.ebuild
new file mode 100644
index 000000000000..7f92a7a53e09
--- /dev/null
+++ b/dev-ruby/metaclass/metaclass-0.0.4-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby25 ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="metaclass.gemspec"
+
+inherit ruby-fakegem
+SRC_URI="https://github.com/floehopper/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+DESCRIPTION="Adds a __metaclass__ method to all Ruby objects"
+HOMEPAGE="https://github.com/floehopper/metaclass"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/ s:^:#:' Rakefile test/test_helper.rb || die
+ sed -i -e 's/git ls-files/find/' -e '/\(test_files\|executables\)/ s:^:#:' ${RUBY_FAKEGEM_GEMSPEC} || die
+}