summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ros/xmlrpcpp/Manifest1
-rw-r--r--dev-ros/xmlrpcpp/metadata.xml5
-rw-r--r--dev-ros/xmlrpcpp/xmlrpcpp-1.11.14.ebuild19
-rw-r--r--dev-ros/xmlrpcpp/xmlrpcpp-9999.ebuild19
4 files changed, 44 insertions, 0 deletions
diff --git a/dev-ros/xmlrpcpp/Manifest b/dev-ros/xmlrpcpp/Manifest
new file mode 100644
index 000000000000..84bda7639707
--- /dev/null
+++ b/dev-ros/xmlrpcpp/Manifest
@@ -0,0 +1 @@
+DIST ros_comm-1.11.14.tar.gz 945041 SHA256 8e7beff35711b1918501c69cca4f29648d4d4207878edab069bcd59d515c78f3 SHA512 be768faa0a2f45c464e963934a95dc617cac6c3fcec2388602a27846774c25b882b5139099ce10d1d051a21d5938819942e079836d14618071bc7ad90ee78bab WHIRLPOOL e047ce984086655294c20dbf0715cc29f51ec358f075f02de80c5de0d4ef8059990dc8312d78d7a7fa91c4a974dc21cba15d6eacafe02fd3df527770e50f75a5
diff --git a/dev-ros/xmlrpcpp/metadata.xml b/dev-ros/xmlrpcpp/metadata.xml
new file mode 100644
index 000000000000..c42ea5b15cf6
--- /dev/null
+++ b/dev-ros/xmlrpcpp/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>
diff --git a/dev-ros/xmlrpcpp/xmlrpcpp-1.11.14.ebuild b/dev-ros/xmlrpcpp/xmlrpcpp-1.11.14.ebuild
new file mode 100644
index 000000000000..a0ae0fd21c51
--- /dev/null
+++ b/dev-ros/xmlrpcpp/xmlrpcpp-1.11.14.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=utilities/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="C++ implementation of the XML-RPC protocol"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-ros/cpp_common"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/xmlrpcpp/xmlrpcpp-9999.ebuild b/dev-ros/xmlrpcpp/xmlrpcpp-9999.ebuild
new file mode 100644
index 000000000000..a0ae0fd21c51
--- /dev/null
+++ b/dev-ros/xmlrpcpp/xmlrpcpp-9999.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=utilities/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="C++ implementation of the XML-RPC protocol"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-ros/cpp_common"
+DEPEND="${RDEPEND}"