summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-misc/beancounter/beancounter-0.8.10-r2.ebuild (renamed from app-misc/beancounter/beancounter-0.8.10-r1.ebuild)13
1 files changed, 7 insertions, 6 deletions
diff --git a/app-misc/beancounter/beancounter-0.8.10-r1.ebuild b/app-misc/beancounter/beancounter-0.8.10-r2.ebuild
index cfcb888f6d28..7435d61063e1 100644
--- a/app-misc/beancounter/beancounter-0.8.10-r1.ebuild
+++ b/app-misc/beancounter/beancounter-0.8.10-r2.ebuild
@@ -1,13 +1,13 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=8
inherit perl-module
DESCRIPTION="Finance performance calculation engine with full data acquisition, SQL support"
-HOMEPAGE="http://dirk.eddelbuettel.com/code/beancounter.html"
-SRC_URI="http://eddelbuettel.com/dirk/code/${PN}/${PN}_${PV}.tar.gz"
+HOMEPAGE="https://dirk.eddelbuettel.com/code/beancounter.html"
+SRC_URI="https://eddelbuettel.com/dirk/code/${PN}/${PN}_${PV}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
@@ -21,12 +21,13 @@ DEPEND="dev-perl/Date-Manip
mysql? ( dev-perl/DBD-mysql )
sqlite? ( dev-perl/DBD-SQLite )
postgres? ( dev-perl/DBD-Pg )"
+RDEPEND="${DEPEND}
+ dev-perl/DBI"
-RDEPEND="${DEPEND} dev-perl/DBI"
mydoc="README example.beancounterrc beancounter_*.txt "
src_install() {
perl-module_src_install
# rm unwanted READMEs
- rm "${D}"usr/share/doc/${PF}/{README.Debian,README.non-gnu} || die
+ rm "${ED}"/usr/share/doc/${PF}/{README.Debian,README.non-gnu} || die
}