summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www-apps/klaus/Manifest1
-rw-r--r--www-apps/klaus/klaus-0.8.0.ebuild27
-rw-r--r--www-apps/klaus/metadata.xml18
3 files changed, 46 insertions, 0 deletions
diff --git a/www-apps/klaus/Manifest b/www-apps/klaus/Manifest
new file mode 100644
index 000000000000..1194285d18b4
--- /dev/null
+++ b/www-apps/klaus/Manifest
@@ -0,0 +1 @@
+DIST klaus-0.8.0.tar.gz 34896 SHA256 233ae0f75b6e2e9414c3ad53c1332c9ba8cb80f4ed8a96fffe0408cdbca4fec2 SHA512 6c5407705d3b81761cdeac17e680392b872c4211f6220e3130953aaf980a36417cddc1aa78d34ee7b25a68ccb1d6c8eff6f2c7d0a17c80fe26c24bf0d67198c8 WHIRLPOOL 941d3db4ad404efd61ac959c81baef4e4ebda786415258810beff4e3736613ec2c84f11c745dd75be0bcd36e22e87416e63ebc2e26eb45cb39d7c0704876659a
diff --git a/www-apps/klaus/klaus-0.8.0.ebuild b/www-apps/klaus/klaus-0.8.0.ebuild
new file mode 100644
index 000000000000..08b9749f3351
--- /dev/null
+++ b/www-apps/klaus/klaus-0.8.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="A simple, easy-to-set-up Git web viewer"
+HOMEPAGE="https://github.com/jonashaag/klaus/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ >=dev-python/dulwich-0.12.0[${PYTHON_USEDEP}]
+ dev-python/httpauth[${PYTHON_USEDEP}]
+ dev-python/humanize[${PYTHON_USEDEP}]
+"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
diff --git a/www-apps/klaus/metadata.xml b/www-apps/klaus/metadata.xml
new file mode 100644
index 000000000000..a262c89828e1
--- /dev/null
+++ b/www-apps/klaus/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>sautier.louis@gmail.com</email>
+ <name>Louis Sautier</name>
+ <description>Proxied maintainer; set to assignee in all bugs</description>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">klaus</remote-id>
+ <remote-id type="github">jonashaag/klaus</remote-id>
+ <bugs-to>https://github.com/jonashaag/klaus/issues</bugs-to>
+ </upstream>
+</pkgmetadata>