summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-action/atanks/atanks-6.4-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/games-action/atanks/atanks-6.4-r1.ebuild b/games-action/atanks/atanks-6.4-r1.ebuild
new file mode 100644
index 000000000000..a9bad0dad69f
--- /dev/null
+++ b/games-action/atanks/atanks-6.4-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils gnome2-utils
+
+DESCRIPTION="Worms and Scorched Earth-like game"
+HOMEPAGE="http://atanks.sourceforge.net/"
+SRC_URI="mirror://sourceforge/atanks/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="media-libs/allegro:0[X]"
+RDEPEND=${DEPEND}
+
+src_compile() {
+ emake \
+ INSTALLDIR="/usr/share/${PN}"
+}
+
+src_install() {
+ dobin ${PN}
+ insinto /usr/share/${PN}
+ doins -r button misc missile sound stock tank tankgun text title unicode.dat *.txt
+ doicon -s 48 ${PN}.png
+ make_desktop_entry atanks "Atomic Tanks"
+ dodoc Changelog README TODO
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}