summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-analyzer/gspoof/files/gspoof-3.2-icon.patch8
-rw-r--r--net-analyzer/gspoof/files/gspoof-3.2-libdir.patch17
-rw-r--r--net-analyzer/gspoof/gspoof-3.2-r3.ebuild43
3 files changed, 64 insertions, 4 deletions
diff --git a/net-analyzer/gspoof/files/gspoof-3.2-icon.patch b/net-analyzer/gspoof/files/gspoof-3.2-icon.patch
index df13a08677db..863049e0d2c7 100644
--- a/net-analyzer/gspoof/files/gspoof-3.2-icon.patch
+++ b/net-analyzer/gspoof/files/gspoof-3.2-icon.patch
@@ -1,7 +1,7 @@
Fix icon path and name.
---- gtk.c
-+++ gtk.c
+--- a/gtk.c
++++ b/gtk.c
@@ -24,9 +24,7 @@
gtk_set_locale ();
gtk_init (&_argc, &_argv);
@@ -13,8 +13,8 @@ Fix icon path and name.
MainWin = create_MainWin();
---- interface.c
-+++ interface.c
+--- a/interface.c
++++ b/interface.c
@@ -102,7 +102,7 @@
gtk_widget_set_size_request (MainWin, 640, 480);
gtk_window_set_title (GTK_WINDOW (MainWin), BANNER);
diff --git a/net-analyzer/gspoof/files/gspoof-3.2-libdir.patch b/net-analyzer/gspoof/files/gspoof-3.2-libdir.patch
new file mode 100644
index 000000000000..67674c2f5155
--- /dev/null
+++ b/net-analyzer/gspoof/files/gspoof-3.2-libdir.patch
@@ -0,0 +1,17 @@
+Don't assume that $(libdir) is lib. Rely on linker defaults instead.
+--- a/configure.ac
++++ b/configure.ac
+@@ -55,13 +55,6 @@ AC_ARG_WITH([libnet-prefix],
+ [ LIBNET_PREFIX=$withval ],
+ [ LIBNET_PREFIX=/usr ])
+
+-AC_CHECK_FILE([$LIBNET_PREFIX/lib/libnet.a],
+- [LDFLAGS="-L$LIBNET_PREFIX/lib"
+- CPPFLAGS="-I$LIBNET_PREFIX/include" ],
+- AC_MSG_ERROR([
+-Libnet-1.1.1 Packet Shaping Library is required!
+-Verify to have installed it and pass --with-libnet-prefix to configure.
+-Or download it from http://www.packetfactory.net/libnet ]))
+
+ AC_CHECK_LIB(net, libnet_name2addr4,,
+ AC_MSG_ERROR([
diff --git a/net-analyzer/gspoof/gspoof-3.2-r3.ebuild b/net-analyzer/gspoof/gspoof-3.2-r3.ebuild
new file mode 100644
index 000000000000..938a95c5179a
--- /dev/null
+++ b/net-analyzer/gspoof/gspoof-3.2-r3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools eutils
+
+DESCRIPTION="A simple GTK/command line TCP/IP packet generator"
+HOMEPAGE="http://gspoof.sourceforge.net/"
+SRC_URI="http://gspoof.sourceforge.net/src/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE=""
+
+DEPEND="
+ x11-libs/gtk+:2
+ dev-libs/glib:2
+ net-libs/libnet:1.1
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-def-values.patch
+ "${FILESDIR}"/${P}-icon.patch
+ "${FILESDIR}"/${PN}-3.2-libdir.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ dobin gspoof
+ newicon pixmap/icon.png ${PN}.png
+ dodoc README CHANGELOG TODO
+}