summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-p2p/pybitmessage/Manifest1
-rw-r--r--net-p2p/pybitmessage/pybitmessage-0.4.2.ebuild73
2 files changed, 0 insertions, 74 deletions
diff --git a/net-p2p/pybitmessage/Manifest b/net-p2p/pybitmessage/Manifest
index bcf46b4adec8..f070c51d948d 100644
--- a/net-p2p/pybitmessage/Manifest
+++ b/net-p2p/pybitmessage/Manifest
@@ -1,2 +1 @@
-DIST pybitmessage-0.4.2.tar.gz 547565 BLAKE2B 8cb7bc0407601f06c5d0040fa03372e95c34e21aed79021001f7067b3340c60a08f7ab7d2c6578e78e1f7bf09a5adc5805252a27cf8e1bda27de6d1495382e35 SHA512 5e783243db4f507ec221092f6da18d25bb15a8c83f28aab7c1796a063d2608c0115c9d636cc73b66a09264a4ff69dda9ba373eff81640b1dd9595100dcdc4917
DIST pybitmessage-0.6.3.2_p20180521.tar.gz 1102349 BLAKE2B 346834ba6a6f7805ad79e95137b922b74963dd2c9da1b978e6e161be1e82b8465443ba1de255a6ab3c909c7ee1328509123eaf129dbafa13ec8c0d9f8291c93b SHA512 ef7e64e67cd6438fea1835db26c6ab71af004e1f6a7fb2cb8681674024a1addaeef1a31d959b1f0d3e502d8b96b3c07c6b6e0840e86dff12768ecd36e4fdf026
diff --git a/net-p2p/pybitmessage/pybitmessage-0.4.2.ebuild b/net-p2p/pybitmessage/pybitmessage-0.4.2.ebuild
deleted file mode 100644
index b9c9b12407d1..000000000000
--- a/net-p2p/pybitmessage/pybitmessage-0.4.2.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-PYTHON_REQ_USE="sqlite"
-
-inherit eutils python-r1 gnome2-utils
-
-DESCRIPTION="P2P communications protocol"
-HOMEPAGE="https://bitmessage.org"
-SRC_URI="https://github.com/Bitmessage/PyBitmessage/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE=""
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-DEPEND="${PYTHON_DEPS}"
-RDEPEND="${DEPEND}
- dev-libs/openssl[-bindist]
- dev-python/PyQt4[${PYTHON_USEDEP}]"
-
-S=${WORKDIR}/PyBitmessage-${PV}
-
-src_compile() { :; }
-
-src_install () {
- cat >> "${T}"/${PN}-wrapper <<-EOF
- #!/usr/bin/env python
- import os
- import sys
- sys.path.append("@SITEDIR@")
- os.chdir("@SITEDIR@")
- os.execl('@PYTHON@', '@EPYTHON@', '@SITEDIR@/bitmessagemain.py')
- EOF
-
- touch src/__init__.py || die
-
- install_python() {
- python_moduleinto ${PN}
- python_domodule src/*
- sed \
- -e "s#@SITEDIR@#$(python_get_sitedir)/${PN}#" \
- -e "s#@EPYTHON@#${EPYTHON}#" \
- -e "s#@PYTHON@#${PYTHON}#" \
- "${T}"/${PN}-wrapper > ${PN} || die
- python_doscript ${PN}
- }
-
- python_foreach_impl install_python
-
- dodoc README.md debian/changelog
- doman man/*
-
- newicon -s 24 desktop/icon24.png ${PN}.png
- newicon -s scalable desktop/can-icon.svg ${PN}.svg
- domenu desktop/${PN}.desktop
-}
-
-pkg_preinst() {
- gnome2_icon_savelist
-}
-
-pkg_postinst() {
- gnome2_icon_cache_update
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update
-}