summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-devel/make/Manifest1
-rw-r--r--sys-devel/make/files/make-4.0-char-cast.patch46
-rw-r--r--sys-devel/make/make-4.0-r1.ebuild46
3 files changed, 0 insertions, 93 deletions
diff --git a/sys-devel/make/Manifest b/sys-devel/make/Manifest
index ca6cf7d048ba..a83ec28d8dc7 100644
--- a/sys-devel/make/Manifest
+++ b/sys-devel/make/Manifest
@@ -1,3 +1,2 @@
-DIST make-4.0.tar.bz2 1341927 BLAKE2B 84cef70a3611da0172610f083ba18f87317c6bf89a71e53ebd7ed6881a6bc1c81897167cdd9dc09ba4754479b6337c746eb2716b2925aeae7d6488a3c1a81771 SHA512 82de265963cd08701491e02a4917cd2097762657257a9508119e5847050d0cb15580c163159463e822860435c5910190677d8e4aba644ba75df2895f26117376
DIST make-4.1.tar.bz2 1327342 BLAKE2B 4a93f893d219e2ac16a87f19de018f1d794a1f4c70c2a57dea52ccaa452b288bfbea0e422a880efcb457f666f41a40913a214e0feae4cc7edcebb8ec945bd72c SHA512 3fcaf06660b7a5019937b81ee69fe54cdfe0a24d66286fc5cc6a34fa996d76dfe6fd5bc49ee59b727ae2b24ddca261ada0fdb5873ba2b38dcc63647ad3cdb193
DIST make-4.2.1.tar.bz2 1407126 BLAKE2B fa6d43f5fd46182182a296c58dcd138a1a4568104eda760bbb3c241c023dee216789cf3128e5ac2b416cec76e1ba82d5b5e7852da12e86138a7d0865c85a42b4 SHA512 9cf00869a2f938492554f71d8cb288b5b009b3bd0489ef164f2c8f6532fc37db5c7e20af1dea288536e7c9710ee0bc6e1ddcdfc4928a8540e6e43661741825b8
diff --git a/sys-devel/make/files/make-4.0-char-cast.patch b/sys-devel/make/files/make-4.0-char-cast.patch
deleted file mode 100644
index 129f54092047..000000000000
--- a/sys-devel/make/files/make-4.0-char-cast.patch
+++ /dev/null
@@ -1,46 +0,0 @@
-https://savannah.gnu.org/bugs/?40371
-http://git.savannah.gnu.org/cgit/make.git/commit/?id=9d58570c
-
-From 9d58570c77240fed53d1f88217877f8e778f4bb2 Mon Sep 17 00:00:00 2001
-From: Paul Smith <psmith@gnu.org>
-Date: Sat, 26 Oct 2013 04:10:17 +0000
-Subject: * makeint.h (STOP_SET): [SV 40371] Cast to unsigned char.
-
-* tests/scripts/misc/utf8: Test variable names with characters >127.
-Fix suggested by Robert Bogomip <bob.bogo@milohedge.com>
----
-diff --git a/makeint.h b/makeint.h
-index 77f51e0..c591427 100644
---- a/makeint.h
-+++ b/makeint.h
-@@ -415,7 +415,7 @@ extern int unixy_shell;
- # define MAP_VMSCOMMA 0x0000
- #endif
-
--#define STOP_SET(_v,_m) ANY_SET (stopchar_map[(int)(_v)],(_m))
-+#define STOP_SET(_v,_m) ANY_SET (stopchar_map[(unsigned char)(_v)],(_m))
-
- #if defined(HAVE_SYS_RESOURCE_H) && defined(HAVE_GETRLIMIT) && defined(HAVE_SETRLIMIT)
- # define SET_STACK_SIZE
-diff --git a/tests/scripts/misc/utf8 b/tests/scripts/misc/utf8
-new file mode 100644
-index 0000000..2adcd07
---- a/dev/null
-+++ b/tests/scripts/misc/utf8
-@@ -0,0 +1,14 @@
-+# -*-perl-*-
-+$description = "Test utf8 handling.";
-+
-+$details = "";
-+
-+# Variable names containing UTF8 characters
-+run_make_test("
-+\xe2\x96\xaa := hello
-+\$(info \$(\xe2\x96\xaa))
-+all:
-+",
-+ '', "hello\n#MAKE#: Nothing to be done for 'all'.");
-+
-+1;
---
-cgit v0.9.0.2
diff --git a/sys-devel/make/make-4.0-r1.ebuild b/sys-devel/make/make-4.0-r1.ebuild
deleted file mode 100644
index 57aea69cf2cc..000000000000
--- a/sys-devel/make/make-4.0-r1.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=4
-
-inherit flag-o-matic eutils
-
-DESCRIPTION="Standard tool to compile source trees"
-HOMEPAGE="https://www.gnu.org/software/make/make.html"
-SRC_URI="mirror://gnu//make/${P}.tar.bz2"
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="guile nls static"
-
-CDEPEND="guile? ( >=dev-scheme/guile-1.8 )"
-DEPEND="${CDEPEND}
- nls? ( sys-devel/gettext )"
-RDEPEND="${CDEPEND}
- nls? ( virtual/libintl )"
-
-src_prepare() {
- epatch \
- "${FILESDIR}"/${PN}-3.82-darwin-library_search-dylib.patch \
- "${FILESDIR}"/${P}-char-cast.patch
-}
-
-src_configure() {
- use static && append-ldflags -static
- econf \
- --program-prefix=g \
- $(use_with guile) \
- $(use_enable nls)
-}
-
-src_install() {
- emake DESTDIR="${D}" install
- dodoc AUTHORS ChangeLog NEWS README*
- if [[ ${USERLAND} == "GNU" ]] ; then
- # we install everywhere as 'gmake' but on GNU systems,
- # symlink 'make' to 'gmake'
- dosym gmake /usr/bin/make
- dosym gmake.1 /usr/share/man/man1/make.1
- fi
-}