summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-analyzer/linkchecker/Manifest1
-rw-r--r--net-analyzer/linkchecker/linkchecker-10.2.1.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/net-analyzer/linkchecker/Manifest b/net-analyzer/linkchecker/Manifest
index 58c60aa4d639..a575a4184c68 100644
--- a/net-analyzer/linkchecker/Manifest
+++ b/net-analyzer/linkchecker/Manifest
@@ -1 +1,2 @@
+DIST LinkChecker-10.2.1.tar.gz 545530 BLAKE2B ddbf22d9cdd04d89257b92d032cff24e4dde866b4be115f7b5b878bf2a42dd08159eef451b33ed621d747f06dffa445f4258975b932e5ae0eb8b79cfb8203549 SHA512 6410aff11e94cbf001979a85dd41e50daaa6a3577689d4256a0a5627a29253baef24ed7739dbafe91f58c0841923ac3094aa558e91f34629e3e6c008e461230a
DIST linkchecker-10.1.0.tar.gz 521214 BLAKE2B 767c1176751a2011e0e175eb7c9e7b3704bda0d469bad7b38ac1481db62b470fbb69a62bf11316699e15fd1ca822f801a1237c798754353aba5c559ccd9d3274 SHA512 a6ba57ef9c617ece2c53d54cf460571561bfa60831e038e31e520e7fbee789566616b6e5b0b98529376510ef4e228bebdb6e6e011fb986b74d837ebc69323085
diff --git a/net-analyzer/linkchecker/linkchecker-10.2.1.ebuild b/net-analyzer/linkchecker/linkchecker-10.2.1.ebuild
new file mode 100644
index 000000000000..eba67d15c6a4
--- /dev/null
+++ b/net-analyzer/linkchecker/linkchecker-10.2.1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_REQ_USE="sqlite?"
+DISTUTILS_USE_PEP517=hatchling
+DISTUTILS_SINGLE_IMPL=1
+
+inherit bash-completion-r1 distutils-r1 multiprocessing optfeature
+
+DESCRIPTION="Check websites for broken links"
+HOMEPAGE="https://github.com/linkcheck/linkchecker"
+SRC_URI="https://github.com/linkchecker/linkchecker/releases/download/v${PV}/LinkChecker-${PV}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="sqlite"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/dnspython[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ ')
+"
+BDEPEND="
+ test? (
+ $(python_gen_cond_dep '
+ app-text/pdfminer[${PYTHON_USEDEP}]
+ dev-python/parameterized[${PYTHON_USEDEP}]
+ dev-python/pyftpdlib[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ ')
+ )
+"
+
+distutils_enable_tests pytest
+
+PATCHES=( "${FILESDIR}/${PN}-9.3-bash-completion.patch" )
+
+DOCS=(
+ doc/changelog.txt
+ doc/upgrading.txt
+)
+
+python_test() {
+ # Telnet test uses miniboa which is not available in Gentoo
+ rm -f tests/checker/test_telnet.py
+ # Multiple warnings about unclosed test sockets with epytest
+ pytest -vra -n "$(makeopts_jobs)"|| die
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ newbashcomp config/linkchecker-completion ${PN}
+}
+
+pkg_postinst() {
+ optfeature "Virus scanning" app-antivirus/clamav
+ optfeature "Check links in PDF files" app-text/pdfminer
+ optfeature "bash-completion support" dev-python/argcomplete
+}