summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-print/cups-pk-helper/cups-pk-helper-0.2.6-r1.ebuild (renamed from net-print/cups-pk-helper/cups-pk-helper-0.2.6.ebuild)16
1 files changed, 7 insertions, 9 deletions
diff --git a/net-print/cups-pk-helper/cups-pk-helper-0.2.6.ebuild b/net-print/cups-pk-helper/cups-pk-helper-0.2.6-r1.ebuild
index ed7774e538cc..39719a8af2cb 100644
--- a/net-print/cups-pk-helper/cups-pk-helper-0.2.6.ebuild
+++ b/net-print/cups-pk-helper/cups-pk-helper-0.2.6-r1.ebuild
@@ -1,8 +1,7 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
-GCONF_DEBUG="no"
+EAPI=8
inherit gnome2
@@ -13,28 +12,27 @@ SRC_URI="https://www.freedesktop.org/software/${PN}/releases/${P}.tar.xz"
LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~alpha amd64 ~arm arm64 ~ia64 ppc ppc64 ~riscv ~sparc x86"
-IUSE=""
# Require {glib,gdbus-codegen}-2.30.0 due to GDBus changes between 2.29.92
# and 2.30.0
-COMMON_DEPEND="
+DEPEND="
>=dev-libs/glib-2.30.0:2
net-print/cups
>=sys-auth/polkit-0.97
"
-RDEPEND="${COMMON_DEPEND}
+RDEPEND="${DEPEND}
sys-apps/dbus
"
-DEPEND="${COMMON_DEPEND}
+BDEPEND="
>=dev-util/gdbus-codegen-2.30.0
>=dev-util/intltool-0.40.6
virtual/pkgconfig
sys-devel/gettext
"
-src_prepare() {
- DOCS="AUTHORS HACKING NEWS README"
+DOCS=( AUTHORS HACKING NEWS README )
+src_prepare() {
# Regenerate dbus-codegen files to fix build with glib-2.30.x; bug #410773
rm -v src/cph-iface-mechanism.{c,h} || die