summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-lang/crystal/crystal-0.27.0.ebuild2
-rw-r--r--dev-lang/crystal/files/crystal-0.27.0-gentoo-tests-long-unix-2.patch13
-rw-r--r--dev-lang/crystal/files/crystal-0.27.0-tcp-server-test.patch12
3 files changed, 27 insertions, 0 deletions
diff --git a/dev-lang/crystal/crystal-0.27.0.ebuild b/dev-lang/crystal/crystal-0.27.0.ebuild
index 763582835a2d..cb040059d964 100644
--- a/dev-lang/crystal/crystal-0.27.0.ebuild
+++ b/dev-lang/crystal/crystal-0.27.0.ebuild
@@ -47,6 +47,8 @@ PATCHES=(
"${FILESDIR}"/${PN}-0.27.0-max-age-0-test.patch
"${FILESDIR}"/${PN}-0.27.0-gentoo-tests-network-sandbox.patch
"${FILESDIR}"/${PN}-0.27.0-gentoo-tests-long-unix.patch
+ "${FILESDIR}"/${PN}-0.27.0-gentoo-tests-long-unix-2.patch
+ "${FILESDIR}"/${PN}-0.27.0-tcp-server-test.patch
)
src_prepare() {
diff --git a/dev-lang/crystal/files/crystal-0.27.0-gentoo-tests-long-unix-2.patch b/dev-lang/crystal/files/crystal-0.27.0-gentoo-tests-long-unix-2.patch
new file mode 100644
index 000000000000..61cec14afcbc
--- /dev/null
+++ b/dev-lang/crystal/files/crystal-0.27.0-gentoo-tests-long-unix-2.patch
@@ -0,0 +1,13 @@
+--- a/spec/std/socket/unix_socket_spec.cr
++++ b/spec/std/socket/unix_socket_spec.cr
+@@ -37,7 +37,9 @@ describe UNIXSocket do
+ end
+ end
+
+- it "sync flag after accept" do
++ # On large non-standard temp paths the test fails as:
++ # Path size exceeds the maximum size of 107 bytes
++ pending "sync flag after accept" do
+ with_tempfile("unix_socket-accept.sock") do |path|
+ UNIXServer.open(path) do |server|
+ UNIXSocket.open(path) do |client|
diff --git a/dev-lang/crystal/files/crystal-0.27.0-tcp-server-test.patch b/dev-lang/crystal/files/crystal-0.27.0-tcp-server-test.patch
new file mode 100644
index 000000000000..8f61c8aeef47
--- /dev/null
+++ b/dev-lang/crystal/files/crystal-0.27.0-tcp-server-test.patch
@@ -0,0 +1,12 @@
+--- a/spec/std/http/server/server_spec.cr
++++ b/spec/std/http/server/server_spec.cr
+@@ -524,7 +524,8 @@ module HTTP
+ end
+
+ describe "#close" do
+- it "closes gracefully" do
++ # fails under gentoo's sandbox
++ pending "closes gracefully" do
+ server = Server.new do |context|
+ context.response.flush
+ context.response.puts "foo"