summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-admin/consul/Manifest2
-rw-r--r--app-admin/consul/consul-1.4.4-r1.ebuild69
-rw-r--r--app-admin/consul/consul-1.6.0.ebuild74
3 files changed, 0 insertions, 145 deletions
diff --git a/app-admin/consul/Manifest b/app-admin/consul/Manifest
index 246b22c435ac..3e09147cca03 100644
--- a/app-admin/consul/Manifest
+++ b/app-admin/consul/Manifest
@@ -1,4 +1,2 @@
-DIST consul-1.4.4.tar.gz 22736827 BLAKE2B a1b973a303f77d84993e4879aa92072d4f2d36353683cf9a2c6cdeaded8587e8464f066168f190f7347f6038df28b3cba1d8b8a3ca0b700ee085019af5014966 SHA512 d3e5dd536726976b705fe4c78c67eaf345b8f47225919c0ca1609d75e74343d9a16d893ef4cd5140998f23b3149cfa60f5b432ed9a7251bb3b232be9b65e7241
DIST consul-1.5.3.tar.gz 21743194 BLAKE2B c797b04457c5f0b12f06732a94038b25367b53a9e6088d725eea61786a0e18bd905ad680bc12c4bfa30b44292d2676689dd6f18e9e2143bf6e1b02c2c55f678f SHA512 3f275ec160b9e583b81ba8d463fdb05e9fc9058db2453d9393a56b67337ea04df98a89225323192230938e1abfb48fa60fe0a32b4d8980573b749217b69933e9
-DIST consul-1.6.0.tar.gz 22465984 BLAKE2B 3a030619786e8dabdf8b778012a80ff4b0e76ede6c313b688bf04bfd1a8488bff1bbd4a36c1dd11496bd1942f7bba2a9bb22ae3b364fee4335adfb741756dd67 SHA512 a122892693e3bee0fc0e0b5c0945e4a8dddb890228c091112e0db11a8afd33430611c20ff9bc13d2b3a2ac0d3b560be2d9c4e03a9cc425983fbd8f7edb699658
DIST consul-1.6.1.tar.gz 22621651 BLAKE2B b696823d3f7f3ef135ba578f3c4ae76f78a1f172e083a3bb5cd07212b3907aefbac3fc0a1d68c5d494e7781cb84c686e2cfb1e5f7cd2d34f8bf671be84b3ca00 SHA512 c96855f3a344699580e34d6f45efe863ba4e6b23ef0889a22ee89bad8ffa807b3cec1a9d14604a340b16b0a8df8227c9eeacd507f94e4a19b25e0385ca5155ac
diff --git a/app-admin/consul/consul-1.4.4-r1.ebuild b/app-admin/consul/consul-1.4.4-r1.ebuild
deleted file mode 100644
index d2c2ea9df0ba..000000000000
--- a/app-admin/consul/consul-1.4.4-r1.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit golang-vcs-snapshot systemd user
-GIT_COMMIT="ea5210a"
-KEYWORDS="~amd64"
-EGO_PN="github.com/hashicorp/consul"
-DESCRIPTION="A tool for service discovery, monitoring and configuration"
-HOMEPAGE="https://www.consul.io"
-SRC_URI="https://github.com/hashicorp/consul/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-SLOT="0"
-LICENSE="MPL-2.0 Apache-2.0 BSD BSD-2 CC0-1.0 ISC MIT"
-IUSE=""
-
-RESTRICT="test"
-
-DEPEND="dev-go/gox
- >=dev-lang/go-1.11:=
- >=dev-go/go-tools-0_pre20160121"
-RDEPEND=""
-
-pkg_setup() {
- enewgroup consul
- enewuser consul -1 -1 /var/lib/${PN} consul
-}
-
-src_prepare() {
- default
-
- sed -e 's:go get -u -v $(GOTOOLS)::' \
- -e 's:vendorfmt dev-build:dev-build:' \
- -i "src/${EGO_PN}/GNUmakefile" || die
-}
-
-src_compile() {
- # The dev target sets causes build.sh to set appropriate XC_OS
- # and XC_ARCH, and skips generation of an unused zip file,
- # avoiding a dependency on app-arch/zip.
- GOPATH="${S}" \
- GOBIN="${S}/bin" \
- GIT_DESCRIBE="v${PV}" \
- GIT_DIRTY="" \
- GIT_COMMIT="${GIT_COMMIT}" \
- emake -C "src/${EGO_PN}" dev-build
-}
-
-src_install() {
- local x
-
- dobin bin/consul
-
- keepdir /etc/consul.d
- insinto /etc/consul.d
- doins "${FILESDIR}/"*.json.example
-
- for x in /var/{lib,log}/${PN}; do
- keepdir "${x}"
- fowners consul:consul "${x}"
- done
-
- newinitd "${FILESDIR}/consul.initd" "${PN}"
- newconfd "${FILESDIR}/consul.confd" "${PN}"
- insinto /etc/logrotate.d
- newins "${FILESDIR}/${PN}.logrotated" "${PN}"
- systemd_dounit "${FILESDIR}/consul.service"
-}
diff --git a/app-admin/consul/consul-1.6.0.ebuild b/app-admin/consul/consul-1.6.0.ebuild
deleted file mode 100644
index 91013647ce8f..000000000000
--- a/app-admin/consul/consul-1.6.0.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit golang-vcs-snapshot systemd user
-GIT_COMMIT="944cc71"
-KEYWORDS="~amd64"
-EGO_PN="github.com/hashicorp/consul"
-DESCRIPTION="A tool for service discovery, monitoring and configuration"
-HOMEPAGE="https://www.consul.io"
-SRC_URI="https://github.com/hashicorp/consul/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-SLOT="0"
-LICENSE="MPL-2.0 Apache-2.0 BSD BSD-2 CC0-1.0 ISC MIT"
-IUSE=""
-
-RESTRICT="test"
-
-DEPEND="dev-go/gox
- >=dev-lang/go-1.11:=
- >=dev-go/go-tools-0_pre20160121"
-RDEPEND=""
-
-pkg_setup() {
- enewgroup consul
- enewuser consul -1 -1 /var/lib/${PN} consul
-}
-
-src_prepare() {
- default
-
- # avoid network-sandbox violations since go-1.13
- rm src/${EGO_PN}/go.mod || die
- grep -rlZ '_ "github.com/envoyproxy/protoc-gen-validate/validate"' . | \
- xargs -0 sed -i '/_ "github.com\/envoyproxy\/protoc-gen-validate\/validate"/d' || die
-
- sed -e 's:go get -u -v $(GOTOOLS)::' \
- -e 's:vendorfmt dev-build:dev-build:' \
- -i "src/${EGO_PN}/GNUmakefile" || die
-}
-
-src_compile() {
- # The dev target sets causes build.sh to set appropriate XC_OS
- # and XC_ARCH, and skips generation of an unused zip file,
- # avoiding a dependency on app-arch/zip.
- GOPATH="${S}" \
- GOBIN="${S}/bin" \
- GIT_DESCRIBE="v${PV}" \
- GIT_DIRTY="" \
- GIT_COMMIT="${GIT_COMMIT}" \
- emake -C "src/${EGO_PN}" dev-build
-}
-
-src_install() {
- local x
-
- dobin bin/consul
-
- keepdir /etc/consul.d
- insinto /etc/consul.d
- doins "${FILESDIR}/"*.json.example
-
- for x in /var/{lib,log}/${PN}; do
- keepdir "${x}"
- fowners consul:consul "${x}"
- done
-
- newinitd "${FILESDIR}/consul.initd" "${PN}"
- newconfd "${FILESDIR}/consul.confd" "${PN}"
- insinto /etc/logrotate.d
- newins "${FILESDIR}/${PN}.logrotated" "${PN}"
- systemd_dounit "${FILESDIR}/consul.service"
-}