summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-auth/seatd/seatd-0.4.0-r1.ebuild (renamed from sys-auth/seatd/seatd-0.4.0.ebuild)4
-rw-r--r--sys-auth/seatd/seatd-9999.ebuild3
2 files changed, 4 insertions, 3 deletions
diff --git a/sys-auth/seatd/seatd-0.4.0.ebuild b/sys-auth/seatd/seatd-0.4.0-r1.ebuild
index 06bf3fce1be6..ab311a6c5986 100644
--- a/sys-auth/seatd/seatd-0.4.0.ebuild
+++ b/sys-auth/seatd/seatd-0.4.0-r1.ebuild
@@ -3,13 +3,12 @@
EAPI=7
-inherit meson
+inherit meson systemd
DESCRIPTION="Minimal seat management daemon and universal library"
HOMEPAGE="https://sr.ht/~kennylevinsen/seatd"
if [[ ${PV} == 9999 ]]; then
inherit git-r3
-
EGIT_REPO_URI="https://git.sr.ht/~kennylevinsen/seatd"
else
KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
@@ -45,4 +44,5 @@ src_configure() {
src_install() {
meson_src_install
newinitd "${FILESDIR}/seatd.initd" seatd
+ systemd_dounit contrib/systemd/seatd.service
}
diff --git a/sys-auth/seatd/seatd-9999.ebuild b/sys-auth/seatd/seatd-9999.ebuild
index 3d89eb8e867b..ab311a6c5986 100644
--- a/sys-auth/seatd/seatd-9999.ebuild
+++ b/sys-auth/seatd/seatd-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit meson
+inherit meson systemd
DESCRIPTION="Minimal seat management daemon and universal library"
HOMEPAGE="https://sr.ht/~kennylevinsen/seatd"
@@ -44,4 +44,5 @@ src_configure() {
src_install() {
meson_src_install
newinitd "${FILESDIR}/seatd.initd" seatd
+ systemd_dounit contrib/systemd/seatd.service
}