summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ml/postgresql-ocaml/Manifest1
-rw-r--r--dev-ml/postgresql-ocaml/postgresql-ocaml-3.2.2.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-ml/postgresql-ocaml/Manifest b/dev-ml/postgresql-ocaml/Manifest
index a2bcec517985..eedacf3e2838 100644
--- a/dev-ml/postgresql-ocaml/Manifest
+++ b/dev-ml/postgresql-ocaml/Manifest
@@ -2,3 +2,4 @@ DIST postgresql-ocaml-2.0.5.tar.gz 79123 SHA256 e786c46edbd63aacd82e008098a2c801
DIST postgresql-ocaml-2.0.6.tar.gz 79697 SHA256 1f3ae24c323f3b1f5876d647168eeca2182994feb53dad9ef540fd54837887cb SHA512 0cde0deb38df5bdce467941ca4e9bd3a9648c430a9e406eadc6aecffbe7b5aae27fb5fe3464954de98cba8ecece77e91416cd28f94cb3d3d7d08993d2238f2dc WHIRLPOOL f5f3a100074fb0e1d1dbc6ae13b98be28db76cf7dce5f1731bee44f099dd00f40dd0e13015432f6e1e1f55d3b522986bacf1ea369f1d1a881be10266d2decd8c
DIST postgresql-ocaml-3.2.0.tar.gz 85619 SHA256 bdae08e08fffa0f863512ac54675db6fa2edd0bab63762cc9ffbedc656893426 SHA512 da35820cf1081641161e8e9c0ee5c0d1090fa61b1f0e13893feda83ae6a0167aac93e58db7448b3cf841bab345f3a4efa97b385ca7819019c6146fd17cd9f146 WHIRLPOOL fab8eee40cbf808faab9aca277a1a6306a1bb02d7fba9d2a45fdf8c586d6174367417b9760656a13622bc9fbff2d4b8218b7627a8c9f365db99eb9bd983cac34
DIST postgresql-ocaml-3.2.1.tar.gz 85604 SHA256 e4679e22f10d4c366ad03b926ab63e65618e4da8359e16711d8f2d9dff8a7593 SHA512 36c4c894259d8bfaccbb1e5dc517fdbb025fe6d9fd24fa5e1d2120faf75aec472218d62c8816ef0055b1c0de934ff74a7eb22d8724d9e9790c21eaa6c4a56ed6 WHIRLPOOL c1476316e1b9b77ef0d5e8c76384a1bfb367d83cb527fed56afbea51e924cebef51af7de2e7d72ca6b117726d71147e8b842f57bf1aa003a7f9e7f06a59fdfbf
+DIST postgresql-ocaml-3.2.2.tar.gz 85697 SHA256 51348110f06e7d17f68894fd91f91b3e1f935647355a94a79b8c16f923ce9e81 SHA512 c41c6feed76d8d49932399a080d2e2fa9227b742e0cab5efdf849315ae1b633369e035bee3fd1d94c6a61e533f23d3881e9de650d1b4ec01946660f39c245917 WHIRLPOOL c314346cf113c87ceec3ded469505952a7717f06bdc6099e5fab84d4b5911927b611036bf924c9fdadb35c545ad3fc8ab06d115fd24ad78e045580ba8e02a04f
diff --git a/dev-ml/postgresql-ocaml/postgresql-ocaml-3.2.2.ebuild b/dev-ml/postgresql-ocaml/postgresql-ocaml-3.2.2.ebuild
new file mode 100644
index 000000000000..3f2ac2fec70b
--- /dev/null
+++ b/dev-ml/postgresql-ocaml/postgresql-ocaml-3.2.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+OASIS_BUILD_DOCS=1
+
+inherit oasis
+
+DESCRIPTION="A package for ocaml that provides access to PostgreSQL databases"
+SRC_URI="https://github.com/mmottl/postgresql-ocaml/releases/download/v${PV}/${P}.tar.gz"
+HOMEPAGE="http://mmottl.github.io/postgresql-ocaml/"
+IUSE="examples"
+
+RDEPEND="
+ dev-db/postgresql:=[server]
+"
+DEPEND="${RDEPEND}
+ >=dev-ml/findlib-1.5"
+
+SLOT="0/${PV}"
+LICENSE="LGPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DOCS=( "AUTHORS.txt" "CHANGES.txt" "README.md" )
+
+src_install() {
+ oasis_src_install
+ if use examples ; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}