summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-haskell/with-location/Manifest2
-rw-r--r--dev-haskell/with-location/metadata.xml11
-rw-r--r--dev-haskell/with-location/with-location-0.0.0.ebuild25
-rw-r--r--dev-haskell/with-location/with-location-0.1.0.ebuild26
4 files changed, 64 insertions, 0 deletions
diff --git a/dev-haskell/with-location/Manifest b/dev-haskell/with-location/Manifest
new file mode 100644
index 000000000000..40a20ba45b14
--- /dev/null
+++ b/dev-haskell/with-location/Manifest
@@ -0,0 +1,2 @@
+DIST with-location-0.0.0.tar.gz 1806 SHA256 65919edc3d0aaa403c54d0e8a9023568642daa635c057120090d17c61960bac5 SHA512 c5be3a9478c0f9585daebe1b7ab73d81ed937740d7c5f5f3dac05289c58a508fca458e5c0727aed767e507c27a9007e878ee949228b8d25355ab8474ba7289c2 WHIRLPOOL a75b414e243339b3e99c6f85646f9100a17e8c216f029d1bbeb2c064a24bb5637417eb46b0224cabc2298666eff7238cab944a7d5d8e04751efd99b03d0326de
+DIST with-location-0.1.0.tar.gz 2029 SHA256 2c91d70cb28d39d6d5fbb37800c7d984aed4254cdcbf03ffa0787404bddefde7 SHA512 1b8bdecd02d4acaa8b21e2cd6acdee573ac29b909c9a6f0d88a56adcd7433d551db5c1fadbc3e72c78378d74a614594d8d2ad08899fd63ecc57c65d0c37b28b9 WHIRLPOOL 5f7ae718313286b13324852bc1e2c6a77bb9d3fa456d2d92c4a722dbb090d8b4305523e4309578e175f45936fccd47c193d9af5d1fac7e7b34a62da91ce22eab
diff --git a/dev-haskell/with-location/metadata.xml b/dev-haskell/with-location/metadata.xml
new file mode 100644
index 000000000000..8ef886bbc57e
--- /dev/null
+++ b/dev-haskell/with-location/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ Use ImplicitParams-based source locations in a backward compatible way
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/with-location/with-location-0.0.0.ebuild b/dev-haskell/with-location/with-location-0.0.0.ebuild
new file mode 100644
index 000000000000..8029af283bab
--- /dev/null
+++ b/dev-haskell/with-location/with-location-0.0.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.7.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Use ImplicitParams-based source locations in a backward compatible way"
+HOMEPAGE="https://github.com/sol/with-location#readme"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+"
diff --git a/dev-haskell/with-location/with-location-0.1.0.ebuild b/dev-haskell/with-location/with-location-0.1.0.ebuild
new file mode 100644
index 000000000000..923051135658
--- /dev/null
+++ b/dev-haskell/with-location/with-location-0.1.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.7.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Use ImplicitParams-based source locations in a backward compatible way"
+HOMEPAGE="https://github.com/sol/with-location#readme"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+ test? ( dev-haskell/hspec )
+"