summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ml/cairo2/Manifest1
-rw-r--r--dev-ml/cairo2/cairo2-0.6.2.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-ml/cairo2/Manifest b/dev-ml/cairo2/Manifest
index 3be8165a41ce..b35c69157d57 100644
--- a/dev-ml/cairo2/Manifest
+++ b/dev-ml/cairo2/Manifest
@@ -1 +1,2 @@
DIST cairo2-0.6.1.tbz 90006 BLAKE2B 78f1a998f821aad9b2a1d2deacffd9290920e6d351e0c66b6cc2a6f4f6140fef67c0dde9c1c317e743b5930e09d68d6c1830beb554d23ac9bcc95738a4091850 SHA512 d09274624854a45cf914ffbe984f1bcdd30db6283e7a0fd73aeec2a19226ff8f68d3f7139bbab72ca5698b58b840d6fd8a35570efc228391a7c5d031421f5c1f
+DIST cairo2-0.6.2.tbz 90428 BLAKE2B a8c03e6ea8d4dcfc34a744f48b9a55a5e84b964602358f1c90aadcc5fdaed8eebecba2c851e71ef60066d42088d0baf9f4b90824541af93426e47f2539d6f41b SHA512 789b65428855c3b8fb71836ee6e607870c3140a6152fb01b8ba6e7d2e2f4842a62412061a5eff99023234d305587b605d0cbbacd29456c86a52e9df6466bd302
diff --git a/dev-ml/cairo2/cairo2-0.6.2.ebuild b/dev-ml/cairo2/cairo2-0.6.2.ebuild
new file mode 100644
index 000000000000..812ac046545e
--- /dev/null
+++ b/dev-ml/cairo2/cairo2-0.6.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="Binding to Cairo, a 2D Vector Graphics Library"
+HOMEPAGE="https://github.com/Chris00/ocaml-cairo"
+SRC_URI="https://github.com/Chris00/ocaml-cairo/releases/download/${PV}/cairo2-${PV}.tbz"
+
+LICENSE="LGPL-3"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="+ocamlopt"
+
+DEPEND="
+ x11-libs/cairo:=
+ dev-ml/dune-configurator:=
+"
+RDEPEND="${DEPEND}
+ !dev-ml/ocaml-cairo
+"
+BDEPEND=""
+
+# >>> Test phase: dev-ml/cairo2-0.6.1
+# image_create alias tests/runtest (got signal SEGV)
+# (cd _build/default/tests && ./image_create.exe)
+# DESTROY bigarray 'data'
+# Done: 70/72 (jobs: 1) * ERROR: dev-ml/cairo2-0.6.1::x-portage failed (test phase):
+RESTRICT=test
+
+# Remove lablgtk2 dep https://github.com/Chris00/ocaml-cairo/issues/21
+# Fix compiler warnings, from: https://github.com/Chris00/ocaml-cairo/pull/22
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.6.1-ignore-gtk-and-pango.patch
+)