summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ml/lablgtk/lablgtk-2.18.10.ebuild9
-rw-r--r--dev-ml/lablgtk/lablgtk-2.18.5.ebuild7
-rw-r--r--dev-ml/lablgtk/lablgtk-2.18.8-r1.ebuild9
3 files changed, 8 insertions, 17 deletions
diff --git a/dev-ml/lablgtk/lablgtk-2.18.10.ebuild b/dev-ml/lablgtk/lablgtk-2.18.10.ebuild
index 4cbb3b17630c..ea2040f934d2 100644
--- a/dev-ml/lablgtk/lablgtk-2.18.10.ebuild
+++ b/dev-ml/lablgtk/lablgtk-2.18.10.ebuild
@@ -10,17 +10,13 @@ SRC_URI="https://github.com/garrigue/lablgtk/archive/${PV}.tar.gz -> ${P}.tar.gz
LICENSE="LGPL-2.1-with-linking-exception examples? ( lablgtk-examples )"
SLOT="2/${PV}"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
-IUSE="debug examples glade gnomecanvas +ocamlopt opengl sourceview spell svg"
+IUSE="debug examples glade gnomecanvas +ocamlopt sourceview spell svg"
DEPEND="dev-lang/ocaml:=[ocamlopt?]
dev-ml/camlp4:=
x11-libs/gtk+:2
glade? ( gnome-base/libglade )
gnomecanvas? ( gnome-base/libgnomecanvas )
- opengl? (
- dev-ml/lablgl:=
- x11-libs/gtkglarea:2
- )
sourceview? ( x11-libs/gtksourceview:2.0 )
spell? ( app-text/gtkspell:2 )
svg? ( gnome-base/librsvg:2 )"
@@ -37,7 +33,8 @@ src_configure() {
$(use_with glade)
--without-gnomeui
--without-panel
- $(use_with opengl gl)
+ # relies on EOL gtkglarea
+ --without-gl
$(use_with spell gtkspell)
--without-gtksourceview
$(use_with sourceview gtksourceview2)
diff --git a/dev-ml/lablgtk/lablgtk-2.18.5.ebuild b/dev-ml/lablgtk/lablgtk-2.18.5.ebuild
index 8cfdfda4cf9c..bf0575dc8bd1 100644
--- a/dev-ml/lablgtk/lablgtk-2.18.5.ebuild
+++ b/dev-ml/lablgtk/lablgtk-2.18.5.ebuild
@@ -5,7 +5,7 @@ EAPI=5
inherit multilib findlib
-IUSE="debug examples glade gnomecanvas sourceview +ocamlopt opengl spell svg"
+IUSE="debug examples glade gnomecanvas sourceview +ocamlopt spell svg"
DESCRIPTION="Objective CAML interface for Gtk+2"
HOMEPAGE="http://lablgtk.forge.ocamlcore.org/"
@@ -17,8 +17,6 @@ RDEPEND=">=x11-libs/gtk+-2.10:2
svg? ( >=gnome-base/librsvg-2.2:2 )
glade? ( >=gnome-base/libglade-2.0.1 )
gnomecanvas? ( >=gnome-base/libgnomecanvas-2.2 )
- opengl? ( >=dev-ml/lablgl-0.98:=
- >=x11-libs/gtkglarea-1.9:2 )
spell? ( app-text/gtkspell:2 )
sourceview? ( x11-libs/gtksourceview:2.0 )
dev-ml/camlp4:=
@@ -35,7 +33,7 @@ src_configure() {
$(use_with glade) \
--without-gnomeui \
--without-panel \
- $(use_with opengl gl) \
+ --without-gl \
$(use_with spell gtkspell) \
--without-gtksourceview \
$(use_with sourceview gtksourceview2) \
@@ -58,7 +56,6 @@ install_examples() {
use svg && insinto /usr/share/doc/${PF}/examples/rsvg && doins examples/rsvg/*.ml examples/rsvg/*.svg
use glade && insinto /usr/share/doc/${PF}/examples/glade && doins examples/glade/*.ml examples/glade/*.glade*
use sourceview && insinto /usr/share/doc/${PF}/examples/sourceview && doins examples/sourceview/*.ml examples/sourceview/*.lang
- use opengl && insinto /usr/share/doc/${PF}/examples/GL && doins examples/GL/*.ml
docompress -x /usr/share/doc/${PF}/examples
}
diff --git a/dev-ml/lablgtk/lablgtk-2.18.8-r1.ebuild b/dev-ml/lablgtk/lablgtk-2.18.8-r1.ebuild
index d1e17c9dd1b2..92dd9af9dc69 100644
--- a/dev-ml/lablgtk/lablgtk-2.18.8-r1.ebuild
+++ b/dev-ml/lablgtk/lablgtk-2.18.8-r1.ebuild
@@ -10,17 +10,13 @@ SRC_URI="https://github.com/garrigue/lablgtk/releases/download/lablgtk2188/${P}.
LICENSE="LGPL-2.1-with-linking-exception examples? ( lablgtk-examples )"
SLOT="2/${PV}"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
-IUSE="debug examples glade gnomecanvas +ocamlopt opengl sourceview spell svg"
+IUSE="debug examples glade gnomecanvas +ocamlopt sourceview spell svg"
DEPEND="dev-lang/ocaml:=[ocamlopt?]
dev-ml/camlp4:=
x11-libs/gtk+:2
glade? ( gnome-base/libglade )
gnomecanvas? ( gnome-base/libgnomecanvas )
- opengl? (
- dev-ml/lablgl:=
- x11-libs/gtkglarea:2
- )
sourceview? ( x11-libs/gtksourceview:2.0 )
spell? ( app-text/gtkspell:2 )
svg? ( gnome-base/librsvg:2 )"
@@ -37,7 +33,8 @@ src_configure() {
$(use_with glade)
--without-gnomeui
--without-panel
- $(use_with opengl gl)
+ # relies on EOL gtkglarea
+ --without-gl
$(use_with spell gtkspell)
--without-gtksourceview
$(use_with sourceview gtksourceview2)