summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ml/fmt/Manifest1
-rw-r--r--dev-ml/fmt/fmt-0.8.2.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-ml/fmt/Manifest b/dev-ml/fmt/Manifest
index 6e16df3b450b..eaec3126a1b7 100644
--- a/dev-ml/fmt/Manifest
+++ b/dev-ml/fmt/Manifest
@@ -1,2 +1,3 @@
DIST fmt-0.8.0.tbz 14965 SHA256 fd221052a9d2c9be0a8f32d14b2cb35d72ec6f7cd828244759392adbec8ac79b SHA512 5287ff80343ab7f2b33e87b48ff4301e1152b54da1f1de6d8ac235f909cd83e8c9219fd46dbbe239aa6736b406c884141b3ab7578d6a3b2ff289d7756a09ec44 WHIRLPOOL 06eac9e3c3f97f196d2727bd07bf06ccbe4761b77c51fa25bab90575b40db612caf58f4b7685905f67a0ad36c82aa241c2db215c85e574930d1c19e2a6ee5176
DIST fmt-0.8.1.tbz 13639 SHA256 db0b97e88801f8e7e365a929e311a64835e27ab669cdef76811555b2da3d2c0f SHA512 21cf0a89928999bc23de676763ade41d263ce4a9364c8f77fe693ff8941de492d5f71290d30bcfcdd786612fa3af7bf78921a30a26f3fff3969396a728e8e66e WHIRLPOOL 3492f8d20524512c9c0da6c77cdb28cc3f23e60f7708b14123783c4bfc2e62aa49b8dd34bc11d6c34660c471f0fa88c0525ea966595241936a1c5f7f6aae8b40
+DIST fmt-0.8.2.tbz 13668 SHA256 11a1b12037aea444b1ead54143bd0abde43752a57e1ac77dfeab98cac8f91808 SHA512 38f567a988176bb4628665e6f5e47dba4917a2f65310d222dcd7f14809a38fbd824e9ee05ba4de97a20aa2c57a813541c587c8c438b2ac1f93199dddaa441ae0 WHIRLPOOL 159c7d9dfe389707e6a566ae75c52cf4fb890d253c978baecb2ae9d93d03a06094e4e3098141bea9c6686143c53445449bc07bfec35922374cd3ae9774cccd98
diff --git a/dev-ml/fmt/fmt-0.8.2.ebuild b/dev-ml/fmt/fmt-0.8.2.ebuild
new file mode 100644
index 000000000000..8e0f58572e56
--- /dev/null
+++ b/dev-ml/fmt/fmt-0.8.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit findlib
+
+DESCRIPTION="Combinators to devise OCaml Format pretty-printing functions"
+HOMEPAGE="http://erratique.ch/software/fmt https://github.com/dbuenzli/fmt"
+SRC_URI="http://erratique.ch/software/fmt/releases/${P}.tbz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="dev-ml/result:=[ocamlopt]
+ dev-lang/ocaml:=[ocamlopt]
+ dev-ml/uchar:=[ocamlopt]
+ dev-ml/cmdliner:=[ocamlopt]"
+DEPEND="${RDEPEND}
+ dev-ml/opam
+ >=dev-ml/topkg-0.9
+ dev-ml/ocamlbuild
+ dev-ml/findlib"
+
+src_compile() {
+ ocaml pkg/pkg.ml build --tests $(usex test 'true' 'false') || die
+}
+
+src_test() {
+ ocaml pkg/pkg.ml test || die
+}
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ ${PN}.install || die
+ dodoc CHANGES.md README.md
+}