summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/SchemaObject/SchemaObject-0.5.3-r1.ebuild23
-rw-r--r--dev-python/SchemaObject/SchemaObject-0.5.3.ebuild43
2 files changed, 23 insertions, 43 deletions
diff --git a/dev-python/SchemaObject/SchemaObject-0.5.3-r1.ebuild b/dev-python/SchemaObject/SchemaObject-0.5.3-r1.ebuild
new file mode 100644
index 000000000000..eaf96ef07c7d
--- /dev/null
+++ b/dev-python/SchemaObject/SchemaObject-0.5.3-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="A simple Python object interface to a MySQL database schema"
+HOMEPAGE="https://github.com/mmatuson/SchemaObject"
+# old download location is down
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${PN,,}"
diff --git a/dev-python/SchemaObject/SchemaObject-0.5.3.ebuild b/dev-python/SchemaObject/SchemaObject-0.5.3.ebuild
deleted file mode 100644
index 6c56950b7f63..000000000000
--- a/dev-python/SchemaObject/SchemaObject-0.5.3.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=4
-
-PYTHON_DEPEND="2:2.5:2.7"
-
-inherit distutils
-
-DESCRIPTION="A simple Python object interface to a MySQL database schema"
-HOMEPAGE="http://matuson.com/code/schemaobject/"
-SRC_URI="http://www.matuson.com/code/schemaobject/downloads/${P}.tar.gz"
-
-# Switch to ,, when we switch to EAPI=6.
-#pn="${PN,,}"
-pn="schemaobject"
-S="${WORKDIR}/${pn}"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND="dev-python/setuptools"
-RDEPEND="${DEPEND}"
-
-pkg_setup() {
- python_set_active_version 2
- python_pkg_setup
-}
-
-src_prepare() {
- python_convert_shebangs -r 2 .
-}
-
-pkg_postinst() {
- python_mod_optimize "${pn}"
-}
-
-pkg_postrm() {
- python_mod_cleanup "${pn}"
-}