summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www-servers/varnish/files/fix-build-x86.patch25
-rw-r--r--www-servers/varnish/varnish-4.1.5.ebuild3
-rw-r--r--www-servers/varnish/varnish-4.1.6.ebuild3
3 files changed, 31 insertions, 0 deletions
diff --git a/www-servers/varnish/files/fix-build-x86.patch b/www-servers/varnish/files/fix-build-x86.patch
new file mode 100644
index 000000000000..acacd3b9d610
--- /dev/null
+++ b/www-servers/varnish/files/fix-build-x86.patch
@@ -0,0 +1,25 @@
+See https://bugs.gentoo.org/show_bug.cgi?id=620952
+
+From 54b5a09f00c027da280361b30d32a4ff309ba3ab Mon Sep 17 00:00:00 2001
+From: Poul-Henning Kamp <phk@FreeBSD.org>
+Date: Tue, 28 Mar 2017 18:44:12 +0000
+Subject: [PATCH] Try to confuse GCC to not doing FP brain-damage.
+
+Fixes #1875 (maybe)
+---
+ bin/varnishd/mgt/mgt_param_tweak.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/bin/varnishd/mgt/mgt_param_tweak.c b/bin/varnishd/mgt/mgt_param_tweak.c
+index 12a7a52ef..b26581e2e 100644
+--- a/bin/varnishd/mgt/mgt_param_tweak.c
++++ b/bin/varnishd/mgt/mgt_param_tweak.c
+@@ -52,7 +52,7 @@ static int
+ tweak_generic_double(struct vsb *vsb, volatile double *dest,
+ const char *arg, const char *min, const char *max, const char *fmt)
+ {
+- double u, minv = 0, maxv = 0;
++ volatile double u, minv = 0, maxv = 0;
+
+ if (arg != NULL) {
+ if (min != NULL) {
diff --git a/www-servers/varnish/varnish-4.1.5.ebuild b/www-servers/varnish/varnish-4.1.5.ebuild
index fa893f30376d..e0e8515fff58 100644
--- a/www-servers/varnish/varnish-4.1.5.ebuild
+++ b/www-servers/varnish/varnish-4.1.5.ebuild
@@ -53,6 +53,9 @@ src_prepare() {
# automagic dep in our patches, bug #461638
rm -rf lib/libjemalloc
+ # Fix bug #620952
+ epatch "${FILESDIR}"/fix-build-x86.patch
+
# Remove -Werror bug #528354
sed -i -e 's/-Werror\([^=]\)/\1/g' configure.ac
diff --git a/www-servers/varnish/varnish-4.1.6.ebuild b/www-servers/varnish/varnish-4.1.6.ebuild
index 482292dc7485..2d122c0ff486 100644
--- a/www-servers/varnish/varnish-4.1.6.ebuild
+++ b/www-servers/varnish/varnish-4.1.6.ebuild
@@ -53,6 +53,9 @@ src_prepare() {
# automagic dep in our patches, bug #461638
rm -rf lib/libjemalloc
+ # Fix bug #620952
+ epatch "${FILESDIR}"/fix-build-x86.patch
+
# Remove -Werror bug #528354
sed -i -e 's/-Werror\([^=]\)/\1/g' configure.ac