summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-editors/pluma/Manifest1
-rw-r--r--app-editors/pluma/pluma-1.8.0.ebuild86
2 files changed, 0 insertions, 87 deletions
diff --git a/app-editors/pluma/Manifest b/app-editors/pluma/Manifest
index eba94b22c8a1..59f03668c469 100644
--- a/app-editors/pluma/Manifest
+++ b/app-editors/pluma/Manifest
@@ -1,2 +1 @@
-DIST pluma-1.8.0.tar.xz 3395424 SHA256 69b381854bb0bb7976af1469b921feec626b5f12c3c2f077b2ed0ea0020d2979 SHA512 b5298da96198a154f1dd039d594152911e3fa7cb037341a4917bcdef560864ccf08762052c0e8d314c40d12bc2dc82fea692992f0fba0e41312b88f7ddcaa8fe WHIRLPOOL b91ec8134eba44b43d6e5cf4769c770b46fe0383e1a7256103d8d1b6beaf7fac22df6772971674b0920e96eef03bedfeb9d29ea156111949b080d42c4cc93078
DIST pluma-1.8.1.tar.xz 3409032 SHA256 38accc5c05062981a0649874300bc21ab3ad1a5ef47491186dffe7c035ed9e8b SHA512 4429b95a6c692c524db481cc53a3d9d5fd252a2aafa49daf787df5d7b389806f520233bc054b701a3ca47a5df5917cf934dafee8327b0ac01b7fe25059b6adea WHIRLPOOL c1e61e32bc657b7097292869acd57e69b6c67d0610db0644c38141ca4e94b34b0b3bc3b941fc79b444c2f56d3140210f117fc80bfc2102b97d4f45af9e9e2057
diff --git a/app-editors/pluma/pluma-1.8.0.ebuild b/app-editors/pluma/pluma-1.8.0.ebuild
deleted file mode 100644
index 3f27b451ebb9..000000000000
--- a/app-editors/pluma/pluma-1.8.0.ebuild
+++ /dev/null
@@ -1,86 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-
-GCONF_DEBUG="yes"
-GNOME2_LA_PUNT="yes"
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit gnome2 multilib python-single-r1 versionator virtualx
-
-MATE_BRANCH="$(get_version_component_range 1-2)"
-
-SRC_URI="http://pub.mate-desktop.org/releases/${MATE_BRANCH}/${P}.tar.xz"
-DESCRIPTION="Pluma text editor for the MATE desktop"
-HOMEPAGE="http://mate-desktop.org"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64"
-
-IUSE="python spell"
-
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-# Tests require gvfs sftp fs mounted and schema's installed. Disable tests.
-# https://github.com/mate-desktop/mate-text-editor/issues/33
-RESTRICT="test"
-
-RDEPEND="app-text/rarian:0
- dev-libs/atk:0
- >=dev-libs/glib-2.32:2
- >=dev-libs/libxml2-2.5:2
- x11-libs/cairo:0
- x11-libs/gdk-pixbuf:2
- >=x11-libs/gtk+-2.19:2
- >=x11-libs/gtksourceview-2.9.7:2.0
- x11-libs/libICE:0
- x11-libs/libX11:0
- >=x11-libs/libSM-1.0
- x11-libs/pango:0
- virtual/libintl:0
- spell? (
- >=app-text/enchant-1.2:0
- >=app-text/iso-codes-0.35:0
- )
- python? (
- ${PYTHON_DEPS}
- >=dev-python/pygobject-2.15.4:2[${PYTHON_USEDEP}]
- >=dev-python/pygtk-2.12:2[${PYTHON_USEDEP}]
- >=dev-python/pygtksourceview-2.9.2:2
- )
- !!app-editors/mate-text-editor"
-
-DEPEND="${RDEPEND}
- ~app-text/docbook-xml-dtd-4.1.2
- >=app-text/scrollkeeper-dtd-1:1.0
- >=dev-util/intltool-0.40:*
- >=sys-devel/libtool-2.2.6:2
- >=mate-base/mate-common-1.8:0
- >=sys-devel/gettext-0.17:*
- virtual/pkgconfig:*"
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
-}
-
-src_configure() {
- gnome2_src_configure \
- --disable-updater \
- $(use_enable python) \
- $(use_enable spell)
-}
-
-DOCS="AUTHORS ChangeLog NEWS README"
-
-src_test() {
- # FIXME: This should be handled at eclass level.
- "${EROOT}${GLIB_COMPILE_SCHEMAS}" --allow-any-name "${S}/data" || die
-
- unset DBUS_SESSION_BUS_ADDRESS
-
- GSETTINGS_SCHEMA_DIR="${S}/data" Xemake check
-}