summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ros/qt_gui_cpp/Manifest1
-rw-r--r--dev-ros/qt_gui_cpp/files/libdir.patch15
-rw-r--r--dev-ros/qt_gui_cpp/metadata.xml5
-rw-r--r--dev-ros/qt_gui_cpp/qt_gui_cpp-0.2.29.ebuild32
-rw-r--r--dev-ros/qt_gui_cpp/qt_gui_cpp-9999.ebuild32
5 files changed, 85 insertions, 0 deletions
diff --git a/dev-ros/qt_gui_cpp/Manifest b/dev-ros/qt_gui_cpp/Manifest
new file mode 100644
index 000000000000..85ca418d4e93
--- /dev/null
+++ b/dev-ros/qt_gui_cpp/Manifest
@@ -0,0 +1 @@
+DIST qt_gui_core-0.2.29.tar.gz 85881 SHA256 7c51b4fd7e795e37e3f8a4b691a5e520466105fdddbc85e194c10c608fe7448c SHA512 958526a3bd76070e121d75a82c589894aef980870091cb853802fcb60328b54cbc95ee0c9eececa18e24608808cca2c722c5699b662c2a578f150995171d71db WHIRLPOOL f83328ce59fd9cd8db5a066f1a2a93bde54b28268891b18cf73b31d5584b0dc7f932350a39e729c97be3bc3b6780422dd2538321f29b0acd13d06387e0054975
diff --git a/dev-ros/qt_gui_cpp/files/libdir.patch b/dev-ros/qt_gui_cpp/files/libdir.patch
new file mode 100644
index 000000000000..8c22eed2385c
--- /dev/null
+++ b/dev-ros/qt_gui_cpp/files/libdir.patch
@@ -0,0 +1,15 @@
+Index: qt_gui_core-0.2.26/qt_gui_cpp/src/qt_gui_cpp_sip/CMakeLists.txt
+===================================================================
+--- qt_gui_core-0.2.26.orig/qt_gui_cpp/src/qt_gui_cpp_sip/CMakeLists.txt
++++ qt_gui_core-0.2.26/qt_gui_cpp/src/qt_gui_cpp_sip/CMakeLists.txt
+@@ -29,8 +29,8 @@ set(qt_gui_cpp_sip_DEPENDENT_FILES
+ # maintain context for different named target
+ set(qt_gui_cpp_sip_INCLUDE_DIRS ${qt_gui_cpp_INCLUDE_DIRS} "${CMAKE_CURRENT_SOURCE_DIR}/../../include" ${catkin_INCLUDE_DIRS})
+ set(qt_gui_cpp_sip_LIBRARIES ${qt_gui_cpp_LIBRARIES} ${PROJECT_NAME} ${catkin_LIBRARIES} ${Boost_LIBRARIES})
+-set(qt_gui_cpp_sip_LIBRARY_DIRS ${qt_gui_cpp_LIBRARY_DIRS} ${CATKIN_DEVEL_PREFIX}/lib)
+-set(qt_gui_cpp_sip_LDFLAGS_OTHER ${qt_gui_cpp_LDFLAGS_OTHER} -Wl,-rpath,\\"${CATKIN_DEVEL_PREFIX}/lib\\")
++set(qt_gui_cpp_sip_LIBRARY_DIRS ${qt_gui_cpp_LIBRARY_DIRS} ${CATKIN_DEVEL_PREFIX}/${CMAKE_INSTALL_LIBDIR})
++set(qt_gui_cpp_sip_LDFLAGS_OTHER ${qt_gui_cpp_LDFLAGS_OTHER} -Wl,-rpath,\\"${CATKIN_DEVEL_PREFIX}/${CMAKE_INSTALL_LIBDIR}\\")
+
+ find_package(python_qt_binding REQUIRED)
+ include(${python_qt_binding_EXTRAS_DIR}/sip_helper.cmake)
diff --git a/dev-ros/qt_gui_cpp/metadata.xml b/dev-ros/qt_gui_cpp/metadata.xml
new file mode 100644
index 000000000000..c42ea5b15cf6
--- /dev/null
+++ b/dev-ros/qt_gui_cpp/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>
diff --git a/dev-ros/qt_gui_cpp/qt_gui_cpp-0.2.29.ebuild b/dev-ros/qt_gui_cpp/qt_gui_cpp-0.2.29.ebuild
new file mode 100644
index 000000000000..1e355523dc13
--- /dev/null
+++ b/dev-ros/qt_gui_cpp/qt_gui_cpp-0.2.29.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros-visualization/qt_gui_core"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Foundation for C++-bindings for dev-ros/qt_gui and creates bindings for every generator available"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-qt/qtcore:4
+ >=dev-ros/pluginlib-1.9.23
+ >=dev-ros/qt_gui-0.2.18[${PYTHON_USEDEP}]
+ dev-libs/tinyxml
+ dev-ros/python_qt_binding[${PYTHON_USEDEP}]
+ dev-libs/boost:=
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+PATCHES=(
+ "${FILESDIR}/libdir.patch"
+)
diff --git a/dev-ros/qt_gui_cpp/qt_gui_cpp-9999.ebuild b/dev-ros/qt_gui_cpp/qt_gui_cpp-9999.ebuild
new file mode 100644
index 000000000000..1e355523dc13
--- /dev/null
+++ b/dev-ros/qt_gui_cpp/qt_gui_cpp-9999.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros-visualization/qt_gui_core"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Foundation for C++-bindings for dev-ros/qt_gui and creates bindings for every generator available"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-qt/qtcore:4
+ >=dev-ros/pluginlib-1.9.23
+ >=dev-ros/qt_gui-0.2.18[${PYTHON_USEDEP}]
+ dev-libs/tinyxml
+ dev-ros/python_qt_binding[${PYTHON_USEDEP}]
+ dev-libs/boost:=
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+PATCHES=(
+ "${FILESDIR}/libdir.patch"
+)