summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-drivers/xf86-video-ati/xf86-video-ati-19.1.0.ebuild12
-rw-r--r--x11-drivers/xf86-video-ati/xf86-video-ati-9999.ebuild12
2 files changed, 18 insertions, 6 deletions
diff --git a/x11-drivers/xf86-video-ati/xf86-video-ati-19.1.0.ebuild b/x11-drivers/xf86-video-ati/xf86-video-ati-19.1.0.ebuild
index 8949920fd61b..70b6b7db0934 100644
--- a/x11-drivers/xf86-video-ati/xf86-video-ati-19.1.0.ebuild
+++ b/x11-drivers/xf86-video-ati/xf86-video-ati-19.1.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -29,7 +29,7 @@ PATCHES=(
)
pkg_pretend() {
- if use kernel_linux ; then
+ if use kernel_linux; then
if kernel_is -ge 3 9; then
CONFIG_CHECK="~!DRM_RADEON_UMS ~!FB_RADEON"
else
@@ -40,8 +40,14 @@ pkg_pretend() {
}
pkg_setup() {
- XORG_CONFIGURE_OPTIONS=(
+ linux-info_pkg_setup
+ xorg-3_pkg_setup
+}
+
+src_configure() {
+ local XORG_CONFIGURE_OPTIONS=(
--enable-glamor
$(use_enable udev)
)
+ xorg-3_src_configure
}
diff --git a/x11-drivers/xf86-video-ati/xf86-video-ati-9999.ebuild b/x11-drivers/xf86-video-ati/xf86-video-ati-9999.ebuild
index 2aab4b2d7290..0d96979995e8 100644
--- a/x11-drivers/xf86-video-ati/xf86-video-ati-9999.ebuild
+++ b/x11-drivers/xf86-video-ati/xf86-video-ati-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -25,7 +25,7 @@ DEPEND="${RDEPEND}
x11-base/xorg-proto"
pkg_pretend() {
- if use kernel_linux ; then
+ if use kernel_linux; then
if kernel_is -ge 3 9; then
CONFIG_CHECK="~!DRM_RADEON_UMS ~!FB_RADEON"
else
@@ -36,8 +36,14 @@ pkg_pretend() {
}
pkg_setup() {
- XORG_CONFIGURE_OPTIONS=(
+ linux-info_pkg_setup
+ xorg-3_pkg_setup
+}
+
+src_configure() {
+ local XORG_CONFIGURE_OPTIONS=(
--enable-glamor
$(use_enable udev)
)
+ xorg-3_src_configure
}