summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/vcstools/Manifest1
-rw-r--r--dev-python/vcstools/vcstools-0.1.40.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/vcstools/Manifest b/dev-python/vcstools/Manifest
index bd829424ad96..3990a236e0a6 100644
--- a/dev-python/vcstools/Manifest
+++ b/dev-python/vcstools/Manifest
@@ -1,2 +1,3 @@
DIST vcstools-0.1.38.tar.gz 54671 BLAKE2B b19730749878de8fb55706751b8a276e351d944803aecb45d8f07497ed9d4283939594d751e818c7fcc09a7cefc4238df978470e8f9da10f27bed5abfe76ce5c SHA512 a3693d34777235e562a5db006af8f33590df99ffce96f5d3cfd2d816ebdc23ee5fb3536bf289b64a36588e60ce20ce8396a448394f300a12672fd8bf5800973e
DIST vcstools-0.1.39.tar.gz 51610 BLAKE2B 24997cf3981a70f9647c16a230ff776b32aaf7096d760976b6af7b1fa1fe78b4993299680d8aad53d82465e66c4fcd80389e26b8da1476df64ccaf9b40c705af SHA512 163ced29baa158d915169a4f8f432bd9ad60ddcd5abae0d3801b5d970049d717c11bd8aa95f7af9dfe48cdcbcce49d14331a82a9c41b9ded1ce4caa2e27cd901
+DIST vcstools-0.1.40.tar.gz 62109 BLAKE2B a5347ba62031e602421f26b081e26e55549e92fc4a0648b58a3c4c3b0134b91dba096604f83edcc51a99c989e60fa51e8af2f9ecbf992500a6e942c19da9c82c SHA512 7cd062f3c72b27f78361d3000ed8951b1723ea7dd99bf05ea711e8a8b93c42c2acebdfd6c7cf7384730c708da11bd0d2712a54e538dd833eafbcef46f23857cd
diff --git a/dev-python/vcstools/vcstools-0.1.40.ebuild b/dev-python/vcstools/vcstools-0.1.40.ebuild
new file mode 100644
index 000000000000..8283778fcf05
--- /dev/null
+++ b/dev-python/vcstools/vcstools-0.1.40.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://github.com/vcstools/vcstools"
+fi
+
+inherit ${SCM} distutils-r1
+
+DESCRIPTION="Python library for interacting with various VCS systems"
+HOMEPAGE="http://wiki.ros.org/vcstools"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="http://download.ros.org/downloads/${PN}/${P}.tar.gz
+ https://github.com/vcstools/vcstools/archive/${PV}.tar.gz -> ${P}.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-vcs/git
+ dev-vcs/bzr
+ dev-vcs/mercurial
+ dev-vcs/subversion
+ )
+"
+
+python_test() {
+ # From travis.yml
+ # Set git config to silence some stuff in the tests
+ git config --global user.email "foo@example.com"
+ git config --global user.name "Foo Bar"
+ # Set the hg user
+ echo -e "[ui]\nusername = Your Name <your@mail.com>" >> ~/.hgrc
+ # Set the bzr user
+ bzr whoami "Your Name <name@example.com>"
+ #git config --global user.email "you@example.com"
+ #git config --global user.name "Your Name"
+
+ nosetests --with-coverage --cover-package vcstools || die
+}