summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-cpp/kokkos/kokkos-3.1.01-r1.ebuild11
1 files changed, 11 insertions, 0 deletions
diff --git a/dev-cpp/kokkos/kokkos-3.1.01-r1.ebuild b/dev-cpp/kokkos/kokkos-3.1.01-r1.ebuild
index 8f64a19d12e7..24d979c98647 100644
--- a/dev-cpp/kokkos/kokkos-3.1.01-r1.ebuild
+++ b/dev-cpp/kokkos/kokkos-3.1.01-r1.ebuild
@@ -41,3 +41,14 @@ src_configure() {
cmake_src_configure
}
+
+src_test() {
+ local myctestargs=(
+ # Contains "death tests" which are known/expected(?) to fail
+ # https://github.com/kokkos/kokkos/issues/3033
+ # bug #791514
+ -E "(KokkosCore_UnitTest_OpenMP|KokkosCore_UnitTest_Serial)"
+ )
+
+ cmake_src_test
+}