summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-devel/automake/automake-1.10.3-r1.ebuild4
-rw-r--r--sys-devel/automake/automake-1.10.3-r2.ebuild4
-rw-r--r--sys-devel/automake/automake-1.11.6-r1.ebuild6
-rw-r--r--sys-devel/automake/automake-1.11.6-r2.ebuild6
-rw-r--r--sys-devel/automake/automake-1.12.6-r1.ebuild10
-rw-r--r--sys-devel/automake/automake-1.12.6.ebuild10
-rw-r--r--sys-devel/automake/automake-1.13.4-r1.ebuild10
-rw-r--r--sys-devel/automake/automake-1.13.4.ebuild10
-rw-r--r--sys-devel/automake/automake-1.14.1-r1.ebuild10
-rw-r--r--sys-devel/automake/automake-1.14.1.ebuild10
-rw-r--r--sys-devel/automake/automake-1.15-r1.ebuild10
-rw-r--r--sys-devel/automake/automake-1.15-r2.ebuild10
-rw-r--r--sys-devel/automake/automake-1.15.ebuild10
-rw-r--r--sys-devel/automake/automake-1.4_p6-r2.ebuild4
-rw-r--r--sys-devel/automake/automake-1.5-r2.ebuild6
-rw-r--r--sys-devel/automake/automake-1.6.3-r2.ebuild4
-rw-r--r--sys-devel/automake/automake-1.7.9-r3.ebuild4
-rw-r--r--sys-devel/automake/automake-1.8.5-r5.ebuild4
-rw-r--r--sys-devel/automake/automake-1.9.6-r4.ebuild4
-rw-r--r--sys-devel/automake/automake-9999.ebuild4
20 files changed, 70 insertions, 70 deletions
diff --git a/sys-devel/automake/automake-1.10.3-r1.ebuild b/sys-devel/automake/automake-1.10.3-r1.ebuild
index dde41deb150c..a7faad7994d2 100644
--- a/sys-devel/automake/automake-1.10.3-r1.ebuild
+++ b/sys-devel/automake/automake-1.10.3-r1.ebuild
@@ -36,7 +36,7 @@ src_configure() {
# slot the info pages. do this w/out munging the source so we don't have
# to depend on texinfo to regen things. #464146 (among others)
slot_info_pages() {
- pushd "${D}"/usr/share/info >/dev/null
+ pushd "${ED}"/usr/share/info >/dev/null
rm -f dir
# Rewrite all the references to other pages.
@@ -71,7 +71,7 @@ src_install() {
for x in aclocal automake ; do
help2man "perl -Ilib ${x}" > ${x}-${SLOT}.1
doman ${x}-${SLOT}.1
- rm -f "${D}"/usr/bin/${x}
+ rm -f "${ED}"/usr/bin/${x}
done
# remove all config.guess and config.sub files replacing them
diff --git a/sys-devel/automake/automake-1.10.3-r2.ebuild b/sys-devel/automake/automake-1.10.3-r2.ebuild
index de41a4fa3bbc..077f2ed70ed8 100644
--- a/sys-devel/automake/automake-1.10.3-r2.ebuild
+++ b/sys-devel/automake/automake-1.10.3-r2.ebuild
@@ -37,7 +37,7 @@ src_configure() {
# slot the info pages. do this w/out munging the source so we don't have
# to depend on texinfo to regen things. #464146 (among others)
slot_info_pages() {
- pushd "${D}"/usr/share/info >/dev/null
+ pushd "${ED}"/usr/share/info >/dev/null
rm -f dir
# Rewrite all the references to other pages.
@@ -72,7 +72,7 @@ src_install() {
for x in aclocal automake ; do
help2man "perl -Ilib ${x}" > ${x}-${SLOT}.1
doman ${x}-${SLOT}.1
- rm -f "${D}"/usr/bin/${x}
+ rm -f "${ED}"/usr/bin/${x}
done
# remove all config.guess and config.sub files replacing them
diff --git a/sys-devel/automake/automake-1.11.6-r1.ebuild b/sys-devel/automake/automake-1.11.6-r1.ebuild
index b0bfdff4d5aa..cd077f96929c 100644
--- a/sys-devel/automake/automake-1.11.6-r1.ebuild
+++ b/sys-devel/automake/automake-1.11.6-r1.ebuild
@@ -45,7 +45,7 @@ src_compile() {
# slot the info pages. do this w/out munging the source so we don't have
# to depend on texinfo to regen things. #464146 (among others)
slot_info_pages() {
- pushd "${D}"/usr/share/info >/dev/null
+ pushd "${ED}"/usr/share/info >/dev/null
rm -f dir
# Rewrite all the references to other pages.
@@ -78,8 +78,8 @@ src_install() {
dodoc NEWS README THANKS TODO AUTHORS ChangeLog
rm \
- "${D}"/usr/bin/{aclocal,automake} \
- "${D}"/usr/share/man/man1/{aclocal,automake}.1 || die
+ "${ED}"/usr/bin/{aclocal,automake} \
+ "${ED}"/usr/share/man/man1/{aclocal,automake}.1 || die
# remove all config.guess and config.sub files replacing them
# w/a symlink to a specific gnuconfig version
diff --git a/sys-devel/automake/automake-1.11.6-r2.ebuild b/sys-devel/automake/automake-1.11.6-r2.ebuild
index d6ead6fe036d..c789fc1f2cfe 100644
--- a/sys-devel/automake/automake-1.11.6-r2.ebuild
+++ b/sys-devel/automake/automake-1.11.6-r2.ebuild
@@ -47,7 +47,7 @@ src_compile() {
# slot the info pages. do this w/out munging the source so we don't have
# to depend on texinfo to regen things. #464146 (among others)
slot_info_pages() {
- pushd "${D}"/usr/share/info >/dev/null
+ pushd "${ED}"/usr/share/info >/dev/null
rm -f dir
# Rewrite all the references to other pages.
@@ -80,8 +80,8 @@ src_install() {
dodoc NEWS README THANKS TODO AUTHORS ChangeLog
rm \
- "${D}"/usr/bin/{aclocal,automake} \
- "${D}"/usr/share/man/man1/{aclocal,automake}.1 || die
+ "${ED}"/usr/bin/{aclocal,automake} \
+ "${ED}"/usr/share/man/man1/{aclocal,automake}.1 || die
# remove all config.guess and config.sub files replacing them
# w/a symlink to a specific gnuconfig version
diff --git a/sys-devel/automake/automake-1.12.6-r1.ebuild b/sys-devel/automake/automake-1.12.6-r1.ebuild
index f9c1334ce991..6c76eae63eda 100644
--- a/sys-devel/automake/automake-1.12.6-r1.ebuild
+++ b/sys-devel/automake/automake-1.12.6-r1.ebuild
@@ -39,7 +39,7 @@ src_compile() {
# slot the info pages. do this w/out munging the source so we don't have
# to depend on texinfo to regen things. #464146 (among others)
slot_info_pages() {
- pushd "${D}"/usr/share/info >/dev/null
+ pushd "${ED}"/usr/share/info >/dev/null
rm -f dir
# Rewrite all the references to other pages.
@@ -69,13 +69,13 @@ src_install() {
emake DESTDIR="${D}" install \
APIVERSION="${SLOT}" pkgvdatadir="/usr/share/${PN}-${SLOT}"
slot_info_pages
- rm "${D}"/usr/share/aclocal/README || die
- rmdir "${D}"/usr/share/aclocal || die
+ rm "${ED}"/usr/share/aclocal/README || die
+ rmdir "${ED}"/usr/share/aclocal || die
dodoc AUTHORS ChangeLog NEWS README THANKS
rm \
- "${D}"/usr/bin/{aclocal,automake} \
- "${D}"/usr/share/man/man1/{aclocal,automake}.1 || die
+ "${ED}"/usr/bin/{aclocal,automake} \
+ "${ED}"/usr/share/man/man1/{aclocal,automake}.1 || die
# remove all config.guess and config.sub files replacing them
# w/a symlink to a specific gnuconfig version
diff --git a/sys-devel/automake/automake-1.12.6.ebuild b/sys-devel/automake/automake-1.12.6.ebuild
index 06a25a3e8519..6d117262fbb7 100644
--- a/sys-devel/automake/automake-1.12.6.ebuild
+++ b/sys-devel/automake/automake-1.12.6.ebuild
@@ -38,7 +38,7 @@ src_compile() {
# slot the info pages. do this w/out munging the source so we don't have
# to depend on texinfo to regen things. #464146 (among others)
slot_info_pages() {
- pushd "${D}"/usr/share/info >/dev/null
+ pushd "${ED}"/usr/share/info >/dev/null
rm -f dir
# Rewrite all the references to other pages.
@@ -68,13 +68,13 @@ src_install() {
emake DESTDIR="${D}" install \
APIVERSION="${SLOT}" pkgvdatadir="/usr/share/${PN}-${SLOT}"
slot_info_pages
- rm "${D}"/usr/share/aclocal/README || die
- rmdir "${D}"/usr/share/aclocal || die
+ rm "${ED}"/usr/share/aclocal/README || die
+ rmdir "${ED}"/usr/share/aclocal || die
dodoc AUTHORS ChangeLog NEWS README THANKS
rm \
- "${D}"/usr/bin/{aclocal,automake} \
- "${D}"/usr/share/man/man1/{aclocal,automake}.1 || die
+ "${ED}"/usr/bin/{aclocal,automake} \
+ "${ED}"/usr/share/man/man1/{aclocal,automake}.1 || die
# remove all config.guess and config.sub files replacing them
# w/a symlink to a specific gnuconfig version
diff --git a/sys-devel/automake/automake-1.13.4-r1.ebuild b/sys-devel/automake/automake-1.13.4-r1.ebuild
index 6e12d6022d21..3f1d61e94c1e 100644
--- a/sys-devel/automake/automake-1.13.4-r1.ebuild
+++ b/sys-devel/automake/automake-1.13.4-r1.ebuild
@@ -44,7 +44,7 @@ src_test() {
# slot the info pages. do this w/out munging the source so we don't have
# to depend on texinfo to regen things. #464146 (among others)
slot_info_pages() {
- pushd "${D}"/usr/share/info >/dev/null
+ pushd "${ED}"/usr/share/info >/dev/null
rm -f dir
# Rewrite all the references to other pages.
@@ -74,13 +74,13 @@ src_install() {
emake DESTDIR="${D}" install \
APIVERSION="${SLOT}" pkgvdatadir="/usr/share/${PN}-${SLOT}"
slot_info_pages
- rm "${D}"/usr/share/aclocal/README || die
- rmdir "${D}"/usr/share/aclocal || die
+ rm "${ED}"/usr/share/aclocal/README || die
+ rmdir "${ED}"/usr/share/aclocal || die
dodoc AUTHORS ChangeLog NEWS README THANKS
rm \
- "${D}"/usr/bin/{aclocal,automake} \
- "${D}"/usr/share/man/man1/{aclocal,automake}.1 || die
+ "${ED}"/usr/bin/{aclocal,automake} \
+ "${ED}"/usr/share/man/man1/{aclocal,automake}.1 || die
# remove all config.guess and config.sub files replacing them
# w/a symlink to a specific gnuconfig version
diff --git a/sys-devel/automake/automake-1.13.4.ebuild b/sys-devel/automake/automake-1.13.4.ebuild
index 57f143ba8ad2..320aaf6feb26 100644
--- a/sys-devel/automake/automake-1.13.4.ebuild
+++ b/sys-devel/automake/automake-1.13.4.ebuild
@@ -43,7 +43,7 @@ src_test() {
# slot the info pages. do this w/out munging the source so we don't have
# to depend on texinfo to regen things. #464146 (among others)
slot_info_pages() {
- pushd "${D}"/usr/share/info >/dev/null
+ pushd "${ED}"/usr/share/info >/dev/null
rm -f dir
# Rewrite all the references to other pages.
@@ -73,13 +73,13 @@ src_install() {
emake DESTDIR="${D}" install \
APIVERSION="${SLOT}" pkgvdatadir="/usr/share/${PN}-${SLOT}"
slot_info_pages
- rm "${D}"/usr/share/aclocal/README || die
- rmdir "${D}"/usr/share/aclocal || die
+ rm "${ED}"/usr/share/aclocal/README || die
+ rmdir "${ED}"/usr/share/aclocal || die
dodoc AUTHORS ChangeLog NEWS README THANKS
rm \
- "${D}"/usr/bin/{aclocal,automake} \
- "${D}"/usr/share/man/man1/{aclocal,automake}.1 || die
+ "${ED}"/usr/bin/{aclocal,automake} \
+ "${ED}"/usr/share/man/man1/{aclocal,automake}.1 || die
# remove all config.guess and config.sub files replacing them
# w/a symlink to a specific gnuconfig version
diff --git a/sys-devel/automake/automake-1.14.1-r1.ebuild b/sys-devel/automake/automake-1.14.1-r1.ebuild
index b1e9964ae94c..53723929eea1 100644
--- a/sys-devel/automake/automake-1.14.1-r1.ebuild
+++ b/sys-devel/automake/automake-1.14.1-r1.ebuild
@@ -56,7 +56,7 @@ src_test() {
# slot the info pages. do this w/out munging the source so we don't have
# to depend on texinfo to regen things. #464146 (among others)
slot_info_pages() {
- pushd "${D}"/usr/share/info >/dev/null
+ pushd "${ED}"/usr/share/info >/dev/null
rm -f dir
# Rewrite all the references to other pages.
@@ -86,13 +86,13 @@ src_install() {
emake DESTDIR="${D}" install \
APIVERSION="${SLOT}" pkgvdatadir="/usr/share/${PN}-${SLOT}"
slot_info_pages
- rm "${D}"/usr/share/aclocal/README || die
- rmdir "${D}"/usr/share/aclocal || die
+ rm "${ED}"/usr/share/aclocal/README || die
+ rmdir "${ED}"/usr/share/aclocal || die
dodoc AUTHORS ChangeLog NEWS README THANKS
rm \
- "${D}"/usr/bin/{aclocal,automake} \
- "${D}"/usr/share/man/man1/{aclocal,automake}.1 || die
+ "${ED}"/usr/bin/{aclocal,automake} \
+ "${ED}"/usr/share/man/man1/{aclocal,automake}.1 || die
# remove all config.guess and config.sub files replacing them
# w/a symlink to a specific gnuconfig version
diff --git a/sys-devel/automake/automake-1.14.1.ebuild b/sys-devel/automake/automake-1.14.1.ebuild
index 3d5a9585f03c..5ebd96756858 100644
--- a/sys-devel/automake/automake-1.14.1.ebuild
+++ b/sys-devel/automake/automake-1.14.1.ebuild
@@ -55,7 +55,7 @@ src_test() {
# slot the info pages. do this w/out munging the source so we don't have
# to depend on texinfo to regen things. #464146 (among others)
slot_info_pages() {
- pushd "${D}"/usr/share/info >/dev/null
+ pushd "${ED}"/usr/share/info >/dev/null
rm -f dir
# Rewrite all the references to other pages.
@@ -85,13 +85,13 @@ src_install() {
emake DESTDIR="${D}" install \
APIVERSION="${SLOT}" pkgvdatadir="/usr/share/${PN}-${SLOT}"
slot_info_pages
- rm "${D}"/usr/share/aclocal/README || die
- rmdir "${D}"/usr/share/aclocal || die
+ rm "${ED}"/usr/share/aclocal/README || die
+ rmdir "${ED}"/usr/share/aclocal || die
dodoc AUTHORS ChangeLog NEWS README THANKS
rm \
- "${D}"/usr/bin/{aclocal,automake} \
- "${D}"/usr/share/man/man1/{aclocal,automake}.1 || die
+ "${ED}"/usr/bin/{aclocal,automake} \
+ "${ED}"/usr/share/man/man1/{aclocal,automake}.1 || die
# remove all config.guess and config.sub files replacing them
# w/a symlink to a specific gnuconfig version
diff --git a/sys-devel/automake/automake-1.15-r1.ebuild b/sys-devel/automake/automake-1.15-r1.ebuild
index b1e9964ae94c..53723929eea1 100644
--- a/sys-devel/automake/automake-1.15-r1.ebuild
+++ b/sys-devel/automake/automake-1.15-r1.ebuild
@@ -56,7 +56,7 @@ src_test() {
# slot the info pages. do this w/out munging the source so we don't have
# to depend on texinfo to regen things. #464146 (among others)
slot_info_pages() {
- pushd "${D}"/usr/share/info >/dev/null
+ pushd "${ED}"/usr/share/info >/dev/null
rm -f dir
# Rewrite all the references to other pages.
@@ -86,13 +86,13 @@ src_install() {
emake DESTDIR="${D}" install \
APIVERSION="${SLOT}" pkgvdatadir="/usr/share/${PN}-${SLOT}"
slot_info_pages
- rm "${D}"/usr/share/aclocal/README || die
- rmdir "${D}"/usr/share/aclocal || die
+ rm "${ED}"/usr/share/aclocal/README || die
+ rmdir "${ED}"/usr/share/aclocal || die
dodoc AUTHORS ChangeLog NEWS README THANKS
rm \
- "${D}"/usr/bin/{aclocal,automake} \
- "${D}"/usr/share/man/man1/{aclocal,automake}.1 || die
+ "${ED}"/usr/bin/{aclocal,automake} \
+ "${ED}"/usr/share/man/man1/{aclocal,automake}.1 || die
# remove all config.guess and config.sub files replacing them
# w/a symlink to a specific gnuconfig version
diff --git a/sys-devel/automake/automake-1.15-r2.ebuild b/sys-devel/automake/automake-1.15-r2.ebuild
index 8e774977cae5..a2262d26f929 100644
--- a/sys-devel/automake/automake-1.15-r2.ebuild
+++ b/sys-devel/automake/automake-1.15-r2.ebuild
@@ -57,7 +57,7 @@ src_test() {
# slot the info pages. do this w/out munging the source so we don't have
# to depend on texinfo to regen things. #464146 (among others)
slot_info_pages() {
- pushd "${D}"/usr/share/info >/dev/null
+ pushd "${ED}"/usr/share/info >/dev/null
rm -f dir
# Rewrite all the references to other pages.
@@ -87,13 +87,13 @@ src_install() {
emake DESTDIR="${D}" install \
APIVERSION="${SLOT}" pkgvdatadir="/usr/share/${PN}-${SLOT}"
slot_info_pages
- rm "${D}"/usr/share/aclocal/README || die
- rmdir "${D}"/usr/share/aclocal || die
+ rm "${ED}"/usr/share/aclocal/README || die
+ rmdir "${ED}"/usr/share/aclocal || die
dodoc AUTHORS ChangeLog NEWS README THANKS
rm \
- "${D}"/usr/bin/{aclocal,automake} \
- "${D}"/usr/share/man/man1/{aclocal,automake}.1 || die
+ "${ED}"/usr/bin/{aclocal,automake} \
+ "${ED}"/usr/share/man/man1/{aclocal,automake}.1 || die
# remove all config.guess and config.sub files replacing them
# w/a symlink to a specific gnuconfig version
diff --git a/sys-devel/automake/automake-1.15.ebuild b/sys-devel/automake/automake-1.15.ebuild
index 3d5a9585f03c..5ebd96756858 100644
--- a/sys-devel/automake/automake-1.15.ebuild
+++ b/sys-devel/automake/automake-1.15.ebuild
@@ -55,7 +55,7 @@ src_test() {
# slot the info pages. do this w/out munging the source so we don't have
# to depend on texinfo to regen things. #464146 (among others)
slot_info_pages() {
- pushd "${D}"/usr/share/info >/dev/null
+ pushd "${ED}"/usr/share/info >/dev/null
rm -f dir
# Rewrite all the references to other pages.
@@ -85,13 +85,13 @@ src_install() {
emake DESTDIR="${D}" install \
APIVERSION="${SLOT}" pkgvdatadir="/usr/share/${PN}-${SLOT}"
slot_info_pages
- rm "${D}"/usr/share/aclocal/README || die
- rmdir "${D}"/usr/share/aclocal || die
+ rm "${ED}"/usr/share/aclocal/README || die
+ rmdir "${ED}"/usr/share/aclocal || die
dodoc AUTHORS ChangeLog NEWS README THANKS
rm \
- "${D}"/usr/bin/{aclocal,automake} \
- "${D}"/usr/share/man/man1/{aclocal,automake}.1 || die
+ "${ED}"/usr/bin/{aclocal,automake} \
+ "${ED}"/usr/share/man/man1/{aclocal,automake}.1 || die
# remove all config.guess and config.sub files replacing them
# w/a symlink to a specific gnuconfig version
diff --git a/sys-devel/automake/automake-1.4_p6-r2.ebuild b/sys-devel/automake/automake-1.4_p6-r2.ebuild
index e72c741c0964..ccb6b0e7b3cf 100644
--- a/sys-devel/automake/automake-1.4_p6-r2.ebuild
+++ b/sys-devel/automake/automake-1.4_p6-r2.ebuild
@@ -40,7 +40,7 @@ src_prepare() {
# slot the info pages. do this w/out munging the source so we don't have
# to depend on texinfo to regen things. #464146 (among others)
slot_info_pages() {
- pushd "${D}"/usr/share/info >/dev/null
+ pushd "${ED}"/usr/share/info >/dev/null
rm -f dir
# Rewrite all the references to other pages.
@@ -71,7 +71,7 @@ src_install() {
pkgdatadir=/usr/share/automake-${SLOT} \
m4datadir=/usr/share/aclocal-${SLOT}
slot_info_pages
- rm -f "${D}"/usr/bin/{aclocal,automake}
+ rm -f "${ED}"/usr/bin/{aclocal,automake}
dosym automake-${SLOT} /usr/share/automake
dodoc NEWS README THANKS TODO AUTHORS ChangeLog
diff --git a/sys-devel/automake/automake-1.5-r2.ebuild b/sys-devel/automake/automake-1.5-r2.ebuild
index 467a825477d0..6a3362f1c9a9 100644
--- a/sys-devel/automake/automake-1.5-r2.ebuild
+++ b/sys-devel/automake/automake-1.5-r2.ebuild
@@ -36,7 +36,7 @@ src_prepare() {
# slot the info pages. do this w/out munging the source so we don't have
# to depend on texinfo to regen things. #464146 (among others)
slot_info_pages() {
- pushd "${D}"/usr/share/info >/dev/null
+ pushd "${ED}"/usr/share/info >/dev/null
rm -f dir
# Rewrite all the references to other pages.
@@ -68,8 +68,8 @@ src_install() {
local x
for x in aclocal automake ; do
- mv "${D}"/usr/bin/${x}{,-${SLOT}} || die "rename ${x}"
- mv "${D}"/usr/share/${x}{,-${SLOT}} || die "move ${x}"
+ mv "${ED}"/usr/bin/${x}{,-${SLOT}} || die "rename ${x}"
+ mv "${ED}"/usr/share/${x}{,-${SLOT}} || die "move ${x}"
done
# remove all config.guess and config.sub files replacing them
diff --git a/sys-devel/automake/automake-1.6.3-r2.ebuild b/sys-devel/automake/automake-1.6.3-r2.ebuild
index 212b6cd7c825..cc812b0f4ed2 100644
--- a/sys-devel/automake/automake-1.6.3-r2.ebuild
+++ b/sys-devel/automake/automake-1.6.3-r2.ebuild
@@ -33,7 +33,7 @@ src_prepare() {
# slot the info pages. do this w/out munging the source so we don't have
# to depend on texinfo to regen things. #464146 (among others)
slot_info_pages() {
- pushd "${D}"/usr/share/info >/dev/null
+ pushd "${ED}"/usr/share/info >/dev/null
rm -f dir
# Rewrite all the references to other pages.
@@ -62,7 +62,7 @@ slot_info_pages() {
src_install() {
default
slot_info_pages
- rm -f "${D}"/usr/bin/{aclocal,automake}
+ rm -f "${ED}"/usr/bin/{aclocal,automake}
# remove all config.guess and config.sub files replacing them
# w/a symlink to a specific gnuconfig version
diff --git a/sys-devel/automake/automake-1.7.9-r3.ebuild b/sys-devel/automake/automake-1.7.9-r3.ebuild
index cbb9c79f8802..850938f15078 100644
--- a/sys-devel/automake/automake-1.7.9-r3.ebuild
+++ b/sys-devel/automake/automake-1.7.9-r3.ebuild
@@ -36,7 +36,7 @@ src_prepare() {
# slot the info pages. do this w/out munging the source so we don't have
# to depend on texinfo to regen things. #464146 (among others)
slot_info_pages() {
- pushd "${D}"/usr/share/info >/dev/null
+ pushd "${ED}"/usr/share/info >/dev/null
rm -f dir
# Rewrite all the references to other pages.
@@ -65,7 +65,7 @@ slot_info_pages() {
src_install() {
default
slot_info_pages
- rm -f "${D}"/usr/bin/{aclocal,automake}
+ rm -f "${ED}"/usr/bin/{aclocal,automake}
# remove all config.guess and config.sub files replacing them
# w/a symlink to a specific gnuconfig version
diff --git a/sys-devel/automake/automake-1.8.5-r5.ebuild b/sys-devel/automake/automake-1.8.5-r5.ebuild
index b2be27b73fec..6a2438166f88 100644
--- a/sys-devel/automake/automake-1.8.5-r5.ebuild
+++ b/sys-devel/automake/automake-1.8.5-r5.ebuild
@@ -36,7 +36,7 @@ src_prepare() {
# slot the info pages. do this w/out munging the source so we don't have
# to depend on texinfo to regen things. #464146 (among others)
slot_info_pages() {
- pushd "${D}"/usr/share/info >/dev/null
+ pushd "${ED}"/usr/share/info >/dev/null
rm -f dir
# Rewrite all the references to other pages.
@@ -65,7 +65,7 @@ slot_info_pages() {
src_install() {
default
slot_info_pages
- rm -f "${D}"/usr/bin/{aclocal,automake}
+ rm -f "${ED}"/usr/bin/{aclocal,automake}
# remove all config.guess and config.sub files replacing them
# w/a symlink to a specific gnuconfig version
diff --git a/sys-devel/automake/automake-1.9.6-r4.ebuild b/sys-devel/automake/automake-1.9.6-r4.ebuild
index d26eca3c484b..de96fc6618e7 100644
--- a/sys-devel/automake/automake-1.9.6-r4.ebuild
+++ b/sys-devel/automake/automake-1.9.6-r4.ebuild
@@ -39,7 +39,7 @@ src_prepare() {
# slot the info pages. do this w/out munging the source so we don't have
# to depend on texinfo to regen things. #464146 (among others)
slot_info_pages() {
- pushd "${D}"/usr/share/info >/dev/null
+ pushd "${ED}"/usr/share/info >/dev/null
rm -f dir
# Rewrite all the references to other pages.
@@ -73,7 +73,7 @@ src_install() {
for x in aclocal automake ; do
help2man "perl -Ilib ${x}" > ${x}-${SLOT}.1
doman ${x}-${SLOT}.1
- rm -f "${D}"/usr/bin/${x}
+ rm -f "${ED}"/usr/bin/${x}
done
# remove all config.guess and config.sub files replacing them
diff --git a/sys-devel/automake/automake-9999.ebuild b/sys-devel/automake/automake-9999.ebuild
index 48a6b310ffc0..38f880becb63 100644
--- a/sys-devel/automake/automake-9999.ebuild
+++ b/sys-devel/automake/automake-9999.ebuild
@@ -45,7 +45,7 @@ src_test() {
# slot the info pages. do this w/out munging the source so we don't have
# to depend on texinfo to regen things. #464146 (among others)
slot_info_pages() {
- pushd "${D}"/usr/share/info >/dev/null
+ pushd "${ED}"/usr/share/info >/dev/null
rm -f dir
# Rewrite all the references to other pages.
@@ -80,7 +80,7 @@ src_install() {
for x in aclocal automake ; do
help2man "perl -Ilib ${x}" > ${x}-${SLOT}.1
doman ${x}-${SLOT}.1
- rm -f "${D}"/usr/bin/${x}
+ rm -f "${ED}"/usr/bin/${x}
done
# remove all config.guess and config.sub files replacing them