summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-libs/hamlib/Manifest3
-rw-r--r--media-libs/hamlib/hamlib-1.2.15.3-r1.ebuild86
-rw-r--r--media-libs/hamlib/hamlib-3.0.1.ebuild82
-rw-r--r--media-libs/hamlib/hamlib-3.0.ebuild82
4 files changed, 0 insertions, 253 deletions
diff --git a/media-libs/hamlib/Manifest b/media-libs/hamlib/Manifest
index 985cbbdbbded..85e2cb9b8904 100644
--- a/media-libs/hamlib/Manifest
+++ b/media-libs/hamlib/Manifest
@@ -1,4 +1 @@
-DIST hamlib-1.2.15.3.tar.gz 1675879 SHA256 a2ca4549e4fd99d6e5600e354ebcb57502611aa63c6921c1b8a825289833f75e SHA512 88f9cb8d82d813ac02944def0adf6eada0e4ed1407f60e344d51172462d51ab0c3ddd9cbf9ef8cbd61efba6c4158a77acb7c23b886e174c9a082bf1dd11f5baa WHIRLPOOL 33f8e114d05c778e30c1b634e2494cd3f9d89213ccc58b34b4d195bb4f1c803c5451f54c8e232bf276a1daebe6c0a01bae73a51fa90538fe537d3b5bf4ce91de
-DIST hamlib-3.0.1.tar.gz 2074254 SHA256 3fec97ea326d02aa8f35834c4af34194a3f544e6212f391397d788c566b44e32 SHA512 c71d76343092da03dd3bd8470494fe9bd2789597ab3c83a5c98e007c94016c59de21cdbfb461fa6093e27ca8f300cfed65b4ba7e579b3070c6ed0bf6a4de38b2 WHIRLPOOL 95b2ac3d692461085009dc3c45a699c106e0a49e4367d138d18238b32444ffc0a160281c146eb53721ff2e4f12daad3262cf4c772bab318a3b20328d84732adb
-DIST hamlib-3.0.tar.gz 2074188 SHA256 bc16546161a47e21a44a710a40aeb0bce478f112bffcc4f253eb27e150f1c21e SHA512 16ac66ab91d44c364054aa6ba8292a6538886744d83a83eb0887f55407f836e1d4a402cc7a41576594bea8100c2eefa26bae212f767a68b2a4db7a709166cbd2 WHIRLPOOL 31f96037260160e83f376e87f35669cac73772b73d4b50bf78b32893de17d36e02d41d71ab393ac6fa27efbb387a88d71bdc8cb4a7c02c7251b141afea6d82a9
DIST hamlib-3.1.tar.gz 2130615 SHA256 682304c3e88ff6ccfd6a5fc28b33bcc95d2d0a54321973fef015ff62570c994e SHA512 befc5c407379e30711bde2affb9c191add6dbb04a36c1309f8771170cf04156c48609a094775638036282e085de6c78d09ef8d2760d69c595471e16e985e0885 WHIRLPOOL d73b54161cf452db1edcf32d01caccb153ce332682f92ef2e4c6e9092febd801242dd19ffa87626b24d07cc11e4f8745f2872dc900692dd7d1ef759110399c6b
diff --git a/media-libs/hamlib/hamlib-1.2.15.3-r1.ebuild b/media-libs/hamlib/hamlib-1.2.15.3-r1.ebuild
deleted file mode 100644
index 4db2846cf746..000000000000
--- a/media-libs/hamlib/hamlib-1.2.15.3-r1.ebuild
+++ /dev/null
@@ -1,86 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit autotools-utils eutils multilib python-single-r1
-
-DESCRIPTION="Ham radio backend rig control libraries"
-HOMEPAGE="https://sourceforge.net/apps/mediawiki/hamlib"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="LGPL-2 GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86 ~x86-fbsd"
-IUSE="doc python tcl"
-
-RESTRICT="test"
-
-RDEPEND="
- =virtual/libusb-0*
- dev-libs/libxml2
- python? ( ${PYTHON_DEPS} )
- tcl? ( dev-lang/tcl:0= )"
-
-DEPEND=" ${RDEPEND}
- virtual/pkgconfig
- dev-lang/swig
- >=sys-devel/libtool-2.2
- doc? ( app-doc/doxygen )"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-DOCS=(AUTHORS NEWS PLAN README README.betatester README.developer TODO)
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
-}
-
-src_prepare() {
- # fix hardcoded libdir paths
- sed -i -e "s#fix}/lib#fix}/$(get_libdir)/hamlib#" \
- -e "s#fix}/include#fix}/include/hamlib#" \
- hamlib.pc.in || die "sed failed"
-
- # make building of documentation compatible with autotools-utils
- sed -i -e "s/doc:/html:/g" doc/Makefile.am || die "sed failed"
-
- # fix tcl lib path
- epatch "${FILESDIR}"/${PN}-1.2.11-bindings.diff
-
- # use CXXFLAGS for building c++ components (bug #453240)
- epatch "${FILESDIR}"/${P}-configure.diff
-
- eautoreconf
-}
-
-src_configure() {
- local myeconfargs=(
- --libdir=/usr/$(get_libdir)/hamlib
- --disable-static
- --with-rpc-backends
- --without-perl-binding
- $(use_with python python-binding)
- $(use_enable tcl tcl-binding)
- --disable-silent-rules
- )
- autotools-utils_src_configure
-}
-
-src_compile() {
- autotools-utils_src_compile
- use doc && autotools-utils_src_compile html
-}
-
-src_install() {
- use doc && HTML_DOCS=("${AUTOTOOLS_BUILD_DIR}/doc/html/")
- autotools-utils_src_install
-
- insinto /usr/$(get_libdir)/pkgconfig
- doins "${AUTOTOOLS_BUILD_DIR}"/hamlib.pc || die "doins failed"
-
- echo "LDPATH=/usr/$(get_libdir)/hamlib" > "${T}"/73hamlib
- doenvd "${T}"/73hamlib || die "doenvd failed"
-}
diff --git a/media-libs/hamlib/hamlib-3.0.1.ebuild b/media-libs/hamlib/hamlib-3.0.1.ebuild
deleted file mode 100644
index a97e85913a9e..000000000000
--- a/media-libs/hamlib/hamlib-3.0.1.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit autotools-utils eutils multilib python-single-r1
-
-DESCRIPTION="Ham radio backend rig control libraries"
-HOMEPAGE="https://sourceforge.net/apps/mediawiki/hamlib"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="LGPL-2 GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~x86-fbsd"
-IUSE="doc perl python tcl"
-
-RESTRICT="test"
-
-RDEPEND="
- =virtual/libusb-0*
- dev-libs/libxml2
- sys-libs/readline:0
- perl? ( dev-lang/perl )
- python? ( ${PYTHON_DEPS} )
- tcl? ( dev-lang/tcl:0= )"
-
-DEPEND=" ${RDEPEND}
- virtual/pkgconfig
- dev-lang/swig
- >=sys-devel/libtool-2.2
- doc? ( app-doc/doxygen )"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-DOCS=(AUTHORS NEWS PLAN README README.betatester README.developer TODO)
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
-}
-
-src_prepare() {
- # fix hardcoded libdir paths
- sed -i -e "s#fix}/lib#fix}/$(get_libdir)/hamlib#" \
- -e "s#fix}/include#fix}/include/hamlib#" \
- hamlib.pc.in || die "sed failed"
-
- # make building of documentation compatible with autotools-utils
- sed -i -e "s/doc:/html:/g" doc/Makefile.am || die "sed failed"
-
- eautoreconf
-}
-
-src_configure() {
- local myeconfargs=(
- --libdir=/usr/$(get_libdir)/hamlib
- --disable-static
- --with-xml-support
- $(use_with perl perl-binding)
- $(use_with python python-binding)
- $(use_with tcl tcl-binding)
- --disable-silent-rules
- )
- autotools-utils_src_configure
-}
-
-src_compile() {
- autotools-utils_src_compile
- use doc && autotools-utils_src_compile html
-}
-
-src_install() {
- use doc && HTML_DOCS=("${AUTOTOOLS_BUILD_DIR}/doc/html/")
- autotools-utils_src_install
-
- insinto /usr/$(get_libdir)/pkgconfig
- doins "${AUTOTOOLS_BUILD_DIR}"/hamlib.pc || die "doins failed"
-
- echo "LDPATH=/usr/$(get_libdir)/hamlib" > "${T}"/73hamlib
- doenvd "${T}"/73hamlib || die "doenvd failed"
-}
diff --git a/media-libs/hamlib/hamlib-3.0.ebuild b/media-libs/hamlib/hamlib-3.0.ebuild
deleted file mode 100644
index 203e299e1de3..000000000000
--- a/media-libs/hamlib/hamlib-3.0.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit autotools-utils eutils multilib python-single-r1
-
-DESCRIPTION="Ham radio backend rig control libraries"
-HOMEPAGE="https://sourceforge.net/apps/mediawiki/hamlib"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="LGPL-2 GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86 ~x86-fbsd"
-IUSE="doc perl python tcl"
-
-RESTRICT="test"
-
-RDEPEND="
- =virtual/libusb-0*
- dev-libs/libxml2
- sys-libs/readline:0
- perl? ( dev-lang/perl )
- python? ( ${PYTHON_DEPS} )
- tcl? ( dev-lang/tcl:0= )"
-
-DEPEND=" ${RDEPEND}
- virtual/pkgconfig
- dev-lang/swig
- >=sys-devel/libtool-2.2
- doc? ( app-doc/doxygen )"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-DOCS=(AUTHORS NEWS PLAN README README.betatester README.developer TODO)
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
-}
-
-src_prepare() {
- # fix hardcoded libdir paths
- sed -i -e "s#fix}/lib#fix}/$(get_libdir)/hamlib#" \
- -e "s#fix}/include#fix}/include/hamlib#" \
- hamlib.pc.in || die "sed failed"
-
- # make building of documentation compatible with autotools-utils
- sed -i -e "s/doc:/html:/g" doc/Makefile.am || die "sed failed"
-
- eautoreconf
-}
-
-src_configure() {
- local myeconfargs=(
- --libdir=/usr/$(get_libdir)/hamlib
- --disable-static
- --with-xml-support
- $(use_with perl perl-binding)
- $(use_with python python-binding)
- $(use_with tcl tcl-binding)
- --disable-silent-rules
- )
- autotools-utils_src_configure
-}
-
-src_compile() {
- autotools-utils_src_compile
- use doc && autotools-utils_src_compile html
-}
-
-src_install() {
- use doc && HTML_DOCS=("${AUTOTOOLS_BUILD_DIR}/doc/html/")
- autotools-utils_src_install
-
- insinto /usr/$(get_libdir)/pkgconfig
- doins "${AUTOTOOLS_BUILD_DIR}"/hamlib.pc || die "doins failed"
-
- echo "LDPATH=/usr/$(get_libdir)/hamlib" > "${T}"/73hamlib
- doenvd "${T}"/73hamlib || die "doenvd failed"
-}