summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-lang/php/php-5.6.23-r2.ebuild (renamed from dev-lang/php/php-5.6.23-r1.ebuild)5
-rw-r--r--dev-lang/php/php-7.0.8-r1.ebuild (renamed from dev-lang/php/php-7.0.8.ebuild)5
2 files changed, 6 insertions, 4 deletions
diff --git a/dev-lang/php/php-5.6.23-r1.ebuild b/dev-lang/php/php-5.6.23-r2.ebuild
index 0696638dbbe6..071afe4e72df 100644
--- a/dev-lang/php/php-5.6.23-r1.ebuild
+++ b/dev-lang/php/php-5.6.23-r2.ebuild
@@ -255,7 +255,7 @@ php_install_ini() {
dodir "${PHP_EXT_INI_DIR#${EPREFIX}}"
dodir "${PHP_EXT_INI_DIR_ACTIVE#${EPREFIX}}"
- if use_if_iuse opcache; then
+ if use opcache; then
elog "Adding opcache to $PHP_EXT_INI_DIR"
echo "zend_extension=${PHP_DESTDIR}/$(get_libdir)/opcache.so" >> \
"${D}/${PHP_EXT_INI_DIR}"/opcache.ini
@@ -666,7 +666,8 @@ src_install() {
done
# Installing opcache module
- if use_if_iuse opcache ; then
+ if use opcache ; then
+ into "${PHP_DESTDIR#${EPREFIX}}"
dolib.so "modules/opcache$(get_libname)"
fi
diff --git a/dev-lang/php/php-7.0.8.ebuild b/dev-lang/php/php-7.0.8-r1.ebuild
index 5925bb3a4da4..9bd15572e425 100644
--- a/dev-lang/php/php-7.0.8.ebuild
+++ b/dev-lang/php/php-7.0.8-r1.ebuild
@@ -246,7 +246,7 @@ php_install_ini() {
dodir "${PHP_EXT_INI_DIR#${EPREFIX}}"
dodir "${PHP_EXT_INI_DIR_ACTIVE#${EPREFIX}}"
- if use_if_iuse opcache; then
+ if use opcache; then
elog "Adding opcache to $PHP_EXT_INI_DIR"
echo "zend_extension=${PHP_DESTDIR}/$(get_libdir)/opcache.so" >> \
"${D}/${PHP_EXT_INI_DIR}"/opcache.ini
@@ -660,7 +660,8 @@ src_install() {
done
# Installing opcache module
- if use_if_iuse opcache ; then
+ if use opcache ; then
+ into "${PHP_DESTDIR#${EPREFIX}}"
dolib.so "modules/opcache$(get_libname)"
fi