summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-libs/libpsl/libpsl-0.20.2.ebuild35
1 files changed, 19 insertions, 16 deletions
diff --git a/net-libs/libpsl/libpsl-0.20.2.ebuild b/net-libs/libpsl/libpsl-0.20.2.ebuild
index 6eed8f0695e3..b8ec1fa9700b 100644
--- a/net-libs/libpsl/libpsl-0.20.2.ebuild
+++ b/net-libs/libpsl/libpsl-0.20.2.ebuild
@@ -14,10 +14,8 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="icu +idn +man"
-REQUIRED_USE="^^ ( icu idn )"
-
RDEPEND="
- icu? ( dev-libs/icu:=[${MULTILIB_USEDEP}] )
+ icu? ( !idn? ( dev-libs/icu:=[${MULTILIB_USEDEP}] ) )
idn? (
dev-libs/libunistring[${MULTILIB_USEDEP}]
net-dns/libidn2:=[${MULTILIB_USEDEP}]
@@ -34,6 +32,13 @@ BDEPEND="
man? ( dev-libs/libxslt )
"
+pkg_pretend() {
+ if use icu && use idn ; then
+ ewarn "\"icu\" and \"idn\" USE flags are enabled."
+ ewarn "Using \"idn\"."
+ fi
+}
+
multilib_src_configure() {
local myeconfargs=(
--disable-asan
@@ -42,19 +47,17 @@ multilib_src_configure() {
$(use_enable man)
)
- if use icu || use idn ; then
- if use icu ; then
- myeconfargs+=(
- --enable-builtin=libicu
- --enable-runtime=libicu
- )
- fi
- if use idn ; then
- myeconfargs+=(
- --enable-builtin=libidn2
- --enable-runtime=libidn2
- )
- fi
+ # Prefer idn even if icu is in USE as well
+ if use idn ; then
+ myeconfargs+=(
+ --enable-builtin=libidn2
+ --enable-runtime=libidn2
+ )
+ elif use icu ; then
+ myeconfargs+=(
+ --enable-builtin=libicu
+ --enable-runtime=libicu
+ )
else
myeconfargs+=( --disable-runtime )
fi