summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/pygpu/Manifest1
-rw-r--r--dev-python/pygpu/pygpu-0.6.7.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/pygpu/Manifest b/dev-python/pygpu/Manifest
index aa8ffb1ec978..11d6f31f2fa7 100644
--- a/dev-python/pygpu/Manifest
+++ b/dev-python/pygpu/Manifest
@@ -1 +1,2 @@
DIST pygpu-0.6.0.tar.gz 232281 SHA256 a58a0624e894475a4955aaea25e82261c69b4d22c8f15ec07041a4ba176d35af SHA512 ef2b37d7752d7b19e6034ca1992dfa0c82806bae7a15ce54aad785f5abbe06e57a77b804699c55b3b7dc94496afb22acaf3a43cfc15148c150f2c93085c23080 WHIRLPOOL bf702ac1a6f7dd38e59bfc3af3854055730f0ac005ef03b206daf43bab90e930fbe04c8c2765bd673ed3d78b501a5c01f0ba93c22565c99e8aedd6a8049873ac
+DIST pygpu-0.6.7.tar.gz 256440 SHA256 5d3d6f54e53ffe1a43ca86329cf3e5b8b8c1b412cf222df092d741a4de212c2e SHA512 39cdb67ec12d0f939d7a3ebef9726c40e64387413200addbeaf205db4151d09efd90118fec4a71b9d1f81fdde9b52e37d2d97763bf2cc9efa1667c5b9ff716b2 WHIRLPOOL 544c5fd2715c4df9a39c497e4bcef22d95eae8a39f3621d57c3b68ace1e43467855b70209e15b1b8dc08c6a190e14d1307c19084006cddbdb964148442b4453d
diff --git a/dev-python/pygpu/pygpu-0.6.7.ebuild b/dev-python/pygpu/pygpu-0.6.7.ebuild
new file mode 100644
index 000000000000..71838169b36f
--- /dev/null
+++ b/dev-python/pygpu/pygpu-0.6.7.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+
+inherit distutils-r1
+
+MYPV=${PV/_/-}
+
+DESCRIPTION="Python bindings to libgpuarray"
+HOMEPAGE="http://deeplearning.net/software/libgpuarray/"
+SRC_URI="https://github.com/Theano/libgpuarray/archive/v${MYPV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="cuda opencl test"
+
+RDEPEND="
+ dev-python/mako[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-libs/libgpuarray:=[cuda?,opencl?]
+"
+DEPEND="${RDEPEND}
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"
+
+S="${WORKDIR}/libgpuarray-${MYPV}"
+
+python_test() {
+ local DEVICE=cuda
+ use opencl && DEVICE=opencl
+ nosetests -svw "${BUILD_DIR}/lib/" || die
+}