summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-vcs/gitg/Manifest1
-rw-r--r--dev-vcs/gitg/gitg-3.18.0.ebuild82
2 files changed, 83 insertions, 0 deletions
diff --git a/dev-vcs/gitg/Manifest b/dev-vcs/gitg/Manifest
index 5eef70ef7ccd..ea0be3e366c7 100644
--- a/dev-vcs/gitg/Manifest
+++ b/dev-vcs/gitg/Manifest
@@ -1 +1,2 @@
DIST gitg-3.16.1.tar.xz 1322412 SHA256 914e964402dadda152c7e034906d84e266c474603f58bc1a300f2a1659615569 SHA512 30ea13cfbd14d82db4d0db5ff5ffd456a8ceaa2364e8f3b9eff224c268de46b5dab070a068b3dc9497c7acd90023f60618a4bd5041dab35516ca336421454419 WHIRLPOOL 2774a264e00e28a27728ce4c7791a0340702893c52f32dd141f1ffc682516c4643a94d62b21ddc959b6fbb35c7cff73942cd62a77bcf3ac22991853bfe4f6ec9
+DIST gitg-3.18.0.tar.xz 1413188 SHA256 fa4b7b9c492f13f5f1d864af1281ea377ac8c7619c856e05f533b18989edf421 SHA512 df6944df057d6863ec6a551749edf4d003bf9954c474b0d83ef1476747df210f1e7ead4d007dce06de6f84e25afcafb8aa4f61d8af703861c014c4189cf008d0 WHIRLPOOL 4a27708999e33a533988d62e94a2ad2ee6424184d9862e79bd5dd4a1033e38505672f407f492d9831465249cae68b20a112de6d5737286d28d6d952793c33265
diff --git a/dev-vcs/gitg/gitg-3.18.0.ebuild b/dev-vcs/gitg/gitg-3.18.0.ebuild
new file mode 100644
index 000000000000..679ec1203fbb
--- /dev/null
+++ b/dev-vcs/gitg/gitg-3.18.0.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+GCONF_DEBUG="no"
+PYTHON_COMPAT=( python{3_3,3_4} )
+
+inherit gnome2 python-r1 vala
+
+DESCRIPTION="git repository viewer for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Gitg"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+IUSE="debug glade +python"
+REQUIRED_USE="python? ( ^^ ( $(python_gen_useflags '*') ) )"
+
+# test if unbundling of libgd is possible
+# Currently it seems not to be (unstable API/ABI)
+RDEPEND="
+ app-crypt/libsecret
+ dev-libs/libgee:0.8[introspection]
+ >=dev-libs/json-glib-0.16
+ >=app-text/gtkspell-3.0.3:3
+ >=dev-libs/glib-2.38:2[dbus]
+ >=dev-libs/gobject-introspection-0.10.1:=
+ dev-libs/libgit2:=[threads]
+
+ >=dev-libs/libgit2-glib-0.23.5[ssh]
+ <dev-libs/libgit2-glib-0.24.0
+
+ >=dev-libs/libpeas-1.5.0[gtk]
+ >=gnome-base/gsettings-desktop-schemas-0.1.1
+ >=net-libs/webkit-gtk-2.2:4[introspection]
+ >=x11-libs/gtk+-3.12.0:3
+ >=x11-libs/gtksourceview-3.10:3.0
+ >=x11-themes/gnome-icon-theme-symbolic-3.10
+ glade? ( >=dev-util/glade-3.2:3.10 )
+ python? (
+ ${PYTHON_DEPS}
+ dev-libs/libpeas[python,${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ )
+"
+DEPEND="${RDEPEND}
+ >=dev-libs/libgit2-glib-0.22.0[vala]
+ gnome-base/gnome-common
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+ >=dev-util/intltool-0.40
+ $(vala_depend)
+"
+
+pkg_setup() {
+ use python && [[ ${MERGE_TYPE} != binary ]] && python_setup
+}
+
+src_prepare() {
+ sed \
+ -e '/CFLAGS/s:-g::g' \
+ -e '/CFLAGS/s:-O0::g' \
+ -i configure.ac || die
+
+ gnome2_src_prepare
+ vala_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ --disable-deprecations \
+ $(use_enable debug) \
+ $(use_enable glade glade-catalog) \
+ $(use_enable python)
+}
+
+src_install() {
+ gnome2_src_install -j1
+}