summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-im/signal-desktop-bin/Manifest1
-rw-r--r--net-im/signal-desktop-bin/signal-desktop-bin-1.15.5.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/net-im/signal-desktop-bin/Manifest b/net-im/signal-desktop-bin/Manifest
index d6fa3694ee8e..6f106c3ff38d 100644
--- a/net-im/signal-desktop-bin/Manifest
+++ b/net-im/signal-desktop-bin/Manifest
@@ -1 +1,2 @@
DIST signal-desktop_1.15.4_amd64.deb 70043292 BLAKE2B 9cd0956fd08f624da4712dbda51d26b996edc5b4dd383989b4b70182a48b6a1efd8486ebf59b26a7c25851bd49b76bd736aa1906b4625d64c3816befd89f1fd7 SHA512 204b07c965704a7dcac6d6bc2e8769f9170217744742ecd73e80cc10d148ebde15ced069709fed60c5ed888d5b68a2213079ae60bc68c8a47300d979ed390945
+DIST signal-desktop_1.15.5_amd64.deb 70045774 BLAKE2B d315397d87d82c9b2b59795f433baf3d0312ced48742478626e28f23448549acec57e384047417125869e648c69c3f28a19724efc44f594588b3682666e2627f SHA512 91c38d04e949168d01a04636ac01abea52499432e1d898b04741bacb2509c3595001e785ff92e3e23371bf0ea94d304da83b3f1d50b93dbbf8e2a1128388a16e
diff --git a/net-im/signal-desktop-bin/signal-desktop-bin-1.15.5.ebuild b/net-im/signal-desktop-bin/signal-desktop-bin-1.15.5.ebuild
new file mode 100644
index 000000000000..533fd0506812
--- /dev/null
+++ b/net-im/signal-desktop-bin/signal-desktop-bin-1.15.5.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN="${PN/-bin/}"
+
+inherit gnome2-utils pax-utils unpacker xdg-utils
+
+DESCRIPTION="Allows you to send and receive messages of Signal Messenger on your computer"
+HOMEPAGE="https://signal.org/
+ https://github.com/WhisperSystems/Signal-Desktop"
+SRC_URI="https://updates.signal.org/desktop/apt/pool/main/s/${MY_PN}/${MY_PN}_${PV}_amd64.deb"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ gnome-base/gconf:2
+ dev-libs/nss
+ x11-libs/gtk+:3[X]
+ x11-libs/libXScrnSaver
+ x11-libs/libXtst
+ net-print/cups
+ "
+
+QA_PREBUILT="opt/Signal/signal-desktop
+ opt/Signal/libnode.so
+ opt/Signal/libffmpeg.so"
+
+S="${WORKDIR}"
+
+src_prepare(){
+ default
+ sed -e 's|\("/opt/Signal/signal-desktop"\)|\1 --start-in-tray|g' \
+ -i usr/share/applications/signal-desktop.desktop || die
+}
+
+src_install() {
+ insinto /
+ dodoc -r usr/share/doc/signal-desktop/.
+ doins -r opt
+ insinto /usr/share
+ doins -r usr/share/applications
+ doins -r usr/share/icons
+ fperms +x /opt/Signal/signal-desktop
+ pax-mark m opt/Signal/signal-desktop
+
+ dosym ../../opt/Signal/${MY_PN} /usr/bin/${MY_PN}
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ gnome2_icon_cache_update
+}