summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-libs/libunwind/files/libunwind-1.2.1-fix_version_macros.patch13
-rw-r--r--sys-libs/libunwind/libunwind-1.2.1-r1.ebuild (renamed from sys-libs/libunwind/libunwind-1.2.1.ebuild)6
2 files changed, 17 insertions, 2 deletions
diff --git a/sys-libs/libunwind/files/libunwind-1.2.1-fix_version_macros.patch b/sys-libs/libunwind/files/libunwind-1.2.1-fix_version_macros.patch
new file mode 100644
index 000000000000..63202937084c
--- /dev/null
+++ b/sys-libs/libunwind/files/libunwind-1.2.1-fix_version_macros.patch
@@ -0,0 +1,13 @@
+diff --git a/configure.ac b/configure.ac
+index a254bbe..fe0247b 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -1,6 +1,6 @@
+ define(pkg_major, 1)
+-define(pkg_minor, 2.1)
+-define(pkg_extra, )
++define(pkg_minor, 2)
++define(pkg_extra, 1)
+ define(pkg_maintainer, libunwind-devel@nongnu.org)
+ define(mkvers, $1.$2$3)
+ dnl Process this file with autoconf to produce a configure script.
diff --git a/sys-libs/libunwind/libunwind-1.2.1.ebuild b/sys-libs/libunwind/libunwind-1.2.1-r1.ebuild
index b03e4212353e..8bdde358d133 100644
--- a/sys-libs/libunwind/libunwind-1.2.1.ebuild
+++ b/sys-libs/libunwind/libunwind-1.2.1-r1.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
MY_PV=${PV/_/-}
MY_P=${PN}-${MY_PV}
-inherit eutils libtool multilib-minimal
+inherit autotools eutils libtool multilib-minimal
DESCRIPTION="Portable and efficient API to determine the call-chain of a program"
HOMEPAGE="https://savannah.nongnu.org/projects/libunwind"
@@ -47,6 +47,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-1.2-ia64-undwarf.patch
"${FILESDIR}"/${PN}-1.2-ia64-ptrace-coredump.patch
"${FILESDIR}"/${PN}-1.2-ia64-missing.patch
+ "${FILESDIR}"/${PN}-1.2.1-fix_version_macros.patch
)
src_prepare() {
@@ -57,6 +58,7 @@ src_prepare() {
sed -i -e '/^SUBDIRS/s:tests::' Makefile.in || die
elibtoolize
+ eautoreconf
}
multilib_src_configure() {