summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'acct-user/git/git-0-r2.ebuild')
-rw-r--r--acct-user/git/git-0-r2.ebuild31
1 files changed, 0 insertions, 31 deletions
diff --git a/acct-user/git/git-0-r2.ebuild b/acct-user/git/git-0-r2.ebuild
deleted file mode 100644
index 18e2d5f67173..000000000000
--- a/acct-user/git/git-0-r2.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 2019-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit acct-user
-
-DESCRIPTION="Git repository hosting user"
-
-IUSE="git gitea gitolite"
-REQUIRED_USE="^^ ( git gitea gitolite )"
-
-ACCT_USER_ID=196
-ACCT_USER_HOME_OWNER=git:git
-ACCT_USER_HOME_PERMS=750
-ACCT_USER_SHELL=/bin/sh
-ACCT_USER_GROUPS=( git )
-
-acct-user_add_deps
-
-pkg_setup() {
- if use git; then
- ACCT_USER_HOME=/var/lib/git
- elif use gitea; then
- ACCT_USER_HOME=/var/lib/gitea
- elif use gitolite; then
- ACCT_USER_HOME=/var/lib/gitolite
- else
- die "Incorrect USE flag combination"
- fi
-}