summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'acct-user/logcheck/logcheck-0-r3.ebuild')
-rw-r--r--acct-user/logcheck/logcheck-0-r3.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/acct-user/logcheck/logcheck-0-r3.ebuild b/acct-user/logcheck/logcheck-0-r3.ebuild
new file mode 100644
index 000000000000..17b949d61f95
--- /dev/null
+++ b/acct-user/logcheck/logcheck-0-r3.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit acct-user
+
+DESCRIPTION="User for app-admin/logcheck"
+IUSE="systemd"
+
+ACCT_USER_GROUPS=( "logcheck" )
+ACCT_USER_ID="284"
+
+RDEPEND="systemd? ( acct-group/systemd-journal )"
+
+acct-user_add_deps
+
+pkg_setup() {
+ # Allow the 'logcheck' user to view the systemd journal.
+ if use systemd; then
+ ACCT_USER_GROUPS+=( systemd-journal )
+ fi
+}