summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'acct-user/root/root-0-r3.ebuild')
-rw-r--r--acct-user/root/root-0-r3.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/acct-user/root/root-0-r3.ebuild b/acct-user/root/root-0-r3.ebuild
new file mode 100644
index 000000000000..dcb37bf77d3e
--- /dev/null
+++ b/acct-user/root/root-0-r3.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit acct-user
+
+ACCT_USER_ID=0
+ACCT_USER_ENFORCE_ID=yes
+ACCT_USER_SHELL="/bin/bash"
+ACCT_USER_HOME="/root"
+ACCT_USER_HOME_PERMS=0700
+ACCT_USER_GROUPS=( root )
+
+# Avoid reverting changes by the sysadmin.
+# https://bugs.gentoo.org/827813
+ACCT_USER_NO_MODIFY=1
+
+acct-user_add_deps
+
+pkg_prerm() {
+ # Don't lock out the superuser
+ :
+}