summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-accessibility/brltty/files')
-rw-r--r--app-accessibility/brltty/files/brltty-5.2-fix-ldflags.patch56
-rw-r--r--app-accessibility/brltty/files/brltty-5.2-respect-AR.patch12
-rw-r--r--app-accessibility/brltty/files/brltty-5.2-udev.patch28
-rw-r--r--app-accessibility/brltty/files/brltty.rc13
-rw-r--r--app-accessibility/brltty/files/brltty.tmpfiles.conf1
5 files changed, 110 insertions, 0 deletions
diff --git a/app-accessibility/brltty/files/brltty-5.2-fix-ldflags.patch b/app-accessibility/brltty/files/brltty-5.2-fix-ldflags.patch
new file mode 100644
index 000000000000..e60ea9a4e509
--- /dev/null
+++ b/app-accessibility/brltty/files/brltty-5.2-fix-ldflags.patch
@@ -0,0 +1,56 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -377,7 +377,7 @@
+ case "${host_os}"
+ in
+ linux*|gnu*|openbsd*|freebsd*|kfreebsd*|netbsd*|*qnx*|cygwin*|mingw*|elf*)
+- brltty_mkmod_ld_make="-shared"
++ brltty_mkmod_ld_make="-shared ${LDFLAGS}"
+ ;;
+ solaris*)
+ brltty_mkmod_ld_make="-G"
+@@ -404,7 +404,7 @@
+ esac
+ if test "${GCC}" = "yes"
+ then
+- brltty_cv_prog_mkmod="\$(CC) ${brltty_mkmod_gcc_make=-shared} BRLTTY_OPTIONS_LD2CC([${brltty_mkmod_ld_options}]) -o"
++ brltty_cv_prog_mkmod="\$(CC) ${brltty_mkmod_gcc_make=-shared} ${LDFLAGS} BRLTTY_OPTIONS_LD2CC([${brltty_mkmod_ld_options}]) -o"
+ else
+ brltty_cv_prog_mkmod="\$(LD) ${brltty_mkmod_ld_make} ${brltty_mkmod_ld_options} -o"
+ fi])
+@@ -414,7 +414,7 @@
+ case "${host_os}"
+ in
+ linux*|gnu*|openbsd*|freebsd*|kfreebsd*|netbsd*|*qnx*|elf*)
+- brltty_mklib_ld_make="-shared"
++ brltty_mklib_ld_make="-shared ${LDFLAGS}"
+ brltty_mklib_ld_options="-soname"
+ ;;
+ solaris*)
+@@ -449,7 +449,7 @@
+ esac
+ if test "${GCC}" = "yes"
+ then
+- brltty_cv_prog_mklib="\$(CC) ${brltty_mklib_gcc_make=-shared} BRLTTY_OPTIONS_LD2CC([${brltty_mklib_ld_options+${brltty_mklib_ld_options} <name>}]) -o"
++ brltty_cv_prog_mklib="\$(CC) ${brltty_mklib_gcc_make=-shared} ${LDFLAGS} BRLTTY_OPTIONS_LD2CC([${brltty_mklib_ld_options+${brltty_mklib_ld_options} <name>}]) -o"
+ else
+ brltty_cv_prog_mklib="\$(LD) ${brltty_mklib_ld_make} ${brltty_mklib_ld_options+${brltty_mklib_ld_options} <name>} -o"
+ fi])
+--- a/Bindings/OCaml/Makefile.in
++++ b/Bindings/OCaml/Makefile.in
+@@ -55,13 +55,13 @@
+ all : $(OCAML_FILES)
+
+ $(OCAML_CLIBS) : brlapi_stubs.$O brlapi
+- $(OCAMLMKLIB) $(API_LDFLAGS) -oc $(OCAML_LIB)_stubs brlapi_stubs.$O
++ $(OCAMLMKLIB) -ldopt "$(LDFLAGS)" $(API_LDFLAGS) -oc $(OCAML_LIB)_stubs brlapi_stubs.$O
+
+ $(OCAML_BCLIB) : $(OCAML_CLIBS) brlapi.cmo
+ $(OCAMLC) -a $(OCAMLMKLIB_FLAGS) -o $(OCAML_LIB).cma brlapi.cmo
+
+ $(OCAML_NCLIB) : $(OCAML_CLIBS) brlapi.cmx
+- $(OCAMLMKLIB) $(OCAMLMKLIBOPT_FLAGS) -o $(OCAML_LIB) brlapi.cmx
++ $(OCAMLMKLIB) -ldopt "$(LDFLAGS)" $(OCAMLMKLIBOPT_FLAGS) -o $(OCAML_LIB) brlapi.cmx
+
+ brlapi.cmi: brlapi.mli
+ $(OCAMLC) -o $@ -c brlapi.mli
diff --git a/app-accessibility/brltty/files/brltty-5.2-respect-AR.patch b/app-accessibility/brltty/files/brltty-5.2-respect-AR.patch
new file mode 100644
index 000000000000..95451dc98b77
--- /dev/null
+++ b/app-accessibility/brltty/files/brltty-5.2-respect-AR.patch
@@ -0,0 +1,12 @@
+diff -Naur brltty-5.2/Programs/Makefile.in brltty-5.2-new/Programs/Makefile.in
+--- brltty-5.2/Programs/Makefile.in 2014-11-06 07:28:41.000000000 -0800
++++ brltty-5.2-new/Programs/Makefile.in 2014-11-20 05:41:57.144219093 -0800
+@@ -434,7 +434,7 @@
+ [ ! -f lib.def ] || mv lib.def $(API_DEF)
+
+ $(API_ARC): $(API_CLIENT_OBJECTS)
+- ar rc $@ $(API_CLIENT_OBJECTS)
++ $(AR) rc $@ $(API_CLIENT_OBJECTS)
+ $(RANLIB) $@
+
+ brlapi_client.$O:
diff --git a/app-accessibility/brltty/files/brltty-5.2-udev.patch b/app-accessibility/brltty/files/brltty-5.2-udev.patch
new file mode 100644
index 000000000000..dbbc29897662
--- /dev/null
+++ b/app-accessibility/brltty/files/brltty-5.2-udev.patch
@@ -0,0 +1,28 @@
+diff -Naur brltty-5.2/Autostart/Udev/udev.rules brltty-5.2-new/Autostart/Udev/udev.rules
+--- brltty-5.2/Autostart/Udev/udev.rules 2014-11-06 07:28:41.000000000 -0800
++++ brltty-5.2-new/Autostart/Udev/udev.rules 2014-11-20 05:28:44.404885312 -0800
+@@ -182,20 +182,22 @@
+ # FreedomScientific [Focus Blue]
+ ENV{PRODUCT}=="f4e/114/*", ENV{BRLTTY_BRAILLE_DRIVER}="fs", GOTO="brltty_usb_run"
+
++# Seika rules are commented out, because they conflict with USB-to-serial
++# converters.
+ # Device: 10C4:EA60
+ # Generic Identifier
+ # Vendor: Cygnal Integrated Products, Inc.
+ # Product: CP210x UART Bridge / myAVR mySmartUSB light
+ # BrailleMemo [Pocket]
+ # Seika [Braille Display]
+-ENV{PRODUCT}=="10c4/ea60/*", ENV{BRLTTY_BRAILLE_DRIVER}="mm,sk", GOTO="brltty_usb_run"
++#ENV{PRODUCT}=="10c4/ea60/*", ENV{BRLTTY_BRAILLE_DRIVER}="mm,sk", GOTO="brltty_usb_run"
+
+ # Device: 10C4:EA80
+ # Generic Identifier
+ # Vendor: Cygnal Integrated Products, Inc.
+ # Product: CP210x UART Bridge
+ # Seika [Note Taker]
+-ENV{PRODUCT}=="10c4/ea80/*", ENV{BRLTTY_BRAILLE_DRIVER}="sk", GOTO="brltty_usb_run"
++#ENV{PRODUCT}=="10c4/ea80/*", ENV{BRLTTY_BRAILLE_DRIVER}="sk", GOTO="brltty_usb_run"
+
+ # Device: 1148:0301
+ # BrailleMemo [Smart]
diff --git a/app-accessibility/brltty/files/brltty.rc b/app-accessibility/brltty/files/brltty.rc
new file mode 100644
index 000000000000..3afc5af76d3a
--- /dev/null
+++ b/app-accessibility/brltty/files/brltty.rc
@@ -0,0 +1,13 @@
+#!/sbin/runscript
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+command=/bin/brltty
+pidfile=/var/run/brltty.pid
+command_args="-P $pidfile -q"
+
+depend() {
+ before *
+ after clock
+}
diff --git a/app-accessibility/brltty/files/brltty.tmpfiles.conf b/app-accessibility/brltty/files/brltty.tmpfiles.conf
new file mode 100644
index 000000000000..18cc4021e33b
--- /dev/null
+++ b/app-accessibility/brltty/files/brltty.tmpfiles.conf
@@ -0,0 +1 @@
+d /run/brltty 0755 root root -