summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-accessibility/speech-tools/speech-tools-2.5.0-r1.ebuild')
-rw-r--r--app-accessibility/speech-tools/speech-tools-2.5.0-r1.ebuild13
1 files changed, 9 insertions, 4 deletions
diff --git a/app-accessibility/speech-tools/speech-tools-2.5.0-r1.ebuild b/app-accessibility/speech-tools/speech-tools-2.5.0-r1.ebuild
index 76fc1ff30431..90155ff033cd 100644
--- a/app-accessibility/speech-tools/speech-tools-2.5.0-r1.ebuild
+++ b/app-accessibility/speech-tools/speech-tools-2.5.0-r1.ebuild
@@ -1,22 +1,22 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit autotools toolchain-funcs
+inherit autotools flag-o-matic toolchain-funcs
MY_P=${P/speech-/speech_}
PATCHSET="r3"
DESCRIPTION="Speech tools for Festival Text to Speech engine"
-HOMEPAGE="http://www.cstr.ed.ac.uk/projects/speech_tools/"
+HOMEPAGE="https://www.cstr.ed.ac.uk/projects/speech_tools/"
SRC_URI="http://www.festvox.org/packed/festival/$(ver_cut 1-2)/${MY_P}-release.tar.gz
https://dev.gentoo.org/~neurogeek/${PN}/speech_tools-2.1-${PATCHSET}-patches.tar.gz"
S="${WORKDIR}/speech_tools"
LICENSE="FESTIVAL HPND BSD rc regexp-UofT"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+KEYWORDS="~alpha amd64 ~arm ~hppa ~ia64 ~mips ppc ppc64 sparc x86"
IUSE="nas openmp X"
RDEPEND="
@@ -99,6 +99,11 @@ src_configure() {
}
src_compile() {
+ # Lacks prototypes, bug #881863
+ append-cflags -std=gnu89
+ # Uses 'register' keyword removed in C++17, bug #894184
+ append-cxxflags -std=c++14
+
emake -j1 \
CC="$(tc-getCC)" \
CXX="$(tc-getCXX)" \