summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/at-spi2-core/Manifest1
-rw-r--r--app-accessibility/at-spi2-core/at-spi2-core-2.30.0.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/app-accessibility/at-spi2-core/Manifest b/app-accessibility/at-spi2-core/Manifest
index 28c453e10821..94ae9b09920d 100644
--- a/app-accessibility/at-spi2-core/Manifest
+++ b/app-accessibility/at-spi2-core/Manifest
@@ -1,2 +1,3 @@
DIST at-spi2-core-2.24.1.tar.xz 452440 BLAKE2B 2e3e262d507dadbdb8fc5bb1bd60d3dbe8a9c2946228b6dc551d0a9564684d96b1b6cbe29849c1d846b3106b5444a2c6880a10825ba20cca87893f6a52815023 SHA512 e7f354a90204f12d4e464a6b4e4cb27141af3715d7c5ec253bdd2ebe65bc7d191ae7b775c45470a1bd1fe2c0accdd4e84feeb5e1eb1a6c05f3e5e734371027be
DIST at-spi2-core-2.26.2.tar.xz 494484 BLAKE2B 0c67cea9c0107fb6503a933de134eb662f192ae2a98734bde1b0629da151476858720d2dcb1791a00a44b61ae2ead945178fba659f88303c552567d7f3f9817b SHA512 6a8e158e30c37ce475467b6634aff046a318875271966d7bfa3e56052d0cd26cd37435d0b9ae14f079542b8b3e76088da5bd50ed39eb39f3f40394c55ed3f255
+DIST at-spi2-core-2.30.0.tar.xz 188016 BLAKE2B 07e60fdcdf129f807d247bfc02d3d2f11796e21ce94f5149cb2970e13a02ec77c5ef05f8fcb8851d9bd83c1c2ab4c72868980c570c27e63704ad2263e527702e SHA512 f875738fd8a30dc8eeebb0b1a2631d7ef03e93db4dd8475cddb91c173a4ca7b473149ccb4fa2480df53555654612aa02f571461160e8931f50fda10b6a8b8c21
diff --git a/app-accessibility/at-spi2-core/at-spi2-core-2.30.0.ebuild b/app-accessibility/at-spi2-core/at-spi2-core-2.30.0.ebuild
new file mode 100644
index 000000000000..1e699cd04fad
--- /dev/null
+++ b/app-accessibility/at-spi2-core/at-spi2-core-2.30.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome.org meson multilib-minimal virtualx
+
+DESCRIPTION="D-Bus accessibility specifications and registration daemon"
+HOMEPAGE="https://wiki.gnome.org/Accessibility"
+
+LICENSE="LGPL-2+"
+SLOT="2"
+IUSE="X gtk-doc +introspection"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+
+RDEPEND="
+ >=dev-libs/glib-2.36:2[${MULTILIB_USEDEP}]
+ >=sys-apps/dbus-1.5[${MULTILIB_USEDEP}]
+ introspection? ( >=dev-libs/gobject-introspection-1.54.0:= )
+ X? (
+ x11-libs/libX11[${MULTILIB_USEDEP}]
+ x11-libs/libXtst[${MULTILIB_USEDEP}]
+ x11-libs/libXi[${MULTILIB_USEDEP}]
+ )
+"
+DEPEND="${RDEPEND}
+ gtk-doc? ( >=dev-util/gtk-doc-1.25 )
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig[${MULTILIB_USEDEP}]
+"
+
+PATCHES=(
+ # disable teamspaces test since that requires Novell.ICEDesktop.Daemon
+ "${FILESDIR}/${PN}-2.0.2-disable-teamspaces-test.patch"
+)
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Denable_docs=$(multilib_native_usex gtk-doc true false)
+ -Denable-introspection=$(multilib_native_usex introspection)
+ -Denable-x11=$(usex X)
+ )
+ meson_src_configure
+}
+
+multilib_src_compile() {
+ meson_src_compile
+}
+
+multilib_src_test() {
+ virtx meson_src_test
+}
+
+multilib_src_install() {
+ meson_src_install
+}