summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/aerospike-amc-community/aerospike-amc-community-5.0.0.ebuild')
-rw-r--r--app-admin/aerospike-amc-community/aerospike-amc-community-5.0.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-admin/aerospike-amc-community/aerospike-amc-community-5.0.0.ebuild b/app-admin/aerospike-amc-community/aerospike-amc-community-5.0.0.ebuild
new file mode 100644
index 000000000000..07fdde3f4da5
--- /dev/null
+++ b/app-admin/aerospike-amc-community/aerospike-amc-community-5.0.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_P="aerospike-amc-enterprise-${PV}-linux"
+
+DESCRIPTION="Web UI based monitoring tool for Aerospike Community Edition Server"
+HOMEPAGE="https://www.aerospike.com"
+SRC_URI="https://github.com/aerospike-community/amc/releases/download/${PV}/${MY_P}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ acct-group/aerospike-amc
+ acct-user/aerospike-amc
+"
+
+QA_PREBUILT="/opt/amc/amc"
+
+src_install() {
+ cp -r "${S}"/* "${ED}" || die
+ rm "${ED}"/etc/init.d/amc || die
+ newinitd "${FILESDIR}/amc.init.4" amc
+}