summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/ansible-base')
-rw-r--r--app-admin/ansible-base/Manifest3
-rw-r--r--app-admin/ansible-base/ansible-base-2.10.10.ebuild63
-rw-r--r--app-admin/ansible-base/ansible-base-2.10.9.ebuild63
-rw-r--r--app-admin/ansible-base/ansible-base-2.11.1.ebuild64
-rw-r--r--app-admin/ansible-base/ansible-base-9999.ebuild64
-rw-r--r--app-admin/ansible-base/metadata.xml27
6 files changed, 0 insertions, 284 deletions
diff --git a/app-admin/ansible-base/Manifest b/app-admin/ansible-base/Manifest
deleted file mode 100644
index c7908ec569d2..000000000000
--- a/app-admin/ansible-base/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST ansible-base-2.10.10.tar.gz 5986488 BLAKE2B 5c793d25ac5a216d05e15f49cd447cbdfb2ef97c2881bca60be5c23e3245262e15304a63431704d8b69fff56594e25517c0e5e1f2641b3eca5ad6a1e76e4d7b3 SHA512 b599b498a20b77cd3346f5b865b5a0436cdd835af250e8cc4ed20d61ac6a4929bf4ceef9a95c6e7b8e825c5f513d33ea32b24661c58e2f1d285db0569d71fc1b
-DIST ansible-base-2.10.9.tar.gz 6039597 BLAKE2B de455cc402ae4c5c4acd6b1c3d3f2e16572d4a4e79c5f3e4151ec8b913a3be0cfbcb42e5743fe627b7aba9b0e6b004189960cd5a17ff46166cd033a952d3c560 SHA512 093514230a3f6680ddeda07c24e77c2e793475895f44da6e5dd68335341d6fefe10091a124cf84e18475257a099b39fd2c16e6fc0dae0bbaf2d26e70b09c277a
-DIST ansible-core-2.11.1.tar.gz 6148111 BLAKE2B 46b1553542adbebfb0b0756be99a81d20cce2978a59766c65632b40413a851ad3c9de12df67959c0557584c5209ecd4f3c94381ae0a1e6987bd3cfb237de5a85 SHA512 1362754dde0a88ca8f6323d87cc6f4bf5f93b189b8d45fcb435d3fb289c359da128e7688a92107ade2c54828d4c4deb3ded9e01e18d19c503306924aa189a381
diff --git a/app-admin/ansible-base/ansible-base-2.10.10.ebuild b/app-admin/ansible-base/ansible-base-2.10.10.ebuild
deleted file mode 100644
index f7e9e5b567c5..000000000000
--- a/app-admin/ansible-base/ansible-base-2.10.10.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-
-inherit distutils-r1
-
-DESCRIPTION="Model-driven deployment, config management, and command execution framework"
-HOMEPAGE="https://ansible.com/"
-SRC_URI="https://releases.ansible.com/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~x64-macos"
-IUSE="test"
-RESTRICT="test"
-# doc removed due to https://github.com/ansible/ansible/issues/71395
-
-RDEPEND="
- dev-python/paramiko[${PYTHON_USEDEP}]
- dev-python/jinja[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/cryptography[${PYTHON_USEDEP}]
- dev-python/httplib2[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- dev-python/netaddr[${PYTHON_USEDEP}]
- dev-python/pexpect[${PYTHON_USEDEP}]
- net-misc/sshpass
- virtual/ssh
- !<app-admin/ansible-2.10
-"
-# ansible-2.10 or above is needed for the collections
-DEPEND="
- !<app-admin/ansible-2.10
- dev-python/setuptools[${PYTHON_USEDEP}]
- >=dev-python/packaging-16.6[${PYTHON_USEDEP}]
- test? (
- ${RDEPEND}
- dev-python/nose[${PYTHON_USEDEP}]
- >=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
- dev-python/passlib[${PYTHON_USEDEP}]
- dev-python/coverage[${PYTHON_USEDEP}]
- dev-python/unittest2[${PYTHON_USEDEP}]
- dev-vcs/git
- )"
-
-python_compile() {
- # disable version checks on upgrade
- export ANSIBLE_SKIP_CONFLICT_CHECK=1
- distutils-r1_python_compile
-}
-
-python_test() {
- nosetests -d -w test/units -v --with-coverage --cover-package=ansible --cover-branches || die
-}
-
-python_install_all() {
- distutils-r1_python_install_all
- dodoc -r examples
-}
diff --git a/app-admin/ansible-base/ansible-base-2.10.9.ebuild b/app-admin/ansible-base/ansible-base-2.10.9.ebuild
deleted file mode 100644
index 431b7f154bdd..000000000000
--- a/app-admin/ansible-base/ansible-base-2.10.9.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-
-inherit distutils-r1
-
-DESCRIPTION="Model-driven deployment, config management, and command execution framework"
-HOMEPAGE="https://ansible.com/"
-SRC_URI="https://releases.ansible.com/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~ppc64 x86 ~x64-macos"
-IUSE="test"
-RESTRICT="test"
-# doc removed due to https://github.com/ansible/ansible/issues/71395
-
-RDEPEND="
- dev-python/paramiko[${PYTHON_USEDEP}]
- dev-python/jinja[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/cryptography[${PYTHON_USEDEP}]
- dev-python/httplib2[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- dev-python/netaddr[${PYTHON_USEDEP}]
- dev-python/pexpect[${PYTHON_USEDEP}]
- net-misc/sshpass
- virtual/ssh
- !<app-admin/ansible-2.10
-"
-# ansible-2.10 or above is needed for the collections
-DEPEND="
- !<app-admin/ansible-2.10
- dev-python/setuptools[${PYTHON_USEDEP}]
- >=dev-python/packaging-16.6[${PYTHON_USEDEP}]
- test? (
- ${RDEPEND}
- dev-python/nose[${PYTHON_USEDEP}]
- >=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
- dev-python/passlib[${PYTHON_USEDEP}]
- dev-python/coverage[${PYTHON_USEDEP}]
- dev-python/unittest2[${PYTHON_USEDEP}]
- dev-vcs/git
- )"
-
-python_compile() {
- # disable version checks on upgrade
- export ANSIBLE_SKIP_CONFLICT_CHECK=1
- distutils-r1_python_compile
-}
-
-python_test() {
- nosetests -d -w test/units -v --with-coverage --cover-package=ansible --cover-branches || die
-}
-
-python_install_all() {
- distutils-r1_python_install_all
- dodoc -r examples
-}
diff --git a/app-admin/ansible-base/ansible-base-2.11.1.ebuild b/app-admin/ansible-base/ansible-base-2.11.1.ebuild
deleted file mode 100644
index 57eb3a160f1d..000000000000
--- a/app-admin/ansible-base/ansible-base-2.11.1.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..9} )
-DISTUTILS_USE_SETUPTOOLS=bdepend
-
-inherit distutils-r1
-
-DESCRIPTION="Model-driven deployment, config management, and command execution framework"
-HOMEPAGE="https://www.ansible.com/"
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/ansible/ansible.git"
- EGIT_BRANCH="devel"
-else
- MY_PN="${PN/-base/-core}"
- MY_P="${MY_PN}-${PV}"
- SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~x64-macos"
- S="${WORKDIR}"/${MY_P}
-fi
-
-LICENSE="GPL-3"
-SLOT="0"
-IUSE="test"
-RESTRICT="test"
-
-RDEPEND="
- dev-python/paramiko[${PYTHON_USEDEP}]
- dev-python/jinja[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/cryptography[${PYTHON_USEDEP}]
- dev-python/httplib2[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- dev-python/netaddr[${PYTHON_USEDEP}]
- dev-python/pexpect[${PYTHON_USEDEP}]
- >=dev-python/resolvelib-0.5.3[${PYTHON_USEDEP}]
- <dev-python/resolvelib-0.6.0[${PYTHON_USEDEP}]
- net-misc/sshpass
- virtual/ssh
-"
-DEPEND="
- >=dev-python/packaging-16.6[${PYTHON_USEDEP}]
- test? (
- ${RDEPEND}
- dev-python/nose[${PYTHON_USEDEP}]
- >=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
- dev-python/passlib[${PYTHON_USEDEP}]
- dev-python/coverage[${PYTHON_USEDEP}]
- dev-python/unittest2[${PYTHON_USEDEP}]
- dev-vcs/git
- )"
-
-python_compile() {
- export ANSIBLE_SKIP_CONFLICT_CHECK=1
- distutils-r1_python_compile
-}
-
-python_test() {
- nosetests -d -w test/units -v --with-coverage --cover-package=ansible --cover-branches || die
-}
diff --git a/app-admin/ansible-base/ansible-base-9999.ebuild b/app-admin/ansible-base/ansible-base-9999.ebuild
deleted file mode 100644
index 57eb3a160f1d..000000000000
--- a/app-admin/ansible-base/ansible-base-9999.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..9} )
-DISTUTILS_USE_SETUPTOOLS=bdepend
-
-inherit distutils-r1
-
-DESCRIPTION="Model-driven deployment, config management, and command execution framework"
-HOMEPAGE="https://www.ansible.com/"
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/ansible/ansible.git"
- EGIT_BRANCH="devel"
-else
- MY_PN="${PN/-base/-core}"
- MY_P="${MY_PN}-${PV}"
- SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~x64-macos"
- S="${WORKDIR}"/${MY_P}
-fi
-
-LICENSE="GPL-3"
-SLOT="0"
-IUSE="test"
-RESTRICT="test"
-
-RDEPEND="
- dev-python/paramiko[${PYTHON_USEDEP}]
- dev-python/jinja[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/cryptography[${PYTHON_USEDEP}]
- dev-python/httplib2[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- dev-python/netaddr[${PYTHON_USEDEP}]
- dev-python/pexpect[${PYTHON_USEDEP}]
- >=dev-python/resolvelib-0.5.3[${PYTHON_USEDEP}]
- <dev-python/resolvelib-0.6.0[${PYTHON_USEDEP}]
- net-misc/sshpass
- virtual/ssh
-"
-DEPEND="
- >=dev-python/packaging-16.6[${PYTHON_USEDEP}]
- test? (
- ${RDEPEND}
- dev-python/nose[${PYTHON_USEDEP}]
- >=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
- dev-python/passlib[${PYTHON_USEDEP}]
- dev-python/coverage[${PYTHON_USEDEP}]
- dev-python/unittest2[${PYTHON_USEDEP}]
- dev-vcs/git
- )"
-
-python_compile() {
- export ANSIBLE_SKIP_CONFLICT_CHECK=1
- distutils-r1_python_compile
-}
-
-python_test() {
- nosetests -d -w test/units -v --with-coverage --cover-package=ansible --cover-branches || die
-}
diff --git a/app-admin/ansible-base/metadata.xml b/app-admin/ansible-base/metadata.xml
deleted file mode 100644
index 7d6d6d55a3d5..000000000000
--- a/app-admin/ansible-base/metadata.xml
+++ /dev/null
@@ -1,27 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>prometheanfire@gentoo.org</email>
- <name>Matthew Thode</name>
- </maintainer>
- <maintainer type="person">
- <email>monsieurp@gentoo.org</email>
- <name>Patrice Clement</name>
- </maintainer>
- <upstream>
- <remote-id type="pypi">ansible-base</remote-id>
- <remote-id type="github">ansible/ansible</remote-id>
- <bugs-to>https://github.com/ansible/ansible/issues</bugs-to>
- </upstream>
- <longdescription lang="en">
-Radically simple deployment, model-driven configuration management, and
-command execution framework.
-
-This is a minimal installation of Ansible which contains the core programs,
-some documentation, and a tiny subset of modules and plugins to allow for a
-functioning controller. All other modules, including most of those
-bundled with in Ansible 2.9 and older, must be installed separately,
-e.g. from collections.
-</longdescription>
-</pkgmetadata>