summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/ansible-lint/ansible-lint-5.4.0.ebuild')
-rw-r--r--app-admin/ansible-lint/ansible-lint-5.4.0.ebuild53
1 files changed, 0 insertions, 53 deletions
diff --git a/app-admin/ansible-lint/ansible-lint-5.4.0.ebuild b/app-admin/ansible-lint/ansible-lint-5.4.0.ebuild
deleted file mode 100644
index a2b7755f9476..000000000000
--- a/app-admin/ansible-lint/ansible-lint-5.4.0.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-DISTUTILS_USE_PEP517=setuptools
-
-inherit distutils-r1
-
-DESCRIPTION="Checks ansible playbooks for practices and behaviour that can be improved"
-HOMEPAGE="https://github.com/ansible-community/ansible-lint"
-# PyPI tarballs do not contain all the data files needed by the tests
-SRC_URI="https://github.com/ansible-community/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~riscv"
-
-RDEPEND="
- >=app-admin/ansible-2.10[${PYTHON_USEDEP}]
- >=app-admin/ansible-base-2.11.4[${PYTHON_USEDEP}]
- >=dev-python/enrich-1.2.6[${PYTHON_USEDEP}]
- dev-python/packaging[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- >=dev-python/rich-9.5.1[${PYTHON_USEDEP}]
- >=dev-python/ruamel-yaml-0.15.37[${PYTHON_USEDEP}]
- dev-python/tenacity[${PYTHON_USEDEP}]
- >=dev-python/wcmatch-7.0[${PYTHON_USEDEP}]
- >=dev-util/yamllint-1.25.0[${PYTHON_USEDEP}]"
-BDEPEND="
- >=dev-python/setuptools_scm-1.15.0[${PYTHON_USEDEP}]
- >=dev-python/setuptools_scm_git_archive-1.0[${PYTHON_USEDEP}]
- test? (
- >=dev-python/flaky-3.7.0[${PYTHON_USEDEP}]
- >=dev-python/pytest-xdist-2.1.0[${PYTHON_USEDEP}]
- )"
-
-# Skip problematic tests:
-# - test_call_from_outside_venv doesn't play nicely with the sandbox
-# - all test_eco and some test_prerun tests require Internet access
-# - as of 5.4.0, test_cli_auto_detect fails even when run manually with tox
-EPYTEST_DESELECT=(
- test/TestUtils.py::test_cli_auto_detect
- test/test_eco.py
- test/test_main.py::test_call_from_outside_venv
- test/test_prerun.py::test_install_collection
- test/test_prerun.py::test_prerun_reqs_v1
- test/test_prerun.py::test_prerun_reqs_v2
- test/test_prerun.py::test_require_collection_wrong_version
-)
-
-distutils_enable_tests pytest