summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/ansible-lint')
-rw-r--r--app-admin/ansible-lint/Manifest5
-rw-r--r--app-admin/ansible-lint/ansible-lint-24.2.0.ebuild58
-rw-r--r--app-admin/ansible-lint/ansible-lint-24.2.2.ebuild58
-rw-r--r--app-admin/ansible-lint/ansible-lint-24.5.0.ebuild57
-rw-r--r--app-admin/ansible-lint/ansible-lint-5.0.12.ebuild38
-rw-r--r--app-admin/ansible-lint/ansible-lint-5.2.0.ebuild39
-rw-r--r--app-admin/ansible-lint/metadata.xml8
7 files changed, 178 insertions, 85 deletions
diff --git a/app-admin/ansible-lint/Manifest b/app-admin/ansible-lint/Manifest
index 14f529b3e523..793cf95128c8 100644
--- a/app-admin/ansible-lint/Manifest
+++ b/app-admin/ansible-lint/Manifest
@@ -1,2 +1,3 @@
-DIST ansible-lint-5.0.12.tar.gz 348478 BLAKE2B 3ea2a0adb82bd21322fa9a2d4c8dd4f41345f909401341748e8395aa8acf92bfc8058ee679a594c886327480bb808e69622e874c9def97c406265a0828a314eb SHA512 06b84d098253ab70f9c3fb59e1d2ba4d30918f1e7c6f3decc8f73fe8cdb7d697527eff3efcc7238fc952bc07b7179d37582d5fb9968e691e2df5495741802404
-DIST ansible-lint-5.2.0.tar.gz 356238 BLAKE2B 7c8bdb1486d7fca5f6addbb87075d98b51e9af4e5544f5bd272ee2a4648d289e48e3922246f7c681fa3450cb881b1da8e098d715bd49e3d75783c812e9863a7b SHA512 d3c1da5f0ee648ac7b5f32d4ae186a24cda11fba4fccd4d5d43dbd228986793f975b43895db07855a80528fe684f6adfc4be451aeed7109d65dfae6c351b6c47
+DIST ansible-lint-24.2.0.tar.gz 513719 BLAKE2B 54e05acf982cf13cb2142a10bf04250171f07936df14933525dfae68b312a0d92ceb30867603dc7ce686206b7de010f6ca4eb9ab532ca000fc3c15c77c354c81 SHA512 3276d28c7b85a6087a0142cc56442efddf9ff3e81155455c74686015a2ab45ece64847b0243373ad01145e67599d8449866c122efe8ae404cd819011e41c5235
+DIST ansible-lint-24.2.2.tar.gz 515822 BLAKE2B e9d8e689dfe4e4efbd4dad44ff3567f50412400ed979f2d60150f09f17c5f63f2441f25a33ecdf0112024ced07e62ac16b8a2dbc1c01d62855ec785fc75d1b9a SHA512 3de6b14e4b64ba577abcb67920a45dbf45fedb84e21091cd6a29e3c52a7a91555a152ee3e265624aafbf9dddba96d04241c2598a18f2103ce2cae48706142446
+DIST ansible_lint-24.5.0.tar.gz 525539 BLAKE2B 2681da05c69299f62b9a180ff4a10ea8fa27731d5a9f3d836e67fd211c2def86a6baa38583900e9c8be1a5da0a8658aded6e83cb8f13f129f55bd18a06b2e574 SHA512 b390743bbb09c03c9b402c35644c2b2e29b9a94fce842bf42b8938f7094b145ea75275f643949383bdad694408c606c0bc3038d5ca733a39ac08ef77cc7dc459
diff --git a/app-admin/ansible-lint/ansible-lint-24.2.0.ebuild b/app-admin/ansible-lint/ansible-lint-24.2.0.ebuild
new file mode 100644
index 000000000000..1995f0728a37
--- /dev/null
+++ b/app-admin/ansible-lint/ansible-lint-24.2.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Checks ansible playbooks for practices and behaviour that can be improved"
+HOMEPAGE="https://github.com/ansible/ansible-lint"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 ~riscv"
+
+# Upstream has stated explicitly that all tests require Internet access
+PROPERTIES="test_network"
+RESTRICT="test"
+
+RDEPEND="
+ >=app-admin/ansible-core-2.12.0[${PYTHON_USEDEP}]
+ >=dev-python/ansible-compat-4.1.11[${PYTHON_USEDEP}]
+ >=dev-python/black-22.8.0[${PYTHON_USEDEP}]
+ >=dev-python/filelock-3.8.0[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-4.17.0[${PYTHON_USEDEP}]
+ >=dev-python/packaging-21.3[${PYTHON_USEDEP}]
+ >=dev-python/pathspec-0.10.3[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.4.1[${PYTHON_USEDEP}]
+ >=dev-python/rich-12.0.0[${PYTHON_USEDEP}]
+ >=dev-python/ruamel-yaml-0.18.5[${PYTHON_USEDEP}]
+ >=dev-python/wcmatch-8.3.2[${PYTHON_USEDEP}]
+ >=dev-util/yamllint-1.30.0[${PYTHON_USEDEP}]
+ dev-vcs/git"
+BDEPEND="
+ >=dev-python/setuptools-scm-7.0.5[${PYTHON_USEDEP}]
+ test? (
+ dev-python/mypy[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ >=dev-python/pytest-plus-0.6[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xdist-2.5.0[${PYTHON_USEDEP}]
+ )"
+
+# test_call_from_outside_venv doesn't play nicely with the sandbox
+# irrespective of whether Internet access is allowed or not
+EPYTEST_DESELECT=(
+ test/test_main.py::test_call_from_outside_venv
+)
+
+distutils_enable_tests pytest
+
+# Test suite fails to start without this
+python_test() {
+ epytest test
+}
diff --git a/app-admin/ansible-lint/ansible-lint-24.2.2.ebuild b/app-admin/ansible-lint/ansible-lint-24.2.2.ebuild
new file mode 100644
index 000000000000..e8e336e27738
--- /dev/null
+++ b/app-admin/ansible-lint/ansible-lint-24.2.2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Checks ansible playbooks for practices and behaviour that can be improved"
+HOMEPAGE="https://github.com/ansible/ansible-lint"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv"
+
+# Upstream has stated explicitly that all tests require Internet access
+PROPERTIES="test_network"
+RESTRICT="test"
+
+RDEPEND="
+ >=app-admin/ansible-core-2.12.0[${PYTHON_USEDEP}]
+ >=dev-python/ansible-compat-4.1.11[${PYTHON_USEDEP}]
+ >=dev-python/black-22.8.0[${PYTHON_USEDEP}]
+ >=dev-python/filelock-3.8.0[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-4.17.0[${PYTHON_USEDEP}]
+ >=dev-python/packaging-21.3[${PYTHON_USEDEP}]
+ >=dev-python/pathspec-0.10.3[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.4.1[${PYTHON_USEDEP}]
+ >=dev-python/rich-12.0.0[${PYTHON_USEDEP}]
+ >=dev-python/ruamel-yaml-0.18.5[${PYTHON_USEDEP}]
+ >=dev-python/wcmatch-8.3.2[${PYTHON_USEDEP}]
+ >=dev-util/yamllint-1.30.0[${PYTHON_USEDEP}]
+ dev-vcs/git"
+BDEPEND="
+ >=dev-python/setuptools-scm-7.0.5[${PYTHON_USEDEP}]
+ test? (
+ dev-python/mypy[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ >=dev-python/pytest-plus-0.6[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xdist-2.5.0[${PYTHON_USEDEP}]
+ )"
+
+# test_call_from_outside_venv doesn't play nicely with the sandbox
+# irrespective of whether Internet access is allowed or not
+EPYTEST_DESELECT=(
+ test/test_main.py::test_call_from_outside_venv
+)
+
+distutils_enable_tests pytest
+
+# Test suite fails to start without this
+python_test() {
+ epytest test
+}
diff --git a/app-admin/ansible-lint/ansible-lint-24.5.0.ebuild b/app-admin/ansible-lint/ansible-lint-24.5.0.ebuild
new file mode 100644
index 000000000000..fcaeec307b68
--- /dev/null
+++ b/app-admin/ansible-lint/ansible-lint-24.5.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Checks ansible playbooks for practices and behaviour that can be improved"
+HOMEPAGE="https://github.com/ansible/ansible-lint"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv"
+
+# Upstream has stated explicitly that all tests require Internet access
+PROPERTIES="test_network"
+RESTRICT="test"
+
+RDEPEND="
+ >=app-admin/ansible-core-2.12.0[${PYTHON_USEDEP}]
+ >=dev-python/ansible-compat-4.1.11[${PYTHON_USEDEP}]
+ >=dev-python/black-22.8.0[${PYTHON_USEDEP}]
+ >=dev-python/filelock-3.8.0[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-4.17.0[${PYTHON_USEDEP}]
+ >=dev-python/packaging-21.3[${PYTHON_USEDEP}]
+ >=dev-python/pathspec-0.10.3[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.4.1[${PYTHON_USEDEP}]
+ >=dev-python/rich-12.0.0[${PYTHON_USEDEP}]
+ >=dev-python/ruamel-yaml-0.18.5[${PYTHON_USEDEP}]
+ >=dev-python/wcmatch-8.3.2[${PYTHON_USEDEP}]
+ >=dev-util/yamllint-1.30.0[${PYTHON_USEDEP}]
+ dev-vcs/git"
+BDEPEND="
+ >=dev-python/setuptools-scm-7.0.5[${PYTHON_USEDEP}]
+ test? (
+ dev-python/mypy[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ >=dev-python/pytest-plus-0.6[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xdist-2.5.0[${PYTHON_USEDEP}]
+ )"
+
+# test_call_from_outside_venv doesn't play nicely with the sandbox
+# irrespective of whether Internet access is allowed or not
+EPYTEST_DESELECT=(
+ test/test_main.py::test_call_from_outside_venv
+)
+
+distutils_enable_tests pytest
+
+# Test suite fails to start without this
+python_test() {
+ epytest test
+}
diff --git a/app-admin/ansible-lint/ansible-lint-5.0.12.ebuild b/app-admin/ansible-lint/ansible-lint-5.0.12.ebuild
deleted file mode 100644
index bb3d2887ad1e..000000000000
--- a/app-admin/ansible-lint/ansible-lint-5.0.12.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..9} )
-
-inherit distutils-r1
-
-DESCRIPTION="Checks ansible playbooks for practices and behaviour that can be improved"
-HOMEPAGE="https://github.com/ansible-community/ansible-lint"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~riscv"
-
-# tests are broken at the moment
-RESTRICT="test"
-
-RDEPEND="
- app-admin/ansible[${PYTHON_USEDEP}]
- dev-python/enrich[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/rich[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- dev-python/tenacity[${PYTHON_USEDEP}]
- dev-python/wcmatch[${PYTHON_USEDEP}]"
-BDEPEND="
- dev-python/ruamel-yaml[${PYTHON_USEDEP}]
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- dev-python/setuptools_scm_git_archive[${PYTHON_USEDEP}]
- test? (
- dev-python/flake8[${PYTHON_USEDEP}]
- dev-python/wheel[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests nose
diff --git a/app-admin/ansible-lint/ansible-lint-5.2.0.ebuild b/app-admin/ansible-lint/ansible-lint-5.2.0.ebuild
deleted file mode 100644
index 23d0affbc127..000000000000
--- a/app-admin/ansible-lint/ansible-lint-5.2.0.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..9} )
-
-inherit distutils-r1
-
-DESCRIPTION="Checks ansible playbooks for practices and behaviour that can be improved"
-HOMEPAGE="https://github.com/ansible-community/ansible-lint"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~riscv"
-
-# Many tests require still-unpackaged yamlllint
-RESTRICT="test"
-
-RDEPEND="
- >=app-admin/ansible-2.10[${PYTHON_USEDEP}]
- >=app-admin/ansible-base-2.11.4[${PYTHON_USEDEP}]
- >=dev-python/enrich-1.2.6[${PYTHON_USEDEP}]
- dev-python/packaging[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- >=dev-python/rich-9.5.1[${PYTHON_USEDEP}]
- >=dev-python/ruamel-yaml-0.15.37[${PYTHON_USEDEP}]
- dev-python/tenacity[${PYTHON_USEDEP}]
- >=dev-python/wcmatch-7.0[${PYTHON_USEDEP}]"
-BDEPEND="
- >=dev-python/setuptools_scm-1.15.0[${PYTHON_USEDEP}]
- >=dev-python/setuptools_scm_git_archive-1.0[${PYTHON_USEDEP}]
- test? (
- >=dev-python/flaky-3.7.0[${PYTHON_USEDEP}]
- >=dev-python/pytest-xdist-2.1.0[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests pytest
diff --git a/app-admin/ansible-lint/metadata.xml b/app-admin/ansible-lint/metadata.xml
index c30f7c5d92bc..8ec7574bc4cb 100644
--- a/app-admin/ansible-lint/metadata.xml
+++ b/app-admin/ansible-lint/metadata.xml
@@ -2,16 +2,12 @@
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
- <email>monsieurp@gentoo.org</email>
- <name>Patrice Clement</name>
- </maintainer>
- <maintainer type="person">
<email>marecki@gentoo.org</email>
<name>Marek Szuba</name>
</maintainer>
<upstream>
<remote-id type="pypi">ansible-lint</remote-id>
- <remote-id type="github">ansible-community/ansible-lint</remote-id>
- <bugs-to>https://github.com/ansible-community/ansible-lint/issues</bugs-to>
+ <remote-id type="github">ansible/ansible-lint</remote-id>
+ <bugs-to>https://github.com/ansible/ansible-lint/issues</bugs-to>
</upstream>
</pkgmetadata>