summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/ansible-lint')
-rw-r--r--app-admin/ansible-lint/Manifest6
-rw-r--r--app-admin/ansible-lint/ansible-lint-24.2.0.ebuild58
-rw-r--r--app-admin/ansible-lint/ansible-lint-24.2.2.ebuild58
-rw-r--r--app-admin/ansible-lint/ansible-lint-24.5.0.ebuild57
-rw-r--r--app-admin/ansible-lint/ansible-lint-5.4.0.ebuild53
-rw-r--r--app-admin/ansible-lint/ansible-lint-6.2.2.ebuild72
-rw-r--r--app-admin/ansible-lint/ansible-lint-6.3.0.ebuild72
-rw-r--r--app-admin/ansible-lint/files/ansible-lint-6.0.2_test-module-check.patch23
-rw-r--r--app-admin/ansible-lint/metadata.xml4
9 files changed, 176 insertions, 227 deletions
diff --git a/app-admin/ansible-lint/Manifest b/app-admin/ansible-lint/Manifest
index cc62ee1d1a12..793cf95128c8 100644
--- a/app-admin/ansible-lint/Manifest
+++ b/app-admin/ansible-lint/Manifest
@@ -1,3 +1,3 @@
-DIST ansible-lint-5.4.0.tar.gz 349353 BLAKE2B 9f41abdf1e9485afa4c8ed9498627b0dcbdcf57916f3b57c9886de8bd806e4e5b34e7e9c2e66b44ac8009a0afcea4d8566900ee8d391eaca61081fa23323c41c SHA512 f1bbbb49eb77991d60b6087646c695a938d328d719bba67707af4ed858de857d383b78490bcf0930cffebd13a0b0abde20269a47e47e4713a37da715a28c5da0
-DIST ansible-lint-6.2.2.tar.gz 232952 BLAKE2B 571dce6dc348c1158fed396fc29054421d172964facd8cbb0f8c1560036de574aa304f59497c8c76415ac99424d0450c8b06509ced113c9a997808e960793621 SHA512 ae119b29d87ce59e7bd5c401a8fcbc2194bdddecd5a65010ea02aee62cff1764a767803a57edcfd297e9ad0cbdf70fe69212625ed80b21afb53b4ebe429a7636
-DIST ansible-lint-6.3.0.tar.gz 268331 BLAKE2B 00ea2dbc7bb5e71d63a737ac99d4116441f6b1eee2fa476d9aa4d78068064e53975df00950f337e7c9e25dacf8778ddd2e40eb5d3ea1301f56a80dfd90d42c20 SHA512 3e9d480cb90f3022a4b001c061c3e76b753620776a009b1563dce335c13ee38b7ac334725592ac644a2808d85ceb98b618a451c193bc7c4961474d4e7fbbb88e
+DIST ansible-lint-24.2.0.tar.gz 513719 BLAKE2B 54e05acf982cf13cb2142a10bf04250171f07936df14933525dfae68b312a0d92ceb30867603dc7ce686206b7de010f6ca4eb9ab532ca000fc3c15c77c354c81 SHA512 3276d28c7b85a6087a0142cc56442efddf9ff3e81155455c74686015a2ab45ece64847b0243373ad01145e67599d8449866c122efe8ae404cd819011e41c5235
+DIST ansible-lint-24.2.2.tar.gz 515822 BLAKE2B e9d8e689dfe4e4efbd4dad44ff3567f50412400ed979f2d60150f09f17c5f63f2441f25a33ecdf0112024ced07e62ac16b8a2dbc1c01d62855ec785fc75d1b9a SHA512 3de6b14e4b64ba577abcb67920a45dbf45fedb84e21091cd6a29e3c52a7a91555a152ee3e265624aafbf9dddba96d04241c2598a18f2103ce2cae48706142446
+DIST ansible_lint-24.5.0.tar.gz 525539 BLAKE2B 2681da05c69299f62b9a180ff4a10ea8fa27731d5a9f3d836e67fd211c2def86a6baa38583900e9c8be1a5da0a8658aded6e83cb8f13f129f55bd18a06b2e574 SHA512 b390743bbb09c03c9b402c35644c2b2e29b9a94fce842bf42b8938f7094b145ea75275f643949383bdad694408c606c0bc3038d5ca733a39ac08ef77cc7dc459
diff --git a/app-admin/ansible-lint/ansible-lint-24.2.0.ebuild b/app-admin/ansible-lint/ansible-lint-24.2.0.ebuild
new file mode 100644
index 000000000000..1995f0728a37
--- /dev/null
+++ b/app-admin/ansible-lint/ansible-lint-24.2.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Checks ansible playbooks for practices and behaviour that can be improved"
+HOMEPAGE="https://github.com/ansible/ansible-lint"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 ~riscv"
+
+# Upstream has stated explicitly that all tests require Internet access
+PROPERTIES="test_network"
+RESTRICT="test"
+
+RDEPEND="
+ >=app-admin/ansible-core-2.12.0[${PYTHON_USEDEP}]
+ >=dev-python/ansible-compat-4.1.11[${PYTHON_USEDEP}]
+ >=dev-python/black-22.8.0[${PYTHON_USEDEP}]
+ >=dev-python/filelock-3.8.0[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-4.17.0[${PYTHON_USEDEP}]
+ >=dev-python/packaging-21.3[${PYTHON_USEDEP}]
+ >=dev-python/pathspec-0.10.3[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.4.1[${PYTHON_USEDEP}]
+ >=dev-python/rich-12.0.0[${PYTHON_USEDEP}]
+ >=dev-python/ruamel-yaml-0.18.5[${PYTHON_USEDEP}]
+ >=dev-python/wcmatch-8.3.2[${PYTHON_USEDEP}]
+ >=dev-util/yamllint-1.30.0[${PYTHON_USEDEP}]
+ dev-vcs/git"
+BDEPEND="
+ >=dev-python/setuptools-scm-7.0.5[${PYTHON_USEDEP}]
+ test? (
+ dev-python/mypy[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ >=dev-python/pytest-plus-0.6[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xdist-2.5.0[${PYTHON_USEDEP}]
+ )"
+
+# test_call_from_outside_venv doesn't play nicely with the sandbox
+# irrespective of whether Internet access is allowed or not
+EPYTEST_DESELECT=(
+ test/test_main.py::test_call_from_outside_venv
+)
+
+distutils_enable_tests pytest
+
+# Test suite fails to start without this
+python_test() {
+ epytest test
+}
diff --git a/app-admin/ansible-lint/ansible-lint-24.2.2.ebuild b/app-admin/ansible-lint/ansible-lint-24.2.2.ebuild
new file mode 100644
index 000000000000..e8e336e27738
--- /dev/null
+++ b/app-admin/ansible-lint/ansible-lint-24.2.2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Checks ansible playbooks for practices and behaviour that can be improved"
+HOMEPAGE="https://github.com/ansible/ansible-lint"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv"
+
+# Upstream has stated explicitly that all tests require Internet access
+PROPERTIES="test_network"
+RESTRICT="test"
+
+RDEPEND="
+ >=app-admin/ansible-core-2.12.0[${PYTHON_USEDEP}]
+ >=dev-python/ansible-compat-4.1.11[${PYTHON_USEDEP}]
+ >=dev-python/black-22.8.0[${PYTHON_USEDEP}]
+ >=dev-python/filelock-3.8.0[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-4.17.0[${PYTHON_USEDEP}]
+ >=dev-python/packaging-21.3[${PYTHON_USEDEP}]
+ >=dev-python/pathspec-0.10.3[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.4.1[${PYTHON_USEDEP}]
+ >=dev-python/rich-12.0.0[${PYTHON_USEDEP}]
+ >=dev-python/ruamel-yaml-0.18.5[${PYTHON_USEDEP}]
+ >=dev-python/wcmatch-8.3.2[${PYTHON_USEDEP}]
+ >=dev-util/yamllint-1.30.0[${PYTHON_USEDEP}]
+ dev-vcs/git"
+BDEPEND="
+ >=dev-python/setuptools-scm-7.0.5[${PYTHON_USEDEP}]
+ test? (
+ dev-python/mypy[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ >=dev-python/pytest-plus-0.6[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xdist-2.5.0[${PYTHON_USEDEP}]
+ )"
+
+# test_call_from_outside_venv doesn't play nicely with the sandbox
+# irrespective of whether Internet access is allowed or not
+EPYTEST_DESELECT=(
+ test/test_main.py::test_call_from_outside_venv
+)
+
+distutils_enable_tests pytest
+
+# Test suite fails to start without this
+python_test() {
+ epytest test
+}
diff --git a/app-admin/ansible-lint/ansible-lint-24.5.0.ebuild b/app-admin/ansible-lint/ansible-lint-24.5.0.ebuild
new file mode 100644
index 000000000000..fcaeec307b68
--- /dev/null
+++ b/app-admin/ansible-lint/ansible-lint-24.5.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Checks ansible playbooks for practices and behaviour that can be improved"
+HOMEPAGE="https://github.com/ansible/ansible-lint"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv"
+
+# Upstream has stated explicitly that all tests require Internet access
+PROPERTIES="test_network"
+RESTRICT="test"
+
+RDEPEND="
+ >=app-admin/ansible-core-2.12.0[${PYTHON_USEDEP}]
+ >=dev-python/ansible-compat-4.1.11[${PYTHON_USEDEP}]
+ >=dev-python/black-22.8.0[${PYTHON_USEDEP}]
+ >=dev-python/filelock-3.8.0[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-4.17.0[${PYTHON_USEDEP}]
+ >=dev-python/packaging-21.3[${PYTHON_USEDEP}]
+ >=dev-python/pathspec-0.10.3[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.4.1[${PYTHON_USEDEP}]
+ >=dev-python/rich-12.0.0[${PYTHON_USEDEP}]
+ >=dev-python/ruamel-yaml-0.18.5[${PYTHON_USEDEP}]
+ >=dev-python/wcmatch-8.3.2[${PYTHON_USEDEP}]
+ >=dev-util/yamllint-1.30.0[${PYTHON_USEDEP}]
+ dev-vcs/git"
+BDEPEND="
+ >=dev-python/setuptools-scm-7.0.5[${PYTHON_USEDEP}]
+ test? (
+ dev-python/mypy[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ >=dev-python/pytest-plus-0.6[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xdist-2.5.0[${PYTHON_USEDEP}]
+ )"
+
+# test_call_from_outside_venv doesn't play nicely with the sandbox
+# irrespective of whether Internet access is allowed or not
+EPYTEST_DESELECT=(
+ test/test_main.py::test_call_from_outside_venv
+)
+
+distutils_enable_tests pytest
+
+# Test suite fails to start without this
+python_test() {
+ epytest test
+}
diff --git a/app-admin/ansible-lint/ansible-lint-5.4.0.ebuild b/app-admin/ansible-lint/ansible-lint-5.4.0.ebuild
deleted file mode 100644
index a2b7755f9476..000000000000
--- a/app-admin/ansible-lint/ansible-lint-5.4.0.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-DISTUTILS_USE_PEP517=setuptools
-
-inherit distutils-r1
-
-DESCRIPTION="Checks ansible playbooks for practices and behaviour that can be improved"
-HOMEPAGE="https://github.com/ansible-community/ansible-lint"
-# PyPI tarballs do not contain all the data files needed by the tests
-SRC_URI="https://github.com/ansible-community/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~riscv"
-
-RDEPEND="
- >=app-admin/ansible-2.10[${PYTHON_USEDEP}]
- >=app-admin/ansible-base-2.11.4[${PYTHON_USEDEP}]
- >=dev-python/enrich-1.2.6[${PYTHON_USEDEP}]
- dev-python/packaging[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- >=dev-python/rich-9.5.1[${PYTHON_USEDEP}]
- >=dev-python/ruamel-yaml-0.15.37[${PYTHON_USEDEP}]
- dev-python/tenacity[${PYTHON_USEDEP}]
- >=dev-python/wcmatch-7.0[${PYTHON_USEDEP}]
- >=dev-util/yamllint-1.25.0[${PYTHON_USEDEP}]"
-BDEPEND="
- >=dev-python/setuptools_scm-1.15.0[${PYTHON_USEDEP}]
- >=dev-python/setuptools_scm_git_archive-1.0[${PYTHON_USEDEP}]
- test? (
- >=dev-python/flaky-3.7.0[${PYTHON_USEDEP}]
- >=dev-python/pytest-xdist-2.1.0[${PYTHON_USEDEP}]
- )"
-
-# Skip problematic tests:
-# - test_call_from_outside_venv doesn't play nicely with the sandbox
-# - all test_eco and some test_prerun tests require Internet access
-# - as of 5.4.0, test_cli_auto_detect fails even when run manually with tox
-EPYTEST_DESELECT=(
- test/TestUtils.py::test_cli_auto_detect
- test/test_eco.py
- test/test_main.py::test_call_from_outside_venv
- test/test_prerun.py::test_install_collection
- test/test_prerun.py::test_prerun_reqs_v1
- test/test_prerun.py::test_prerun_reqs_v2
- test/test_prerun.py::test_require_collection_wrong_version
-)
-
-distutils_enable_tests pytest
diff --git a/app-admin/ansible-lint/ansible-lint-6.2.2.ebuild b/app-admin/ansible-lint/ansible-lint-6.2.2.ebuild
deleted file mode 100644
index 8e20fa3a01ff..000000000000
--- a/app-admin/ansible-lint/ansible-lint-6.2.2.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-DISTUTILS_USE_PEP517=setuptools
-
-inherit distutils-r1
-
-DESCRIPTION="Checks ansible playbooks for practices and behaviour that can be improved"
-HOMEPAGE="https://github.com/ansible/ansible-lint"
-# PyPI tarballs do not contain all the data files needed by the tests
-SRC_URI="https://github.com/ansible/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~riscv"
-
-# Since 6.2.0 ansible-lint once again does not need access to Ansible Galaxy
-# even to get the test suite started, however quite a large fraction of tests
-# fails without network access. Needs more work.
-PROPERTIES="test_network"
-RESTRICT="test"
-
-RDEPEND="
- >=app-admin/ansible-base-2.12.0[${PYTHON_USEDEP}]
- >=dev-python/ansible-compat-2.0.4[${PYTHON_USEDEP}]
- >=dev-python/enrich-1.2.6[${PYTHON_USEDEP}]
- >=dev-python/jsonschema-4.5.1[${PYTHON_USEDEP}]
- dev-python/packaging[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- >=dev-python/rich-9.5.1[${PYTHON_USEDEP}]
- >=dev-python/ruamel-yaml-0.15.37[${PYTHON_USEDEP}]
- >=dev-python/wcmatch-7.0[${PYTHON_USEDEP}]
- >=dev-util/yamllint-1.25.0[${PYTHON_USEDEP}]"
-BDEPEND="
- >=dev-python/setuptools_scm-3.5.0[${PYTHON_USEDEP}]
- >=dev-python/setuptools_scm_git_archive-1.0[${PYTHON_USEDEP}]
- test? (
- >=dev-python/flaky-3.7.0[${PYTHON_USEDEP}]
- >=dev-python/pytest-plus-0.2[${PYTHON_USEDEP}]
- >=dev-python/pytest-xdist-2.5.0[${PYTHON_USEDEP}]
- )"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-6.0.2_test-module-check.patch
-)
-
-# Skip problematic tests (TODO: update this list for ansible-lint-6.2.0+):
-# - test_call_from_outside_venv doesn't play nicely with the sandbox
-# - all test_eco and some test_prerun tests require Internet access
-# - as of 5.4.0, test_cli_auto_detect fails even when run manually with tox
-EPYTEST_DESELECT=(
- test/test_eco.py
- test/test_main.py::test_call_from_outside_venv
- test/test_prerun.py::test_install_collection
- test/test_prerun.py::test_prerun_reqs_v1
- test/test_prerun.py::test_prerun_reqs_v2
- test/test_prerun.py::test_require_collection_wrong_version
- test/test_utils.py::test_cli_auto_detect
-)
-
-distutils_enable_tests pytest
-
-python_test() {
- # As of 6.2.1, without this the test suite still gets confused by the presence of ansible-lint modules
- # in both ${ED} and ${S}.
- cd "${S}" || die
-
- epytest test
-}
diff --git a/app-admin/ansible-lint/ansible-lint-6.3.0.ebuild b/app-admin/ansible-lint/ansible-lint-6.3.0.ebuild
deleted file mode 100644
index 6a378c69fa29..000000000000
--- a/app-admin/ansible-lint/ansible-lint-6.3.0.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-DISTUTILS_USE_PEP517=setuptools
-
-inherit distutils-r1
-
-DESCRIPTION="Checks ansible playbooks for practices and behaviour that can be improved"
-HOMEPAGE="https://github.com/ansible/ansible-lint"
-# PyPI tarballs do not contain all the data files needed by the tests
-SRC_URI="https://github.com/ansible/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~riscv"
-
-# Since 6.2.0 ansible-lint once again does not need access to Ansible Galaxy
-# even to get the test suite started, however quite a large fraction of tests
-# fails without network access. Needs more work.
-PROPERTIES="test_network"
-RESTRICT="test"
-
-RDEPEND="
- >=app-admin/ansible-base-2.12.0[${PYTHON_USEDEP}]
- >=dev-python/ansible-compat-2.1.0[${PYTHON_USEDEP}]
- >=dev-python/enrich-1.2.6[${PYTHON_USEDEP}]
- >=dev-python/jsonschema-4.6.0[${PYTHON_USEDEP}]
- dev-python/packaging[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- >=dev-python/rich-9.5.1[${PYTHON_USEDEP}]
- >=dev-python/ruamel-yaml-0.15.37[${PYTHON_USEDEP}]
- >=dev-python/wcmatch-7.0[${PYTHON_USEDEP}]
- >=dev-util/yamllint-1.25.0[${PYTHON_USEDEP}]"
-BDEPEND="
- >=dev-python/setuptools_scm-3.5.0[${PYTHON_USEDEP}]
- >=dev-python/setuptools_scm_git_archive-1.0[${PYTHON_USEDEP}]
- test? (
- >=dev-python/flaky-3.7.0[${PYTHON_USEDEP}]
- >=dev-python/pytest-plus-0.2[${PYTHON_USEDEP}]
- >=dev-python/pytest-xdist-2.5.0[${PYTHON_USEDEP}]
- )"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-6.0.2_test-module-check.patch
-)
-
-# Skip problematic tests (TODO: update this list for ansible-lint-6.2.0+):
-# - test_call_from_outside_venv doesn't play nicely with the sandbox
-# - all test_eco and some test_prerun tests require Internet access
-# - as of 5.4.0, test_cli_auto_detect fails even when run manually with tox
-EPYTEST_DESELECT=(
- test/test_eco.py
- test/test_main.py::test_call_from_outside_venv
- test/test_prerun.py::test_install_collection
- test/test_prerun.py::test_prerun_reqs_v1
- test/test_prerun.py::test_prerun_reqs_v2
- test/test_prerun.py::test_require_collection_wrong_version
- test/test_utils.py::test_cli_auto_detect
-)
-
-distutils_enable_tests pytest
-
-python_test() {
- # As of 6.2.1, without this the test suite still gets confused by the presence of ansible-lint modules
- # in both ${ED} and ${S}.
- cd "${S}" || die
-
- epytest test
-}
diff --git a/app-admin/ansible-lint/files/ansible-lint-6.0.2_test-module-check.patch b/app-admin/ansible-lint/files/ansible-lint-6.0.2_test-module-check.patch
deleted file mode 100644
index 4288bb897c1e..000000000000
--- a/app-admin/ansible-lint/files/ansible-lint-6.0.2_test-module-check.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-Let the package managers handle dependencies, m'kay?
-
---- a/conftest.py
-+++ b/conftest.py
-@@ -3,18 +3,6 @@
- import os
- import sys
-
--# checking if user is running pytest without installing test dependencies:
--missing = []
--for module in ["ansible", "black", "flake8", "flaky", "mypy", "pylint", "pytest_cov"]:
-- if not importlib.util.find_spec(module):
-- missing.append(module)
--if missing:
-- print(
-- f"FATAL: Missing modules: {', '.join(missing)} -- probably you missed installing test requirements with: pip install -e '.[test]'",
-- file=sys.stderr,
-- )
-- sys.exit(1)
--
-
- os.environ["NO_COLOR"] = "1"
- pytest_plugins = ["ansiblelint.testing.fixtures"]
diff --git a/app-admin/ansible-lint/metadata.xml b/app-admin/ansible-lint/metadata.xml
index 094d18cbba43..8ec7574bc4cb 100644
--- a/app-admin/ansible-lint/metadata.xml
+++ b/app-admin/ansible-lint/metadata.xml
@@ -2,10 +2,6 @@
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
- <email>monsieurp@gentoo.org</email>
- <name>Patrice Clement</name>
- </maintainer>
- <maintainer type="person">
<email>marecki@gentoo.org</email>
<name>Marek Szuba</name>
</maintainer>