summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/ansible-molecule')
-rw-r--r--app-admin/ansible-molecule/Manifest2
-rw-r--r--app-admin/ansible-molecule/ansible-molecule-24.2.1.ebuild87
-rw-r--r--app-admin/ansible-molecule/ansible-molecule-3.5.2-r1.ebuild91
-rw-r--r--app-admin/ansible-molecule/files/ansible-molecule-24.2.1-mkdocs_google_fonts.patch10
-rw-r--r--app-admin/ansible-molecule/files/ansible-molecule-3.5.2_pyyaml6.patch11
-rw-r--r--app-admin/ansible-molecule/metadata.xml2
6 files changed, 99 insertions, 104 deletions
diff --git a/app-admin/ansible-molecule/Manifest b/app-admin/ansible-molecule/Manifest
index 700d4ea41538..a9ab839d7c5c 100644
--- a/app-admin/ansible-molecule/Manifest
+++ b/app-admin/ansible-molecule/Manifest
@@ -1 +1 @@
-DIST molecule-3.5.2.tar.gz 290964 BLAKE2B b6c6bb8ecdb4230d23161e25fa003c8979f48fc1705bfba7d14204fbaa3e9c235a71db0c4ccbab5c4328ddb8a0725d3c2ba7cb4b624afda21c6453c8be824f3e SHA512 04a7d1f7e7e098c0ada71d8dc9a3e3a94320033942d8ee03f2c51ec185405d2ee13fcb44000a4942ec66923f0426717ab7e2c3a785ddda7a23515096474dc3c3
+DIST molecule-24.2.1.tar.gz 343228 BLAKE2B 9605b5a8e21d37597cbf35f0f6f811471909dde5496541b1d7cd130eb2b970125fdc291df6493f8716f38514df17d957094604ae49e64d16f2207a0d3682bd38 SHA512 3813163d72cee51987d340c8a1ed0e03d8abe509a601e94c3e32bf673a56edd83d0c2bde1347057fe8a4c2b37e11a068ef689dd669d4395da64bec3921f1403d
diff --git a/app-admin/ansible-molecule/ansible-molecule-24.2.1.ebuild b/app-admin/ansible-molecule/ansible-molecule-24.2.1.ebuild
new file mode 100644
index 000000000000..ab9a79f80bdc
--- /dev/null
+++ b/app-admin/ansible-molecule/ansible-molecule-24.2.1.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+DOCS_BUILDER="mkdocs"
+DOCS_DEPEND="
+ >=dev-python/mkdocs-ansible-24.3.0
+ dev-python/mkdocs-autorefs
+ dev-python/mkdocstrings-python
+ media-gfx/cairosvg
+"
+PYPI_PN="molecule"
+
+inherit distutils-r1 docs optfeature pypi
+
+DESCRIPTION="A toolkit designed to aid in the development and testing of Ansible roles"
+HOMEPAGE="https://pypi.org/project/molecule/ https://github.com/ansible/molecule/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 ~riscv"
+IUSE="selinux"
+
+# Since around the time of the switch to the yy.m.patchlevel versioning scheme
+# the test suite has been completely incompatible with Portage, with several
+# tests which do pass under Tox failing even with disabled sandboxing.
+# Nb. As of 24.2.1 two tests fail even under Tox, for both PyPI and GitHub
+# tarballs.
+RESTRICT="test"
+
+RDEPEND="$(python_gen_cond_dep '
+ >=app-admin/ansible-core-2.12.10[${PYTHON_USEDEP}]
+ >=dev-python/ansible-compat-4.1.8[${PYTHON_USEDEP}]
+ >=dev-python/click-8.0[${PYTHON_USEDEP}]
+ <dev-python/click-9[${PYTHON_USEDEP}]
+ >=dev-python/click-help-colors-0.9[${PYTHON_USEDEP}]
+ >=dev-python/enrich-1.2.7[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.11.3[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-4.9.1[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ <dev-python/pluggy-2.0[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
+ >=dev-python/rich-9.5.1[${PYTHON_USEDEP}]
+ selinux? ( sys-libs/libselinux[python,${PYTHON_USEDEP}] )
+')"
+BDEPEND="$(python_gen_cond_dep '
+ >=dev-python/setuptools-scm-7.0.5[${PYTHON_USEDEP}]
+ doc? (
+ dev-python/pillow[truetype,${PYTHON_USEDEP}]
+ media-fonts/roboto
+ )
+ test? (
+ >=app-admin/ansible-lint-6.12.1[${PYTHON_USEDEP}]
+ app-misc/check-jsonschema[${PYTHON_USEDEP}]
+ >=dev-python/ansi2html-1.8.0[${PYTHON_USEDEP}]
+ >=dev-python/filelock-3.9.0[${PYTHON_USEDEP}]
+ <dev-python/pexpect-5[${PYTHON_USEDEP}]
+ >=dev-python/pytest-mock-3.10.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-plus-0.4.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xdist-3.1.0[${PYTHON_USEDEP}]
+ )
+')"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-24.2.1-mkdocs_google_fonts.patch
+)
+
+# test_role.py doesn't play nicely with FEATURES=usersandbox. As for test_command.py:
+# - quite a few of these tests use the network;
+# - test_command_dependency[shell] only works if Molecule has previously been installed;
+# - tests involving creation of a new scenario fail on ansible-lint errors, even though
+# a config file is deployed which should skip expected issues.
+EPYTEST_DESELECT=(
+ src/molecule/test/functional/test_command.py
+ src/molecule/test/unit/command/init/test_role.py
+)
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature_header "Some optional packages commonly used in Molecule scenarios:"
+ optfeature "checking playbooks for practices and behaviour that can be improved" app-admin/ansible-lint
+}
diff --git a/app-admin/ansible-molecule/ansible-molecule-3.5.2-r1.ebuild b/app-admin/ansible-molecule/ansible-molecule-3.5.2-r1.ebuild
deleted file mode 100644
index 0ccbaea87c20..000000000000
--- a/app-admin/ansible-molecule/ansible-molecule-3.5.2-r1.ebuild
+++ /dev/null
@@ -1,91 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-# TODO: does support py3.10 upstream so add it here as soon as all the dependencies are ready.
-PYTHON_COMPAT=( python3_{8..9} )
-DISTUTILS_SINGLE_IMPL=1
-
-inherit distutils-r1 optfeature
-
-MY_PN="${PN#ansible-}"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="A toolkit designed to aid in the development and testing of Ansible roles"
-HOMEPAGE="https://pypi.org/project/molecule/ https://github.com/ansible-community/molecule/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="selinux"
-
-RDEPEND="$(python_gen_cond_dep '
- >=dev-python/ansible-compat-0.5.0[${PYTHON_USEDEP}]
- <dev-python/cerberus-1.3.3[${PYTHON_USEDEP}]
- >=dev-python/click-8.0[${PYTHON_USEDEP}]
- >=dev-python/click-help-colors-0.9[${PYTHON_USEDEP}]
- >=dev-python/enrich-1.2.5[${PYTHON_USEDEP}]
- >=dev-python/jinja-2.11.3[${PYTHON_USEDEP}]
- dev-python/packaging[${PYTHON_USEDEP}]
- <dev-python/paramiko-3[${PYTHON_USEDEP}]
- <dev-python/pluggy-2.0[${PYTHON_USEDEP}]
- >=dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
- >=dev-python/rich-9.5.1[${PYTHON_USEDEP}]
- >=dev-python/subprocess-tee-0.3.5[${PYTHON_USEDEP}]
- >=dev-util/cookiecutter-1.7.3[${PYTHON_USEDEP}]
- selinux? ( sys-libs/libselinux[python,${PYTHON_USEDEP}] )
-')"
-BDEPEND="$(python_gen_cond_dep '
- >=dev-python/setuptools_scm-3.5.0[${PYTHON_USEDEP}]
- >=dev-python/setuptools_scm_git_archive-1.1[${PYTHON_USEDEP}]
- doc? (
- dev-python/ansible-pygments[${PYTHON_USEDEP}]
- >=dev-python/simplejson-3.17.2[${PYTHON_USEDEP}]
- )
- test? (
- >=dev-python/ansi2html-1.6.0[${PYTHON_USEDEP}]
- <dev-python/pexpect-5[${PYTHON_USEDEP}]
- >=dev-python/pytest-html-3.0.0[${PYTHON_USEDEP}]
- >=dev-python/pytest-mock-3.3.1[${PYTHON_USEDEP}]
- >=dev-python/pytest-plus-0.2[${PYTHON_USEDEP}]
- >=dev-python/pytest-testinfra-6.1.0[${PYTHON_USEDEP}]
- >=dev-python/pytest-xdist-2.1.0[${PYTHON_USEDEP}]
- dev-util/yamllint
- )
-')"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-3.5.2_pyyaml6.patch
-)
-
-S="${WORKDIR}"/${MY_P}
-
-distutils_enable_sphinx docs '>=dev-python/sphinx-notfound-page-0.7.1' '<dev-python/sphinx_ansible_theme-0.9.0'
-distutils_enable_tests --install pytest
-
-src_prepare() {
- default
-
- if ! use selinux; then
- sed -i "/^\s\+selinux/d" setup.cfg || die "Failed to remove dependency on SELinux"
- fi
-
- # Several issues with tests from this file:
- # - quite a few of these use the network;
- # - test_command_dependency[shell] only works if Molecule has previously been installed;
- # - tests involving creation of a new scenario fail on ansible-lint errors, even though
- # a config file is deployed which should skip expected issues.
- rm -f src/molecule/test/functional/test_command.py
-}
-
-python_test() {
- distutils_install_for_testing --via-venv
- distutils-r1_python_test
-}
-
-pkg_postinst() {
- optfeature_header "Some optional packages commonly used in Molecule scenarios:"
- optfeature "checking playbooks for practices and behaviour that can be improved" app-admin/ansible-lint
-}
diff --git a/app-admin/ansible-molecule/files/ansible-molecule-24.2.1-mkdocs_google_fonts.patch b/app-admin/ansible-molecule/files/ansible-molecule-24.2.1-mkdocs_google_fonts.patch
new file mode 100644
index 000000000000..bf8883258f79
--- /dev/null
+++ b/app-admin/ansible-molecule/files/ansible-molecule-24.2.1-mkdocs_google_fonts.patch
@@ -0,0 +1,10 @@
+--- a/mkdocs.yml
++++ b/mkdocs.yml
+@@ -9,6 +9,7 @@
+
+ theme:
+ name: ansible
++ font: false
+ features:
+ - announce.dismiss
+ - content.action.edit
diff --git a/app-admin/ansible-molecule/files/ansible-molecule-3.5.2_pyyaml6.patch b/app-admin/ansible-molecule/files/ansible-molecule-3.5.2_pyyaml6.patch
deleted file mode 100644
index 80a7d8b7a87d..000000000000
--- a/app-admin/ansible-molecule/files/ansible-molecule-3.5.2_pyyaml6.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/setup.cfg
-+++ b/setup.cfg
-@@ -74,7 +74,7 @@
- packaging
- paramiko >= 2.5.0, < 3
- pluggy >= 0.7.1, < 2.0
-- PyYAML >= 5.1, < 6
-+ PyYAML >= 5.1
- rich >= 9.5.1
- subprocess-tee >= 0.3.5
- selinux; sys_platform=="linux2"
diff --git a/app-admin/ansible-molecule/metadata.xml b/app-admin/ansible-molecule/metadata.xml
index dff0e96953cf..fb47216c4e5e 100644
--- a/app-admin/ansible-molecule/metadata.xml
+++ b/app-admin/ansible-molecule/metadata.xml
@@ -8,6 +8,6 @@
<stabilize-allarches/>
<upstream>
<remote-id type="pypi">molecule</remote-id>
- <remote-id type="github">ansible-community/molecule</remote-id>
+ <remote-id type="github">ansible/molecule</remote-id>
</upstream>
</pkgmetadata>