summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/ansible')
-rw-r--r--app-admin/ansible/Manifest7
-rw-r--r--app-admin/ansible/ansible-2.10.7.ebuild61
-rw-r--r--app-admin/ansible/ansible-2.11.1.ebuild62
-rw-r--r--app-admin/ansible/ansible-7.7.0.ebuild28
-rw-r--r--app-admin/ansible/ansible-8.7.0.ebuild28
-rw-r--r--app-admin/ansible/ansible-9.1.0.ebuild29
-rw-r--r--app-admin/ansible/ansible-9.3.0.ebuild29
-rw-r--r--app-admin/ansible/ansible-9.4.0.ebuild29
-rw-r--r--app-admin/ansible/ansible-9999.ebuild62
-rw-r--r--app-admin/ansible/metadata.xml12
10 files changed, 152 insertions, 195 deletions
diff --git a/app-admin/ansible/Manifest b/app-admin/ansible/Manifest
index 393d4983539b..28e77d767d29 100644
--- a/app-admin/ansible/Manifest
+++ b/app-admin/ansible/Manifest
@@ -1,2 +1,5 @@
-DIST ansible-2.10.7.tar.gz 29862966 BLAKE2B fa86deaac034adc8e02f91cbf4b63ca718d50376cab19e156c85f8372c1787275e2ce24840fc3cbad2b9191146c785feafcf024a0c14052ee39a839390cc1319 SHA512 7a6522bcc57c178c9c6e87e313f6f175d5c74ac0d1b9dd0cad5506c7fa0efb16d4a627dc2d9c73f988177544bd9ccfdbec162d0feacc757edeb20280d7414191
-DIST ansible-core-2.11.1.tar.gz 6148111 BLAKE2B 46b1553542adbebfb0b0756be99a81d20cce2978a59766c65632b40413a851ad3c9de12df67959c0557584c5209ecd4f3c94381ae0a1e6987bd3cfb237de5a85 SHA512 1362754dde0a88ca8f6323d87cc6f4bf5f93b189b8d45fcb435d3fb289c359da128e7688a92107ade2c54828d4c4deb3ded9e01e18d19c503306924aa189a381
+DIST ansible-7.7.0.tar.gz 40709642 BLAKE2B ee2f8d124f79ca3a3f131bfbc4f93e10d104a38262b7d60edd2a88284275fecdd3acf0e566a5cc81a1fb6a179a0b7c51215f2945d669be4c6af7aa2a4f31ade0 SHA512 7da6845c9a68f2b8c10cf3e4cc6ea347861d5b59daa6ac895731ac79b733c6724d234345054fe9e3bf4ea460345b9026492fda42dce22bfbc027c9b4de093fd9
+DIST ansible-8.7.0.tar.gz 49317896 BLAKE2B d5923753e368e908a569c5f8f261b1afe7c51d5381db190bf7de1e81f0a6359136581852faa2974f174e816944c66e2c0f625d3d62bdde324758309982c90de9 SHA512 6a67f8553c3fa56559e4a31ec627cfe2c5f42e147d94bea305ec4580af9ba8add136092b209a5a3d7f9022407e9d557484f044d23cb227973fe4e4341fed7983
+DIST ansible-9.1.0.tar.gz 48839908 BLAKE2B caa652b339fb93334bff7246d1bab6bbdd9672a096637aa0695cd94a7f50d0e5ca7a1bfeb559792833c97eb9d16486965776b609354dc05ca63b1474d43e767b SHA512 ec6d86b3d05e66053001720b6b7d7bd1dba8bd50917c913e1f08a63b0c94f76a5d69732c78e793d038622a0b8c652860290a89cee1dfb22491a81763923ef843
+DIST ansible-9.3.0.tar.gz 38240168 BLAKE2B 0cd243a21b12163fcb37f014a69f6041f9c48dae84d1aeea342713daf8150246efa14ac94f43890e449896d111f1839ebe2dba7d9c48c2359fb01e4aadfd270b SHA512 71eff05455aee0a013b69790145a73325ac7037fc509545a7cdca358aa54c1731f7dc6fb0169f602d668e9da9e41a0879ff48ba1243d372e02dae9382ac46c5c
+DIST ansible-9.4.0.tar.gz 38389836 BLAKE2B a2e08088565e6f248c1185ee96ac2365fc1385993d3f3fe68f941e8acb0e567c3defeec3ea376a30213921f02881bce0a0ac737323fc3ec82dc77d2d4a550dbd SHA512 4c75235a866f3f95cda8dd3b6c9d22b916ad117d54a86a30585f71c9015cd98db764afa225af5b2f6fa884af558ee488785e26c9e8b9e8be105062f069f065b2
diff --git a/app-admin/ansible/ansible-2.10.7.ebuild b/app-admin/ansible/ansible-2.10.7.ebuild
deleted file mode 100644
index c5e15d422cab..000000000000
--- a/app-admin/ansible/ansible-2.10.7.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-DISTUTILS_USE_SETUPTOOLS=bdepend
-
-inherit distutils-r1
-
-DESCRIPTION="Model-driven deployment, config management, and command execution framework"
-HOMEPAGE="https://ansible.com/"
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/ansible/ansible.git"
- EGIT_BRANCH="devel"
-else
- SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
- KEYWORDS="amd64 ~arm ~arm64 ~ppc64 x86 ~x64-macos"
-fi
-
-LICENSE="GPL-3"
-SLOT="0"
-IUSE="test"
-RESTRICT="test"
-
-RDEPEND="
- dev-python/paramiko[${PYTHON_USEDEP}]
- dev-python/jinja[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/cryptography[${PYTHON_USEDEP}]
- dev-python/httplib2[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- dev-python/netaddr[${PYTHON_USEDEP}]
- dev-python/pexpect[${PYTHON_USEDEP}]
- net-misc/sshpass
- virtual/ssh
- app-admin/ansible-base
-"
-DEPEND="
- >=dev-python/packaging-16.6[${PYTHON_USEDEP}]
- app-admin/ansible-base
- test? (
- ${RDEPEND}
- dev-python/nose[${PYTHON_USEDEP}]
- >=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
- dev-python/passlib[${PYTHON_USEDEP}]
- dev-python/coverage[${PYTHON_USEDEP}]
- dev-python/unittest2[${PYTHON_USEDEP}]
- dev-vcs/git
- )"
-
-python_compile() {
- export ANSIBLE_SKIP_CONFLICT_CHECK=1
- distutils-r1_python_compile
-}
-
-python_test() {
- nosetests -d -w test/units -v --with-coverage --cover-package=ansible --cover-branches || die
-}
diff --git a/app-admin/ansible/ansible-2.11.1.ebuild b/app-admin/ansible/ansible-2.11.1.ebuild
deleted file mode 100644
index 1925abcf423d..000000000000
--- a/app-admin/ansible/ansible-2.11.1.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-DISTUTILS_USE_SETUPTOOLS=bdepend
-
-inherit distutils-r1
-
-DESCRIPTION="Model-driven deployment, config management, and command execution framework"
-HOMEPAGE="https://ansible.com/"
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/ansible/ansible.git"
- EGIT_BRANCH="devel"
-else
- SRC_URI="mirror://pypi/${PN:0:1}/${PN}-core/${PN}-core-${PV}.tar.gz"
- KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~x64-macos"
-fi
-S="${WORKDIR}/${PN}-core-${PV}"
-
-LICENSE="GPL-3"
-SLOT="0"
-IUSE="test"
-RESTRICT="test"
-
-RDEPEND="
- dev-python/paramiko[${PYTHON_USEDEP}]
- dev-python/jinja[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/cryptography[${PYTHON_USEDEP}]
- dev-python/httplib2[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- dev-python/netaddr[${PYTHON_USEDEP}]
- dev-python/pexpect[${PYTHON_USEDEP}]
- net-misc/sshpass
- virtual/ssh
- !app-admin/ansible-base
-"
-DEPEND="
- !app-admin/ansible-base
- >=dev-python/packaging-16.6[${PYTHON_USEDEP}]
- test? (
- ${RDEPEND}
- dev-python/nose[${PYTHON_USEDEP}]
- >=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
- dev-python/passlib[${PYTHON_USEDEP}]
- dev-python/coverage[${PYTHON_USEDEP}]
- dev-python/unittest2[${PYTHON_USEDEP}]
- dev-vcs/git
- )"
-
-python_compile() {
- export ANSIBLE_SKIP_CONFLICT_CHECK=1
- distutils-r1_python_compile
-}
-
-python_test() {
- nosetests -d -w test/units -v --with-coverage --cover-package=ansible --cover-branches || die
-}
diff --git a/app-admin/ansible/ansible-7.7.0.ebuild b/app-admin/ansible/ansible-7.7.0.ebuild
new file mode 100644
index 000000000000..0cefb7045e40
--- /dev/null
+++ b/app-admin/ansible/ansible-7.7.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Model-driven deployment, config management, and command execution framework"
+HOMEPAGE="https://www.ansible.com/"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="amd64 ~arm arm64 ~ppc64 ~riscv x86 ~x64-macos"
+RESTRICT="test"
+
+RDEPEND=">=app-admin/ansible-core-2.14.0
+ <app-admin/ansible-core-2.15"
+
+python_compile() {
+ local -x ANSIBLE_SKIP_CONFLICT_CHECK=1
+ distutils-r1_python_compile
+}
+python_install() {
+ local -x ANSIBLE_SKIP_CONFLICT_CHECK=1
+ distutils-r1_python_install
+}
diff --git a/app-admin/ansible/ansible-8.7.0.ebuild b/app-admin/ansible/ansible-8.7.0.ebuild
new file mode 100644
index 000000000000..5116f9b3eeac
--- /dev/null
+++ b/app-admin/ansible/ansible-8.7.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Model-driven deployment, config management, and command execution framework"
+HOMEPAGE="https://www.ansible.com/"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="amd64 ~arm arm64 ~ppc64 ~riscv x86 ~x64-macos"
+RESTRICT="test"
+
+RDEPEND=">=app-admin/ansible-core-2.15.0
+ <app-admin/ansible-core-2.16"
+
+python_compile() {
+ local -x ANSIBLE_SKIP_CONFLICT_CHECK=1
+ distutils-r1_python_compile
+}
+python_install() {
+ local -x ANSIBLE_SKIP_CONFLICT_CHECK=1
+ distutils-r1_python_install
+}
diff --git a/app-admin/ansible/ansible-9.1.0.ebuild b/app-admin/ansible/ansible-9.1.0.ebuild
new file mode 100644
index 000000000000..09a9b1e9bd54
--- /dev/null
+++ b/app-admin/ansible/ansible-9.1.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+DISTUTILS_USE_PEP517=setuptools
+
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Model-driven deployment, config management, and command execution framework"
+HOMEPAGE="https://www.ansible.com/"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="amd64 ~arm arm64 ~ppc64 ~riscv x86 ~x64-macos"
+RESTRICT="test"
+
+RDEPEND=">=app-admin/ansible-core-2.16.0
+ <app-admin/ansible-core-2.17"
+
+python_compile() {
+ local -x ANSIBLE_SKIP_CONFLICT_CHECK=1
+ distutils-r1_python_compile
+}
+python_install() {
+ local -x ANSIBLE_SKIP_CONFLICT_CHECK=1
+ distutils-r1_python_install
+}
diff --git a/app-admin/ansible/ansible-9.3.0.ebuild b/app-admin/ansible/ansible-9.3.0.ebuild
new file mode 100644
index 000000000000..51baea072b8f
--- /dev/null
+++ b/app-admin/ansible/ansible-9.3.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+DISTUTILS_USE_PEP517=setuptools
+
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Model-driven deployment, config management, and command execution framework"
+HOMEPAGE="https://www.ansible.com/"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="amd64 ~arm arm64 ~ppc64 ~riscv x86 ~x64-macos"
+RESTRICT="test"
+
+RDEPEND=">=app-admin/ansible-core-2.16.0
+ <app-admin/ansible-core-2.17"
+
+python_compile() {
+ local -x ANSIBLE_SKIP_CONFLICT_CHECK=1
+ distutils-r1_python_compile
+}
+python_install() {
+ local -x ANSIBLE_SKIP_CONFLICT_CHECK=1
+ distutils-r1_python_install
+}
diff --git a/app-admin/ansible/ansible-9.4.0.ebuild b/app-admin/ansible/ansible-9.4.0.ebuild
new file mode 100644
index 000000000000..51baea072b8f
--- /dev/null
+++ b/app-admin/ansible/ansible-9.4.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+DISTUTILS_USE_PEP517=setuptools
+
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Model-driven deployment, config management, and command execution framework"
+HOMEPAGE="https://www.ansible.com/"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="amd64 ~arm arm64 ~ppc64 ~riscv x86 ~x64-macos"
+RESTRICT="test"
+
+RDEPEND=">=app-admin/ansible-core-2.16.0
+ <app-admin/ansible-core-2.17"
+
+python_compile() {
+ local -x ANSIBLE_SKIP_CONFLICT_CHECK=1
+ distutils-r1_python_compile
+}
+python_install() {
+ local -x ANSIBLE_SKIP_CONFLICT_CHECK=1
+ distutils-r1_python_install
+}
diff --git a/app-admin/ansible/ansible-9999.ebuild b/app-admin/ansible/ansible-9999.ebuild
deleted file mode 100644
index 1925abcf423d..000000000000
--- a/app-admin/ansible/ansible-9999.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-DISTUTILS_USE_SETUPTOOLS=bdepend
-
-inherit distutils-r1
-
-DESCRIPTION="Model-driven deployment, config management, and command execution framework"
-HOMEPAGE="https://ansible.com/"
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/ansible/ansible.git"
- EGIT_BRANCH="devel"
-else
- SRC_URI="mirror://pypi/${PN:0:1}/${PN}-core/${PN}-core-${PV}.tar.gz"
- KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~x64-macos"
-fi
-S="${WORKDIR}/${PN}-core-${PV}"
-
-LICENSE="GPL-3"
-SLOT="0"
-IUSE="test"
-RESTRICT="test"
-
-RDEPEND="
- dev-python/paramiko[${PYTHON_USEDEP}]
- dev-python/jinja[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/cryptography[${PYTHON_USEDEP}]
- dev-python/httplib2[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- dev-python/netaddr[${PYTHON_USEDEP}]
- dev-python/pexpect[${PYTHON_USEDEP}]
- net-misc/sshpass
- virtual/ssh
- !app-admin/ansible-base
-"
-DEPEND="
- !app-admin/ansible-base
- >=dev-python/packaging-16.6[${PYTHON_USEDEP}]
- test? (
- ${RDEPEND}
- dev-python/nose[${PYTHON_USEDEP}]
- >=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
- dev-python/passlib[${PYTHON_USEDEP}]
- dev-python/coverage[${PYTHON_USEDEP}]
- dev-python/unittest2[${PYTHON_USEDEP}]
- dev-vcs/git
- )"
-
-python_compile() {
- export ANSIBLE_SKIP_CONFLICT_CHECK=1
- distutils-r1_python_compile
-}
-
-python_test() {
- nosetests -d -w test/units -v --with-coverage --cover-package=ansible --cover-branches || die
-}
diff --git a/app-admin/ansible/metadata.xml b/app-admin/ansible/metadata.xml
index a8f9be939d94..32affbcfbda2 100644
--- a/app-admin/ansible/metadata.xml
+++ b/app-admin/ansible/metadata.xml
@@ -1,21 +1,17 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>prometheanfire@gentoo.org</email>
<name>Matthew Thode</name>
</maintainer>
- <maintainer type="person">
- <email>monsieurp@gentoo.org</email>
- <name>Patrice Clement</name>
- </maintainer>
<upstream>
<remote-id type="pypi">ansible</remote-id>
<remote-id type="github">ansible/ansible</remote-id>
<bugs-to>https://github.com/ansible/ansible/issues</bugs-to>
</upstream>
<longdescription lang="en">
-Radically simple deployment, model-driven configuration management, and
-command execution framework.
-</longdescription>
+ Radically simple deployment, model-driven configuration management, and
+ command execution framework.
+ </longdescription>
</pkgmetadata>