summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/apache-tools/files')
-rw-r--r--app-admin/apache-tools/files/apache-tools-2.4.54-Makefile.patch37
-rw-r--r--app-admin/apache-tools/files/apache-tools-2.4.54-libtool.patch21
-rw-r--r--app-admin/apache-tools/files/apache-tools-2.4.54-no-which.patch54
-rw-r--r--app-admin/apache-tools/files/apache-tools-2.4.7-Makefile.patch47
4 files changed, 112 insertions, 47 deletions
diff --git a/app-admin/apache-tools/files/apache-tools-2.4.54-Makefile.patch b/app-admin/apache-tools/files/apache-tools-2.4.54-Makefile.patch
new file mode 100644
index 000000000000..882e97a1c26e
--- /dev/null
+++ b/app-admin/apache-tools/files/apache-tools-2.4.54-Makefile.patch
@@ -0,0 +1,37 @@
+Bug: https://bugs.gentoo.org/459446
+
+From: orbea <orbea@riseup.net>
+Date: Tue, 19 Jul 2022 10:42:26 -0700
+Subject: [PATCH] support: Install fewer programs
+
+--- a/support/Makefile.in
++++ b/support/Makefile.in
+@@ -14,27 +14,12 @@ include $(top_builddir)/build/rules.mk
+
+ install:
+ @test -d $(DESTDIR)$(bindir) || $(MKINSTALLDIRS) $(DESTDIR)$(bindir)
+- @test -d $(DESTDIR)$(sbindir) || $(MKINSTALLDIRS) $(DESTDIR)$(sbindir)
+- @test -d $(DESTDIR)$(libexecdir) || $(MKINSTALLDIRS) $(DESTDIR)$(libexecdir)
+- @cp -p $(top_builddir)/server/httpd.exp $(DESTDIR)$(libexecdir)
+- @for i in apxs dbmmanage; do \
++ @for i in dbmmanage; do \
+ if test -f "$(builddir)/$$i"; then \
+ cp -p $$i $(DESTDIR)$(bindir); \
+ chmod 755 $(DESTDIR)$(bindir)/$$i; \
+ fi ; \
+ done
+- @for i in apachectl; do \
+- if test -f "$(builddir)/$$i"; then \
+- cp -p $$i $(DESTDIR)$(sbindir); \
+- chmod 755 $(DESTDIR)$(sbindir)/$$i; \
+- fi ; \
+- done
+- @if test -f "$(builddir)/envvars-std"; then \
+- cp -p envvars-std $(DESTDIR)$(sbindir); \
+- if test ! -f $(DESTDIR)$(sbindir)/envvars; then \
+- cp -p envvars-std $(DESTDIR)$(sbindir)/envvars ; \
+- fi ; \
+- fi
+
+ htpasswd.lo: passwd_common.h
+ passwd_common.lo: passwd_common.h
diff --git a/app-admin/apache-tools/files/apache-tools-2.4.54-libtool.patch b/app-admin/apache-tools/files/apache-tools-2.4.54-libtool.patch
new file mode 100644
index 000000000000..9cd957c21499
--- /dev/null
+++ b/app-admin/apache-tools/files/apache-tools-2.4.54-libtool.patch
@@ -0,0 +1,21 @@
+Bug: https://bugs.gentoo.org/858833
+
+From: orbea <orbea@riseup.net>
+Date: Tue, 19 Jul 2022 07:46:36 -0700
+Subject: [PATCH] build: Fix the build with slibtool
+
+Adding LT_INIT to configure.in generates the libtool script in the build
+directory which is required by rlibtool to determine if the build is
+shared or static.
+
+--- a/configure.in
++++ b/configure.in
+@@ -398,7 +398,7 @@ AC_PATH_PROG(RSYNC, rsync)
+ AC_PATH_PROG(SVN, svn)
+ AC_PROG_AWK
+ AC_PROG_LN_S
+-AC_CHECK_TOOL(RANLIB, ranlib, true)
++LT_INIT
+ dnl AC_PATH_PROG(PERL_PATH, perl)
+ AC_CHECK_PROGS(LYNX_PATH,[lynx links elinks], [lynx])
+
diff --git a/app-admin/apache-tools/files/apache-tools-2.4.54-no-which.patch b/app-admin/apache-tools/files/apache-tools-2.4.54-no-which.patch
new file mode 100644
index 000000000000..65764dfe022a
--- /dev/null
+++ b/app-admin/apache-tools/files/apache-tools-2.4.54-no-which.patch
@@ -0,0 +1,54 @@
+https://bugs.gentoo.org/844868
+https://bz.apache.org/bugzilla/show_bug.cgi?id=66130
+--- a/build/aix/buildaix.ksh
++++ b/build/aix/buildaix.ksh
+@@ -26,14 +26,14 @@ export CFLAGS='-O2 -qlanglvl=extc99'
+ lslpp -L bos.adt.insttools >/dev/null
+ [[ $? -ne 0 ]] && echo "must have bos.adt.insttools installed" && exit -1
+
+-apr_config=`which apr-1-config`
+-apu_config=`which apu-1-config`
++apr_config=`command -v apr-1-config 2>/dev/null`
++apu_config=`command -v apu-1-config 2>/dev/null`
+
+ if [[ -z ${apr_config} && -z ${apu_config} ]]
+ then
+ export PATH=/opt/bin:${PATH}
+- apr_config=`which apr-1-config`
+- apu_config=`which apu-1-config`
++ apr_config=`command -v apr-1-config 2>/dev/null`
++ apu_config=`command -v apu-1-config 2>/dev/null`
+ fi
+
+ while test $# -gt 0
+--- a/build/pkg/buildpkg.sh
++++ b/build/pkg/buildpkg.sh
+@@ -24,8 +24,8 @@ PREFIX=/usr/local/apache2
+ TEMPDIR=/var/tmp/$USER/httpd-root
+ rm -rf $TEMPDIR
+
+-apr_config=`which apr-1-config`
+-apu_config=`which apu-1-config`
++apr_config=`command -v apr-1-config 2>/dev/null`
++apu_config=`command -v apu-1-config 2>/dev/null`
+
+ while test $# -gt 0
+ do
+--- a/configure.in
++++ b/configure.in
+@@ -216,13 +216,13 @@ AC_ARG_WITH(pcre,
+ APACHE_HELP_STRING(--with-pcre=PATH,Use external PCRE library))
+ if test "x$with_pcre" = "x" || test "$with_pcre" = "yes"; then
+ with_pcre="$PATH"
+-else if which $with_pcre 2>/dev/null; then :; else
++else if command -v $with_pcre 2>/dev/null; then :; else
+ with_pcre="$with_pcre/bin:$with_pcre"
+ fi
+ fi
+
+ AC_CHECK_TARGET_TOOLS(PCRE_CONFIG, [pcre2-config pcre-config],
+- [`which $with_pcre 2>/dev/null`], $with_pcre)
++ [`command -v $with_pcre 2>/dev/null`], $with_pcre)
+
+ if test "x$PCRE_CONFIG" != "x"; then
+ if $PCRE_CONFIG --version >/dev/null 2>&1; then :; else
diff --git a/app-admin/apache-tools/files/apache-tools-2.4.7-Makefile.patch b/app-admin/apache-tools/files/apache-tools-2.4.7-Makefile.patch
deleted file mode 100644
index b7d3c274ea48..000000000000
--- a/app-admin/apache-tools/files/apache-tools-2.4.7-Makefile.patch
+++ /dev/null
@@ -1,47 +0,0 @@
-https://bugs.gentoo.org/459446
-
-https://raw.github.com/archlinuxcn/repo/master/apache-tools/apache-tools-Makefile.patch
-
---- a/support/Makefile.in
-+++ b/support/Makefile.in
-@@ -1,9 +1,9 @@
- DISTCLEAN_TARGETS = apxs apachectl dbmmanage log_server_status \
-- logresolve.pl phf_abuse_log.cgi split-logfile envvars-std
-+ logresolve.pl phf_abuse_log.cgi split-logfile
-
- CLEAN_TARGETS = suexec
-
--bin_PROGRAMS = htpasswd htdigest htdbm ab logresolve httxt2dbm
-+bin_PROGRAMS = htpasswd htdigest htdbm ab logresolve httxt2dbm dbmmanage
- sbin_PROGRAMS = htcacheclean rotatelogs $(NONPORTABLE_SUPPORT)
- TARGETS = $(bin_PROGRAMS) $(sbin_PROGRAMS)
-
-@@ -15,26 +15,18 @@
- install:
- @test -d $(DESTDIR)$(bindir) || $(MKINSTALLDIRS) $(DESTDIR)$(bindir)
- @test -d $(DESTDIR)$(sbindir) || $(MKINSTALLDIRS) $(DESTDIR)$(sbindir)
-- @test -d $(DESTDIR)$(libexecdir) || $(MKINSTALLDIRS) $(DESTDIR)$(libexecdir)
-- @cp -p $(top_builddir)/server/httpd.exp $(DESTDIR)$(libexecdir)
-- @for i in apxs dbmmanage; do \
-+ @for i in $(bin_PROGRAMS); do \
- if test -f "$(builddir)/$$i"; then \
- cp -p $$i $(DESTDIR)$(bindir); \
- chmod 755 $(DESTDIR)$(bindir)/$$i; \
- fi ; \
- done
-- @for i in apachectl; do \
-+ @for i in $(sbin_PROGRAMS); do \
- if test -f "$(builddir)/$$i"; then \
- cp -p $$i $(DESTDIR)$(sbindir); \
- chmod 755 $(DESTDIR)$(sbindir)/$$i; \
- fi ; \
- done
-- @if test -f "$(builddir)/envvars-std"; then \
-- cp -p envvars-std $(DESTDIR)$(sbindir); \
-- if test ! -f $(DESTDIR)$(sbindir)/envvars; then \
-- cp -p envvars-std $(DESTDIR)$(sbindir)/envvars ; \
-- fi ; \
-- fi
-
- htpasswd.lo: passwd_common.h
- passwd_common.lo: passwd_common.h